CSU 1216异或最大值

Description

给定一些数,求这些数中两个数的异或值最大的那个值

Input

多组数据。第一行为数字个数n,1 <= n <= 10 ^ 5。接下来n行每行一个32位有符号非负整数。

Output

任意两数最大异或值

Sample Input

3
3
7
9

Sample Output

14

Hint
Source
CSGrandeur的数据结构习题

异或

异或运算符(^ 也叫xor(以后做题会遇到xor,就是异或))
规则:0^0 = 0,0^1=1,1^0=1,1^1=0 参加位运算的两位只要相同为0,不同为1
例子:3^5 = 6(00000011^00000101=00000110)

暴力(不用说)

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
const int maxN = 1e5 + 7;

int a[maxN];

int main() {
    int n;
    scanf("%d",&n);
    for(int i = 1;i <= n;++ i) {
        scanf("%d",a[i]);
    }
    int maxn = 0;
    for(int i = 1;i < n;++ i) {
        for(int j = i + 1;j <= n;++ j) {
            maxn = max(maxn,a[i] xor a[j]);
        }
    }
    printf("%d",maxn);
}

正解:我们可以发现异或的一些性质,不同为1,根据等比数列求和,
等比数列求和

$2^1 + 2^2 + 2^3 + 2^4 < 2^5 $
证明: 设$2^1 + 2^2 + 2^3 + 2^4$为S,那么$2S = 2^2 + 2^3 + 2^4 + 2^5 - S$;
等于$2^5 - 1 < 2^5 $
为什么要涉及到这个呢,因为我们要贪心的选取,一定要看看有没有特殊情况.
我们从高位开始选择与其不同的二进制位.就Ok了.

code

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define ll long long
using namespace std;
const int maxN = 1e5 + 7;

int a[maxN];
int son[maxN * 20][3],cnt;

void init() {
    memset(son,0,sizeof(son));
    cnt = 0;
    return;
}
void build(ll a) {
    int now = 0;
    for(int i = 32;i >= 0;-- i) {
        int qwq = (a >> i & 1);
        if( !son[now][qwq] )son[now][qwq] = ++ cnt;
        now = son[now][qwq];
    }
}

ll find(ll a) {
    ll res = 0,now = 0;
    for(int i = 32;i >= 0;-- i) {
        bool tmp = ((a >> i & 1) ^ 1);
        if(son[now][tmp]) now = son[now][tmp],res = res | (1LL << i);
        else now = son[now][tmp ^ 1];
    }
    return res;
}

int main() {
    int n;
    while(~scanf("%d", &n)) {
        init();
        for(int i = 1;i <= n;++ i)
            scanf("%d",&a[i]);
        for(int i = 1;i <= n;++ i)
            build(a[i]);
        ll Ans = 0;
        for(int i = 1;i <= n;++ i) {
            Ans = max(Ans,find(a[i]));
        }
        printf("%lld\n",Ans);//一定要注意:换行!!!!
    }
}

原文地址:https://www.cnblogs.com/tpgzy/p/9320497.html

时间: 2024-10-07 06:33:18

CSU 1216异或最大值的相关文章

CSU 1216 异或最大值

[题意] 给定序列q[1..n],求任意两数异或的最大值 数据范围:1<=n<=10^5,q[i]为32位非负整数 [分析]Trie用来从高到低保存0和1,然后爆搜:尽可能凑1,不然凑0 [代码] WOC为什么是多组数据? #include <cstdio> #include <cstring> #include <cstdlib> using namespace std; const int K=32; const int L=3300000; typed

中南大学COJ 1216: 异或最大值(数据结构)

中南大学COJ 1216: 异或最大值(数据结构) ACM 题目地址:COJ 1216 题意: 中文题,注意是多组样例. 分析: 用01Trie做的. 代码: /* * Author: illuz <iilluzen[at]gmail.com> * File: coj1216.cpp * Create Date: 2014-07-27 14:18:44 * Descripton: trie */ #include <cstdio> #include <cstring>

异或最大值

1.1216: 异或最大值 http://acm.csu.edu.cn/csuoj/problemset/problem?pid=1216 Time Limit: 2 Sec Memory Limit: 128 Mb Description 给定一些数,求这些数中两个数的异或值最大的那个值 Input 多组数据.第一行为数字个数n,1 <= n <= 10 ^ 5.接下来n行每行一个32位有符号非负整数. Output 任意两数最大异或值 Sample Input 3 3 7 9 Sample

异或最大值(01字典树)

/** 异或最大值(01字典树) 题意:求n个非负数中任意2个的异或值的最大值.n数量级为10^5 分析:直接暴力肯定超时了.一个非负整数可以看成1个32位的01字符串,n个数可以看成n个字符串,因此可以建立字典树, 建好树后,对于任意非负整数x,可以沿着树根往下贪心找到y,使得x异或y最大,复杂度为树的深度. */ #include <stdio.h> #include <string.h> #include <algorithm> #include <iost

Poj The xor-longest Path 经典题 Trie求n个数中任意两个异或最大值

Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 5646   Accepted: 1226 Description In an edge-weighted tree, the xor-length of a path p is defined as the xor sum of the weights of edges on p: ⊕ is the xor operator. We say a path the xor-l

CSU 1258 异或运算的线段树

题目大意:在给定区间内对每个数的最后一个二进制为1的位将其修改为0,如果数本身已经为0了,就不做改变 输出给定区间的所有数的异或值 1 #include <cstdio> 2 #include <cstring> 3 using namespace std; 4 #define N 10005 5 #define L ls,x,mid 6 #define R rs,mid+1,y 7 int sum[N<<2],cnt[N<<2],num[N]; 8 9 v

bzoj3261: 最大异或和 可持久化trie

题意:给定一个非负整数序列{a},初始长度为N. 有M个操作,有以下两种操作类型: 1.Ax:添加操作,表示在序列末尾添加一个数x,序列的长度N+1. 2.Qlrx:询问操作,你需要找到一个位置p,满足l<=p<=r,使得: a[p] xor a[p+1] xor ... xor a[N] xor x 最大,输出最大是多少. 题解:可持久化trie 用前缀异或来建树,查询就变成了last^x和l到r中a[p]异或最大值是多少 先插入一个0,然后像可持久化线段树那样建树即可,还是挺简单的 /**

[十二省联考2019]异或粽子 (可持久化01tire 堆)

/* 查询异或最大值的方法是前缀和一下, 在01trie上二分 那么我们可以对于n个位置每个地方先求出最大的数, 然后把n个信息扔到堆里, 当我们拿出某个位置的信息时, 将他去除当前最大后最大的信息插入到堆中 所以动态维护01trie就可以了 */ #include<cstdio> #include<cstring> #include<algorithm> #include<iostream> #include<queue> #define mm

[luogu] P4551 最长异或路径(贪心)

P4551 最长异或路径 题目描述 给定一棵\(n\)个点的带权树,结点下标从\(1\)开始到\(N\).寻找树中找两个结点,求最长的异或路径. 异或路径指的是指两个结点之间唯一路径上的所有边权的异或. 输入输出格式 输入格式: 第一行一个整数\(N\),表示点数. 接下来 \(n-1\) 行,给出 \(u,v,w\) ,分别表示树上的 \(u\) 点和 \(v\) 点有连边,边的权值是 \(w\). 输出格式: 一行,一个整数表示答案. 输入输出样例 输入样例#1: 复制 4 1 2 3 2