PAT 1137 Final Grading

For a student taking the online course "Data Structures" on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G=(G?mid?term×40%+Gfinal×60%) if Gmid?term>G?final, or Gfinal will be taken as the final grade G. Here Gmid?term and Gfinal are the student‘s scores of the mid-term and the final exams, respectively.

The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

Input Specification:
Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.

Then three blocks follow. The first block contains P online programming scores Gp ‘s; the second one contains M mid-term scores Gmid?term‘s; and the last one contains N final exam scores Gfinal ‘s. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

***Output Specification:
For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:

StudentID G?p Gmid?term Gfinal G

If some score does not exist, output "?1" instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID‘s. It is guaranteed that the StudentID‘s are all distinct, and there is at least one qullified student.

Sample Input:

6 6 7
01234 880
a1903 199
ydjh2 200
wehu8 300
dx86w 220
missing 400
ydhfu77 99
wehu8 55
ydjh2 98
dx86w 88
a1903 86
01234 39
ydhfu77 88
a1903 66
01234 58
wehu8 84
ydjh2 82
missing 99
dx86w 81

Sample Output:

missing 400 -1 99 99
ydjh2 200 98 82 88
dx86w 220 88 81 84
wehu8 300 55 84 84

#include<iostream> //海星
#include<map>
#include<algorithm>
#include<vector>
#include<math.h>
using namespace std;
struct node{
    string name;
    int Gp, Gm, Gf, G;
};
bool cmp(node n1, node n2){
    return (n1.G==n2.G?n1.name<n2.name:n1.G>n2.G);
}
int main(){
    map<string, int> index;
    vector<node> rank;
    string id;
    int p, m, n, cnt=1, s;
    cin>>p>>m>>n;
    for(int i=0; i<p; i++){
        cin>>id>>s;
        if(s>=200){
            rank.push_back(node{id, s, -1, -1});
            index[id]=cnt++;
        }
    }
    for(int i=0; i<m; i++){
        cin>>id>>s;
        if(index[id]!=0)
            rank[index[id]-1].Gm=s;
    }
    for(int i=0; i<n; i++){
        cin>>id>>s;
        if(index[id]!=0){
            rank[index[id]-1].Gf=s;
            if(s>=rank[index[id]-1].Gm)
                rank[index[id]-1].G=s;
            else
                rank[index[id]-1].G=round(0.4*rank[index[id]-1].Gm+0.6*s);
        }
    }
    sort(rank.begin(), rank.end(), cmp);
    for(int i=0; i<rank.size(); i++)
        if(rank[i].G>=60)
            cout<<rank[i].name<<" "<<rank[i].Gp<<" "<<rank[i].Gm<<" "<<rank[i].Gf<<" "<<rank[i].G<<endl;
    return 0;
} 

原文地址:https://www.cnblogs.com/A-Little-Nut/p/9651966.html

时间: 2024-08-30 17:39:52

PAT 1137 Final Grading的相关文章

1137 Final Grading (25 分)

1137 Final Grading (25 分) For a student taking the online course "Data Structures" on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online program

PAT 甲级 1137 Final Grading

https://pintia.cn/problem-sets/994805342720868352/problems/994805345401028608 For a student taking the online course "Data Structures" on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first ob

1137 Final Grading

题意:排序题. 思路:通过unordered_map来存储考生姓名与其成绩信息结构体的映射,成绩初始化为-1,在读入数据时更新各个成绩,最后计算最终成绩并把符合条件的学生存入vector,再排序即可.需要注意的是,计算最终成绩时记得"G must be rounded up to an integer".关于取整函数,总结在这里. 代码: #include <iostream> #include <string> #include <unordered_m

PAT-1137. Final Grading (25)

1137. Final Grading (25) 时间限制 100 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue For a student taking the online course "Data Structures" on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/sh

A题目

1 1001 A+B Format(20) 2 1002 A+B for Polynomials(25) 3 1003 Emergency(25) 4 1004 Counting Leaves(30) 5 1005 Spell It Right(20) 6 1006 Sign In and Sign Out(25) 7 1007 Maximum Subsequence Sum(25) 8 1008 Elevator(20) 9 1009 Product of Polynomials(25) 10

1025. PAT Ranking (25)

题目如下: Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. No

九度oj 1002 Grading 2011年浙江大学计算机及软件工程研究生机试真题

1 #include<iostream> 2 #include<queue> 3 #include<cstdio> 4 #include<cstring> 5 #include<cmath> 6 #include<algorithm> 7 using namespace std; 8 int map[15][15]; 9 int main(){ 10 int P,T,G1,G2,G3,GJ; 11 while(cin>>P

1025. PAT Ranking

1025. PAT Ranking (25) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneous

九度OJ 1002 Grading

题目1002:Grading 时间限制:1 秒 内存限制:32 兆 特殊判题:否 提交:15686 解决:4053 题目描述: Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam pro