前缀匹配

Problem B

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 14   Accepted Submission(s) : 12

Problem Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input

Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

01 10 0010 0000 9 01 10 010 0000 9

Sample Output

Set 1 is immediately decodable Set 2 is not immediately decodable

借鉴别人的代码:

#include<cstdio> 
#include<cstring> 
   
char s[1000][100]; 
int n; 
   
inline bool check() 

    for (int i = 0; i < n - 1; i++) 
        for (int j = i + 1; j < n; j++) 
        { 
            bool flag = false; 
            int l1 = strlen(s[i]); 
            int l2 = strlen(s[j]); 
            for (int k = 0; k < l1 && k < l2; k++)///比strstr()要快一点 
                if (s[i][k] != s[j][k]) 
                { 
                    flag = true; 
                    break; 
                } 
            if (!flag) return false; 
        } 
    return true; 

   
int main(void) 

    int cas = 0; 
    while (gets(s[0])) 
    { 
        for (n = 1;; n++) 
        { 
            gets(s[n]); 
            if (s[n][0] == ‘9‘) 
                break; 
        } 
        if (check()) printf("Set %d is immediately decodable\n", ++cas); 
        else printf("Set %d is not immediately decodable\n", ++cas); 
    } 
}

我的代码:

不能输入数据
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define MAX 20

struct Trie{
 Trie *next[MAX];
 int v;
};
Trie *root;

void CreatTrie(char * str){
 int len=strlen(str),i,j,id;
 Trie *p=root,*q;
 for(i=0;i<len;i++){
        id=str[i]-‘0‘;
  if(p->next[id]==NULL){
   q=(Trie*)malloc(sizeof(Trie));
   q->v=1;
   for(j=0;j<len;j++){
    q->next[j]=NULL;    
   }
   p->next[id]=q;
   p=p->next[id];
  }
  else{
   p->next[id]->v++;
            p=p->next[id];
  }
 }
    p->v=-1;
}

int FindTrie(char *str){
 int len=strlen(str),i;
 Trie *p=root;
 for(i=0;i<len;i++){
    int id=str[i]-‘0‘;
    p=p->next[id];
    if(p==NULL)
     return 0;
    if(p->v==-1)
     return 1;
    }
 return 1;
}

int main()
{
 char a[20];
 int flag,k,i;
 for(i=0;i<MAX;i++)
  root->next[i]=NULL;
    while(gets(a)&&a[0]!=‘9‘){
  CreatTrie(a);
//  k++;
 }
 gets(a);
 if(FindTrie(a)) printf("YES\n");
 else printf("NO\n");
 return 0;
}

前缀匹配,布布扣,bubuko.com

时间: 2024-10-08 18:51:37

前缀匹配的相关文章

CIDR详解和ip最长地址前缀匹配

1.CIDR是什么 无类域间路由(CIDR)编址方案 摒弃传统的基于类的地址分配方式,允许使用任意长度的地址前缀,有效提高地址空间的利用率. 就是一个ip加一个网络掩码,不过这个掩码不是之前只有3个值(A类:8,B类:16,C类:24),而是0-32随意的一个值. 例如: 208.12.128.0/17 2.如何理解CIDR格式 上图 可以理解为一个从0到(2^32-1)长的线段. 掩码32表示n个ip的点,数量n是2^32. 掩码31表示n个小线段1,每个线段1包含2(2^(32-31))个i

一个 VPC 与使用最长前缀匹配的两个 VPC 具有对等关系

您有带一个子网的中心 VPC (VPC A),在 VPC A 与 VPC B 之间具有 VPC 对等连接 (pcx-aaaabbbb),并且在 VPC A 与 VPC C 之间具有 VPC 对等连接 (pcx-aaaacccc).VPC B 和 VPC C 具有匹配 CIDR 块.您要使用 VPC 对等连接 pcx-aaaabbbb 在 VPC A 与 VPC B 中特定实例之间路由流量.以 10.0.0.0/16 IP 地址范围为目标的所有其他流量都通过 pcx-aaaacccc 在 VPC

HDU4300-Clairewd’s message(KMP前缀匹配后缀)

Clairewd's message Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3228    Accepted Submission(s): 1248 Problem Description Clairewd is a member of FBI. After several years concealing in BUPT,

索引最左前缀匹配原则

如果索引字符串的前面n个字符都不相同,那么最好不要索引整个数据列,二十索引前n个字符,这样可以节省大量空间. 如果在数据列a,b,c上建立了复合索引,索引中的数据行按照a/b/c次序排列,因此数据表会自动的按照a/b和a排列,即使指定了a,或者a和b的值,mysql也可以使用这个索引. 这个索引可以用于如下数据列的组合: a,  b,c a,b a Mysql不能利用这个索引搜索没有包含在最左前缀的内容.如按照b或者按照c来搜索,就不会使用这个索引.如果搜索给定a和c的数据,也不能使用这个索引.

【算法学习笔记】57. 前缀树 字典序优化技巧 STL学习 SJTU OJ 1366 前缀匹配

Description 给出一个总字符个数大小不超过1,000,000的字典(这个字典的单词顺序不为字典序)和不超过1000个长度不超过1000的前缀,输出字典中匹配该前缀,字典序为K_i的单词在字典中的位置. 所有单词都为小写字母. Input Format 第一行: 两个整数N,M,分别表示字典中的单词个数和需要查询的前缀数. 接下来N行:每行一个字符串,表示字典中的单词. 接下来M行,每行一个K_i, P_i, P_i表示查询的前缀,K_i表示满足这个前缀在字典序中的位置. Output

elasticsearch 前缀匹配

curl -XDELETE 'http://localhost:9200/ess/'; curl -XPOST 'http://localhost:9200/ess' -d '{ "analysis": { "filter": { "autocomplete_filter": { "type":     "edge_ngram", "min_gram": 1, "max_gra

HDOJ1671(字符串前缀匹配)

#include<iostream> #include<cstdio> #include<string> #include<vector> #include<algorithm> using namespace std; vector<string> words; bool isPrefix(string s1, string s2) { string::iterator it1=s1.begin(); string::iterato

HDOJ1251(前缀匹配---分块查找&amp;map应用)

分块查找算法 #include<iostream> #include<cstdio> #include<cstring> #include<algorithm> using namespace std; const int SIZE=1300000+16; const int BLOCKS=50000; //块的大小 char word[SIZE][11]; char pre[20]; int Num[27]; bool isPre(char mo[],ch

[Elasticsearch] 部分匹配 (一) - 前缀查询

部分匹配(Partial Matching) 敏锐的读者可能已经发现到目前为止,介绍的查询都是在整个词条层面进行操作的.匹配的最小单元必须是一个词条.你只能找到存在于倒排索引(Inverted Index)中的词条. 但是如果你想匹配词条的一部分,而不是整个词条呢?部分匹配(Partial Matching)允许用户指定词条的一部分然后找到含有该部分的任何单词. 匹配词条一部分这一需求在全文搜索引擎领域比你想象的要不那么常见.如果你有SQL的背景,你可能有过使用下面的SQL语句来实现一个简单的全