hdu 5532 Almost Sorted Array nlogn 的最长非严格单调子序列

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2504    Accepted Submission(s): 616

Problem Description

We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1,a2,…,an, is it almost sorted?

Input

The first line contains an integer T indicating the total number of test cases. Each test case starts with an integer n in one line, then one line with n integers a1,a2,…,an.

1≤T≤2000
2≤n≤105
1≤ai≤105
There are at most 20 test cases with n>1000.

Output

For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).

Sample Input

3
3
2 1 7
3
3 2 1
5
3 1 4 1 5

Sample Output

YES
YES
NO

Source

2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

Recommend

hujie   |   We have carefully selected several similar problems for you:  5780 5779 5778 5777 5776

题意:依次给你n个数字,判断其是否是至少>=n-1长的单调子序列;

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
typedef  long long  ll;
typedef unsigned long long ull;
#define MM(a,b) memset(a,b,sizeof(a));
#define inf 0x7f7f7f7f
#define FOR(i,n) for(int i=1;i<=n;i++)
#define CT continue;
#define PF printf
#define SC scanf
const int mod=1000000007;
const int N=100000+10;
ull seed=13331;

int dp[N],ans[N],a[N];
int main()
{
    int cas;
    scanf("%d",&cas);
    while(cas--){
       int n;scanf("%d",&n);
       for(int i=1;i<=n;i++) scanf("%d",&a[i]);
       int len=1,flag1=0,flag2=0;
       ans[1]=a[1];
       for(int i=2;i<=n;i++)
       {
             if(a[i]>=ans[len]) {len++;ans[len]=a[i];}
             else{
                int pos=upper_bound(ans+1,ans+len,a[i])-ans;
                ans[pos]=a[i];
             }
       }
       if(len>=n-1) flag1=1;
       len=1;ans[1]=a[n];
       for(int i=n-1;i>=1;i--)
       {
             if(a[i]>=ans[len]) {len++;ans[len]=a[i];}
             else{
                int pos=upper_bound(ans+1,ans+len,a[i])-ans;
                ans[pos]=a[i];
             }
       }
       if(len>=n-1) flag2=1;
       if(flag1||flag2) printf("YES\n");
       else printf("NO\n");
    }
    return 0;
}

  分析:严格单调递增子序列就是lower_bound(),直接进行替换;非严格单调子序列就是upper_bound();

 if(a[i]>=ans[len]) {len++;ans[len]=a[i];}
             else{
                int pos=upper_bound(ans+1,ans+len,a[i])-ans;//非严格单调
                ans[pos]=a[i];
             }

  

时间: 2024-12-15 23:22:02

hdu 5532 Almost Sorted Array nlogn 的最长非严格单调子序列的相关文章

HDU 5532 Almost Sorted Array

Almost Sorted Array Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)Total Submission(s): 831    Accepted Submission(s): 293 Problem Description We are all familiar with sorting algorithms: quick sort, merge sort,

HDU 5532——Almost Sorted Array——————【技巧】

Almost Sorted Array Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)Total Submission(s): 236    Accepted Submission(s): 113 Problem Description We are all familiar with sorting algorithms: quick sort, merge sort,

hdu 5532 Almost Sorted Array (水题)

Almost Sorted Array Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)Total Submission(s): 8541    Accepted Submission(s): 1982 Problem Description We are all familiar with sorting algorithms: quick sort, merge sort

【HDU 5532 Almost Sorted Array】水题,模拟

给出一个序列(长度>=2),问去掉一个元素后是否能成为单调不降序列或单调不增序列. 对任一序列,先假设其可改造为单调不降序列,若成立则输出YES,不成立再假设其可改造为单调不增序列,若成立则输出YES,不成立则输出NO. 由于持平不影响整体单调性,为了直观,我在以下把“不降”称为“递增/升序”,把“不增”称为“递减/降序”. 递增和递减是对称的,这里先考虑递增,递减改个符号和最值就好. 我们把为维护单调性而去掉的那个点称为“坏点”.由题目的要求,“可改造”可等价于“只存在一个坏点”. 对于“坏点

HDU 5532 Almost Sorted Array(最长不下降或不上升子序列)

题目戳这 题目:给你一个序列,问你,这个序列只减少一个元素,减少之后是否为不上升序列或者不下降序列. 思路:直接对序列求最长不下降和不上升子序列,如果这个子序列的长度为n-1或者n的话,就符合题目条件. 最长不下降子序列和最长不上升子序列:这里使用数据结构的方法求最长不上升(下降)子序列的长度.就是另外构造一个数组 f[] ,这个数组表示的意思是:f [ i ] 表示的是长度为 i 的子序列的最小(最大值),因为,同样长度的子序列,最后一个数字最小或最大的时候,更方便往后面放数字.这个时候可能会

HDU 1025 Constructing Roads In JGShining&#39;s Kingdom[动态规划/nlogn求最长非递减子序列]

Constructing Roads In JGShining's Kingdom Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 27358    Accepted Submission(s): 7782 Problem Description JGShining's kingdom consists of 2n(n is no mor

2015ACM/ICPC亚洲区长春站 F hdu 5533 Almost Sorted Array

Almost Sorted Array Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)Total Submission(s): 447    Accepted Submission(s): 201 Problem Description We are all familiar with sorting algorithms: quick sort, merge sort,

HDU 5532 / 2015ACM/ICPC亚洲区长春站 F.Almost Sorted Array

Almost Sorted Array Problem Description We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted arr

Remove Duplicates from Sorted Array II

Follow up for "Remove Duplicates": What if duplicates are allowed at most twice? For example, Given sorted array nums = [1,1,1,2,2,3], Your function should return length = 5, with the first five elements of nums being 1, 1, 2, 2 and 3. It doesn'