PAT 1004. Counting Leaves (30)

A family hierarchy is usually presented by a pedigree tree.  Your job is
to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line
containing 0 < N < 100, the number of nodes in a tree, and M (< N), the
number of non-leaf nodes.  Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the
number of its children, followed by a sequence of two-digit ID‘s of its
children.  For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have
no child for every seniority level starting from the
root.  The numbers must be printed in a line, separated by a space, and
there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and
02 is its only child.  Hence on the root 01 level, there is 0 leaf node;
and on the next level, there is 1 leaf node.  Then we should output "0 1"
in a line.

Sample Input

2 1
01 1 02

Sample Output

0 1

此题我首先想到的是用两次广搜,第一次bfs等到每个节点的高度,第二次bfs得到根据每个节点所在高度得到每层(对应于高度)的叶子节点数。具体见代码:

#include <iostream>
#include <list>
#include <vector>
#include <stack>
#include <algorithm>
using namespace std;

const int N=100;

vector<list<int> > Tree(N);
int nodeHeight[N]={-1}; //height from 0
int heightLeaves[N];

void bfs_getHeight()
{
stack<int> s;
s.push(1);
nodeHeight[1]=0;
int curNode,childNode;
while(!s.empty())
{
curNode=s.top();
s.pop();
for(list<int>::iterator iter=Tree[curNode].begin();iter!=Tree[curNode].end();++iter)
{
childNode=*iter;
nodeHeight[childNode]=nodeHeight[curNode]+1;
if(Tree[childNode].size()!=0)
s.push(childNode);
}
}
}

void bfs_getLeaves()
{
stack<int> s;
s.push(1);
int curNode,childNode;
size_t size;
while(!s.empty())
{
curNode=s.top();
s.pop();
for(list<int>::iterator iter=Tree[curNode].begin();iter!=Tree[curNode].end();++iter)
{
childNode=*iter;
if(0==Tree[childNode].size())
++heightLeaves[nodeHeight[childNode]];
else
s.push(childNode);
}
}
}

int _tmain(int argc, _TCHAR* argv[])
{
int n,m;
cin>>n>>m;
int ID,k,IDbuf;
for(int i=0;i<m;++i)
{
cin>>ID>>k;
for(int j=0;j<k;++j)
{
cin>>IDbuf;
Tree[ID].push_back(IDbuf);
}
}
bfs_getHeight();
bfs_getLeaves();
int maxHeight=*max_element(nodeHeight,nodeHeight+N);
for(int i=0;i<maxHeight;++i)
{
cout<<heightLeaves[i]<<‘ ‘;
}
cout<<heightLeaves[maxHeight];
return 0;
}

但是结果有一个3分的测试点过不了,也不知道错在哪里,实在是没招了,就用了深搜,而且正好可以在每次递归的时候传递层数,反而只需要一次dfs就可以搞定了,相对于第一种解法,第二种解法根据N-M的值为叶子节点数,在输出的时候做了优化。具体见代码:

#include <stdio.h>
#include <map>
#include <vector>
using namespace std;

const int N=101;
map<int,vector<int> > adjlist;
int levelLeaves[N]={0};

void dfs(int node,int level)
{
if(adjlist[node].empty())
{
++levelLeaves[level];
return;
}
vector<int>::iterator iter=adjlist[node].begin();
for(;iter!=adjlist[node].end();++iter)
dfs(*iter,level+1);
}

int _tmain(int argc, _TCHAR* argv[])
{
freopen("1004.txt","r",stdin);
int N,M,ID,K,childID,leaves,cnt;
scanf("%d%d",&N,&M);
leaves=N-M;
while(M--)
{
scanf("%d%d",&ID,&K);
while(K--)
{
scanf("%d",&childID);
adjlist[ID].push_back(childID);
}
}
dfs(1,0);
printf("%d",levelLeaves[0]);
cnt=levelLeaves[0];
for(int i=1;cnt<leaves;++i)
{
printf(" %d",levelLeaves[i]);
cnt+=levelLeaves[i];
}
printf("\n");
return 0;
}

PAT 1004. Counting Leaves (30),布布扣,bubuko.com

时间: 2024-12-23 04:23:49

PAT 1004. Counting Leaves (30)的相关文章

PAT 1004. Counting Leaves (30) C#实现

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child. Input Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree

1004. Counting Leaves (30)——PAT (Advanced Level) Practise

题目信息: 1004. Counting Leaves (30) 时间限制 400 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child. Input Each input file contai

PTA 1004 Counting Leaves (30)(30 分)(建树dfs或者bfs,未AC 段错误)

1004 Counting Leaves (30)(30 分) A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child. Input Each input file contains one test case. Each case starts with a line containing 0 < N < 10

1004 Counting Leaves (30)(30 分)

1004 Counting Leaves (30)(30 分) A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child. Input Each input file contains one test case. Each case starts with a line containing 0 < N < 10

PAT (Advanced Level) 1004. Counting Leaves (30)

简单DFS. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> #include<vector> using namespace std; const int maxn=100+10; vector<int>g[maxn]; int n,m; int ans[maxn]; int root; i

PAT甲题题解-1004. Counting Leaves (30)-统计每层叶子节点个数+dfs

统计每层的叶子节点个数建树,然后dfs即可 #include <iostream> #include <cstdio> #include <algorithm> #include <cstring> #include <vector> using namespace std; /* 统计每层的叶子节点个数 建树,然后dfs即可 */ const int maxn=105; int n,m; int layer[maxn]; //统计每层的叶子节点

PAT:1004. Counting Leaves (30) AC

#include<stdio.h> #include<vector> const int MAX=510; using namespace std; int n,m,le=0; //节点数,非叶子节点数,最深层叶层数 vector<int> child[MAX]; //存储孩子情况 int number[MAX]; //每一层叶子数 void DFS(int s,int l) { if(child[s].size()==0) { ++number[l]; if(le&l

1004. Counting Leaves (30)

时间限制 400 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child. Input Each input file contains one test case. Each case start

PAT 1004 Counting Leaves(结构体)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child. Input Specification: Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of node