POJ 2777 Count Color (线段树 + 状态压缩)

题目

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:

1. "C A B C" Color the board from segment A to segment B with color C. 
2. "P A B" Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

题解

使用位运算进行状态压缩,在非叶子节点处记录的是区间内的颜色状态。

AC代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int seg[100005 << 2];
int tag[100005 << 2];

void push_down(int k){
    if(tag[k] != 0){
        tag[k << 1] = tag[k << 1 | 1] = tag[k];
        seg[k << 1] = seg[k << 1 | 1] = 1 << tag[k];
        tag[k] = 0;
    }
}

void push_up(int k){
    seg[k] = seg[k << 1] | seg[k << 1 | 1];
}

void modify(int L, int R, int l, int r, int k, int val){
    if(l >= L && r <= R){
        tag[k] = val;
        seg[k] = 1 << val;
        return;
    }
    push_down(k);
    int mid = (l + r) >> 1;
    if(mid >= L) modify(L, R, l, mid, k << 1, val);
    if(mid < R) modify(L, R, mid + 1, r, k << 1 | 1, val);
    push_up(k);
}

int query(int L, int R, int l, int r, int k){
    if(l >= L && r <= R){
        return seg[k];
    }
    push_down(k);
    int ans = 0;
    int mid = (l + r) >> 1;
    if(mid >= L) ans = ans | query(L, R, l, mid, k << 1);
    if(mid < R) ans = ans | query(L, R, mid + 1, r, k << 1 | 1);
    return ans;
}

void build(int l, int r, int k){
    if(l == r){
        seg[k] = 1 << 1;
        return;
    }
    int mid = (l + r) >> 1;
    build(l, mid, k << 1);
    build(mid + 1, r, k << 1 | 1);
    push_up(k);
}
int main(){
    int l, t, o;
    scanf("%d%d%d", &l, &t, &o);
    memset(tag, 0, sizeof(tag));
    build(1, l, 1);
    char ch[10]; int a, b, c;
    while(o--){
        //getchar();
        scanf("%s", &ch[0]);
        //cin >> ch;
        if(ch[0] == ‘C‘){
            scanf("%d%d%d", &a, &b, &c);
            if(a > b) swap(a, b);
            //cin >> a >> b >> c;
            modify(a, b, 1, l, 1, c);
        }
        else{
            scanf("%d%d", &a, &b);
            //cin >> a >> b;
            if(a > b) swap(a, b);
            int state = query(a, b, 1, l, 1);
            //cout << state << endl;
            int cnt = 0;
            while(state){
                if(state & 1)
                    cnt++;
                state >>= 1;
            }
            //cout << cnt << endl;
            printf("%d\n", cnt);
        }
    }
    return 0;
}

原文地址:https://www.cnblogs.com/Cl0ud_z/p/11326381.html

时间: 2024-11-05 18:46:00

POJ 2777 Count Color (线段树 + 状态压缩)的相关文章

POJ P2777 Count Color——线段树状态压缩

Description Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. There is a very long board with length L centimeter, L is a positive integer, so we can evenly d

POJ 2777 Count Color(线段树)

题目地址:POJ 2777 我去..延迟标记写错了.标记到了叶子节点上....这根本就没延迟嘛...怪不得一直TLE... 这题就是利用二进制来标记颜色的种类.然后利用或|这个符号来统计每个区间不同颜色种数. 代码如下: #include <iostream> #include <cstdio> #include <string> #include <cstring> #include <stdlib.h> #include <math.h

POJ 2777 Count Color (线段树+位运算)

题意很简单了,对一个区间有两种操作: 1. "C A B C" Color the board from segment A to segment B with color C. //A~B涂上颜色C 2. "P A B" Output the number of different colors painted between segment A and segment B (including). //输出A~B间颜色的种类数 题目链接:http://poj.o

poj 2777 Count Color(线段树、状态压缩、位运算)

Count Color Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 38921   Accepted: 11696 Description Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

POJ 2777 Count Color (线段树成段更新+二进制思维)

题目链接:http://poj.org/problem?id=2777 题意是有L个单位长的画板,T种颜色,O个操作.画板初始化为颜色1.操作C讲l到r单位之间的颜色变为c,操作P查询l到r单位之间的颜色有几种. 很明显的线段树成段更新,但是查询却不好弄.经过提醒,发现颜色的种类最多不超过30种,所以我们用二进制的思维解决这个问题,颜色1可以用二进制的1表示,同理,颜色2用二进制的10表示,3用100,....假设有一个区间有颜色2和颜色3,那么区间的值为二进制的110(十进制为6).那我们就把

poj 2777 count color 线段树

Description Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. There is a very long board with length L centimeter, L is a positive integer, so we can evenly d

POJ 2777 count color(线段树,lazy标记)

这里有一个思想:我们在更新的时候不必要更新到叶子节点,只要更新到当前区间包含线段树区间即可. 设计一个标志位,更新到此. A Simple Problem with Integers 也是一个类似的题目 设计两个函数 push_down 将结点信息传递到下层节点(inc, sub,) push_up      将下层节点信息反馈到上层(max,min,count) #include <map> #include <set> #include <queue> #inclu

POJ 2777 Count Color (线段树区间更新加查询)

Description Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. There is a very long board with length L centimeter, L is a positive integer, so we can evenly d

poj 2777 Count Color(线段树区间修改)

题目链接:http://poj.org/problem?id=2777 题目意思:就是问你在询问的区间里有几种不同的颜色 思路:这题和一般的区间修改差不多,但是唯一不同的就是我们要怎么计算有种颜色,所以这时候我们就需要把延时标记赋予不同的意义,当某段区间有多种颜色时就赋值为-1,当为一种颜色时就把它赋值为这个颜色的号数.这儿我们要怎么统计询问区间不同的颜色数叻,为了不重复计算同一种颜色,那么我们就需要用一个数组来标记计算过的颜色,当我们下次遇到时就不需要再次计算了.... 代码核心处就在计数那儿

poj 2777 Count Color【线段树段更新】

题目:poj 2777 Count Color 题意:给出一段1 * n 的栅栏,有两种操作,第一种:把 l -- r 全部染成同一颜色t,第二种,查询 l---r 一共有多少种颜色. 分类:线段树 分析:我们可以给每个节点加一个标记,标记当前节点是否只有一种颜色,然后对只有一种颜色的节点如果要染色的话,那么他会变成几种颜色的,这时候记得向下更新一次就好,统计的时候统计节点有单个颜色的颜色就好. 代码: #include <cstdio> #include <cstring> #i