练习2-13 求N分之一序列前N项和 (15 分)
输入在一行中给出一个正整数N。
输出格式:
在一行中按照“sum = S”的格式输出部分和的值S,精确到小数点后6位。题目保证计算结果不超过双精度范围。
输入样例:
6
输出样例:
sum = 2.450000
#include <stdio.h>
#include <stdlib.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int main(int argc, char *argv[]) {
int x;
double s=0,y;
scanf("%d",&x);
for(y=1;y<=x;y++){
s+=1.0/y;
}
printf("sum = %.6f\n",s);
return 0;
}
原文地址:https://www.cnblogs.com/xxl-h/p/11111022.html
时间: 2024-10-09 04:59:10