1070 Mooncake 贪心

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region‘s culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤), the number of different kinds of mooncakes, and D(≤ thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45
/*
    Name:
    Copyright:
    Author:  流照君
    Date: 2019/8/17 19:45:19
    Description:
*/
#include <iostream>
#include<string>
#include <algorithm>
#include <vector>
#define inf 1001000
using namespace std;
typedef long long ll;
double sum;
ll n;
struct person{
	double num;
	double p;
};
double res=0.0;
bool cmp(person x,person y)
{
	return x.p/x.num>y.p/y.num;
}
int main(int argc, char** argv)
{
    //freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
    cin>>n>>sum;
    person a[n];
    for(int i=0;i<n;i++)
    cin>>a[i].num ;
    for(int i=0;i<n;i++)
    cin>>a[i].p;
    sort(a,a+n,cmp);
    ll i=0;
    while(sum!=0&&i!=n)//总卡特殊情况  注意!!!
    {
    	if(sum>=a[i].num)
    	{
    		res=res+a[i].p;
    		sum=sum-a[i].num;
		}
		else
		{
			res=res+sum/a[i].num*a[i].p;
			sum=0;
		}
		i++;
		//printf("%.2lf\n",res);
	}
	printf("%.2lf\n",res);
    return 0;
}

  

原文地址:https://www.cnblogs.com/liuzhaojun/p/11370203.html

时间: 2024-10-14 23:03:06

1070 Mooncake 贪心的相关文章

PAT 1070. Mooncake (25)

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival.  Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture.  Now given the inventory amounts and the prices of al

【PAT甲级】1070 Mooncake (25 分)(贪心水中水)

题意: 输入两个正整数N和M(存疑M是否为整数,N<=1000,M<=500)表示月饼的种数和市场对于月饼的最大需求,接着输入N个正整数表示某种月饼的库存,再输入N个正数表示某种月饼库存全部出手的利润.输出最大利润. trick: 测试点2可能包含M不为整数的数据.(尽管题面说明M是正整数,可是根据从前PAT甲级题目的经验,有可能不是整数.....) 代码: #define HAVE_STRUCT_TIMESPEC#include<bits/stdc++.h>using names

1070. Mooncake (25)

(库存量也是double) 时间限制 100 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes accordi

PAT (Advanced Level) 1070. Mooncake (25)

简单贪心.先买性价比高的. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<stack> #include<queue> #include<string> #include<algorithm> using namespace std; double eps=1e-7

1070. Mooncake

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all

hdu 1070 Milk(贪心)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1070 Milk Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 14286    Accepted Submission(s): 3525 Problem Description Ignatius drinks milk everyday,

PAT甲题题解-1070. Mooncake (25)-排序,大水题

#include <iostream> #include <cstdio> #include <algorithm> #include <string.h> using namespace std; /* 3 0 180 150 100 7.5 7.2 4.5 */ const int maxn=1000+5; int amounts[maxn]; float price[maxn]; struct Cake{ float amounts; //注意,这里得

PAT 1070 Mooncake

题目意思能搞成这样我也是服了这个女人了 #include <cstdio> #include <cstdlib> #include <vector> #include <algorithm> using namespace std; int main() { int N = 0; double D = 0; scanf("%d%lf", &N, &D); vector<pair<double, double&g

PAT:1070. Mooncake (25) AC

#include<stdio.h> #include<string.h> #include<algorithm> using namespace std; struct moomcake { double store; //[cation]这个可能是小数! double sumPrice; double solePrice; }M[1010]; bool cmp(moomcake a,moomcake b) { return a.solePrice>b.soleP