hdoj 1150 Machine Schedule【匈牙利算法+最小顶点覆盖】

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6701    Accepted Submission(s): 3358

Problem Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine‘s working mode from time to time, but unfortunately, the machine‘s working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10

0 1 1

1 1 2

2 1 3

3 1 4

4 2 1

5 2 2

6 2 3

7 2 4

8 3 3

9 4 3

0

Sample Output

3

最大匹配数:在所有的顶点都两两被不重复的线连接起来时的边数

最小顶点覆盖==最大匹配数

二分图求最小顶点覆盖:即用最少的顶点个数可以让每条边至少与其中一个点关联

#include<stdio.h>
#include<string.h>
#define MAX 1100
int map[MAX][MAX],vis[MAX],mode[MAX];
int t,n,m;
int find(int x)
{
	int i,j;
	for(i=0;i<m;i++)
	{
		if(map[x][i]&&vis[i]==0)
		{
			vis[i]=1;
			if(mode[i]==0||find(mode[i]))
			{
				mode[i]=x;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int j,i,s,k;
	int x,y;
	while(scanf("%d",&n),n)
	{
		memset(map,0,sizeof(map));
		memset(mode,0,sizeof(mode));
		scanf("%d%d",&m,&k);
		while(k--)
		{
			scanf("%d%d%d",&t,&x,&y);
			if(x&&y)
			map[x][y]=1;
		}
		s=0;
		for(i=0;i<n;i++)
		{
			memset(vis,0,sizeof(vis));
			if(find(i))
			s++;
		}
		printf("%d\n",s);
	}
	return 0;
}
时间: 2024-11-24 17:36:14

hdoj 1150 Machine Schedule【匈牙利算法+最小顶点覆盖】的相关文章

HDOJ 1150 Machine Schedule

最小点覆盖=最大匹配 Machine Schedule Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5350    Accepted Submission(s): 2650 Problem Description As we all know, machine scheduling is a very classical probl

POJ1325 Machine Schedule 【二分图最小顶点覆盖】

Machine Schedule Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 11958   Accepted: 5094 Description As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduli

【二分图入门专题1】C - Machine Schedule hdu1150 【最小顶点覆盖】

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desire

hdu1150 Machine Schedule (匈牙利算法模版)

匈牙利算法本质就是一个个的匹配,对于当前的处理的对象i,假设他的匹配对象为j,但是j已经和v匹配好了,那么就让v去找找着能不能和别人匹配 v可以和别人匹配则i与j匹配,不能则i去找别人匹配 另外引入几个定义和结论: 1:最大匹配数 + 最大独立集 = n + m(n,m为二分图两边的节点数) 2:二分图的最小顶点覆盖数 = 最大匹配数 3:最小路径覆盖 = 最大独立集 最大独立集是指:求一个二分图中最大的一个点集,该点集内的点互不相连. 最小顶点覆盖是指: 在二分图中,用最少的点,让所有的边至少

hdu - 1150 Machine Schedule (二分图匹配最小点覆盖)

http://acm.hdu.edu.cn/showproblem.php?pid=1150 有两种机器,A机器有n种模式,B机器有m种模式,现在有k个任务需要执行,没切换一个任务机器就需要重启一次, 如果任务i在机器A上执行,A机器需要一个对应的模式A,如果在机器B上执行,机器A需要一个模式B. 一直就是机器A在切换模式,现在让你安排一种合理的任务执行顺序,让机器重启次数最少. 每个任务之间连一条边.二分图的最小顶点覆盖就是求最少的点可以连接所有的边,然后转化成最大匹配即可. 这题就是初始状态

hdoj 1054 Strategic Game【匈牙利算法+最小顶点覆盖】

Strategic Game Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 5783    Accepted Submission(s): 2677 Problem Description Bob enjoys playing computer games, especially strategic games, but somet

hdu 1150 Machine Schedule(最小顶点覆盖)

pid=1150">Machine Schedule Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5424    Accepted Submission(s): 2691 Problem Description As we all know, machine scheduling is a very classical pro

hdu 1150 Machine Schedule(二分图-最小顶点覆盖)

Machine Schedule Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5424    Accepted Submission(s): 2691 Problem Description As we all know, machine scheduling is a very classical problem in compu

hdu 1150 Machine Schedule(二分匹配,简单匈牙利算法)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1150 Machine Schedule Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 6733    Accepted Submission(s): 3375 Problem Description As we all know, mach