poj 1141 Brackets Sequence (区间DP)

Brackets Sequence

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 25893   Accepted: 7295   Special Judge

Description

Let us define a regular brackets sequence in the following way:

1. Empty sequence is a regular sequence.

2. If S is a regular sequence, then (S) and [S] are both regular sequences.

3. If A and B are regular sequences, then AB is a regular sequence.

For example, all of the following sequences of characters are regular brackets sequences:

(), [], (()), ([]), ()[], ()[()]

And all of the following character sequences are not:

(, [, ), )(, ([)], ([(]

Some sequence of characters ‘(‘, ‘)‘, ‘[‘, and ‘]‘ is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2
... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.

Input

The input file contains at most 100 brackets (characters ‘(‘, ‘)‘, ‘[‘ and ‘]‘) that are situated on a single line without any other characters among them.

Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input

([(]

Sample Output

()[()]

区间DP题目

#includpe<iostream>
#includpe<stdpio.h>
#includpe<string.h>
using namespace stdp;
#dpefine N 105
#dpefine inf 1e9
char s[N];
int dp[N][N],pos[N][N];
void work(int len)
{
    int i,j,k;
    char left,right;
    for(i=0;i<len;i++)  //若仅仅有一个字符则必须加入一个和它匹配
        dp[i][i]=1;
    for(k=1;k<len;k++)   //枚举间隔长度从1到Len-1
    {
        for(i=0;i<len-k;i++)  //从起始位置開始
        {
            dp[i][i+k]=inf;
            left=s[i];
            right=s[i+k];
            if(left==‘(‘&&right==‘)‘||left==‘[‘&&right==‘]‘)
            {
                dp[i][i+k]=dp[i+1][i+k-1];
                pos[i][i+k]=-1;
            }
            for(j=i;j<i+k;j++)
            {
                if(dp[i][j]+dp[j+1][k+i]<dp[i][i+k])
                {
                    dp[i][i+k]=dp[i][j]+dp[j+1][i+k];
                    pos[i][i+k]=j;
                }
            }
        }
    }
}
void show(int i,int j)
{
    if(i>j)
        return ;
    if(i==j)
    {
        if(s[i]==‘(‘||s[i]==‘)‘)
            printf("()");
        else
            printf("[]");
    }
    else
    {
        if(pos[i][j]==-1)
        {
            printf("%c",s[i]);
            show(i+1,j-1);
            printf("%c",s[j]);
        }
        else
        {
            show(i,pos[i][j]);
            show(pos[i][j]+1,j);
        }
    }
}
int main()
{
    while(gets(s)!=NULL) //不能用scanf
    {
        int len=strlen(s);
        work(len);
        show(0,len-1);
        puts("");
    }
    return 0;
}
				
时间: 2024-12-27 00:48:16

poj 1141 Brackets Sequence (区间DP)的相关文章

POJ 1141 Brackets Sequence (区间dp 记录路径)

题目大意: 给出一种不合法的括号序列,要求构造出一种合法的序列,使得填充的括号最少. 思路分析: 如果只要求输出最少的匹配括号的数量,那么就是简单的区间dp dp[i][j]表示 i - j 之间已经合法了最少添加的括号数. 转移 就是 dp[i] [j] = min  (dp[i+1][j]+1 , dp[ i+ 1] [ k -1 ] + dp[k+1] [j] (i k 位置的括号匹配)) 其次我们要记录路径,你发现  如果 dp [i] [j] 是由 dp [i+1] [j] 转移过来的

uva1626 poj 1141 Brackets Sequence 区间dp 打印路径

// poj 1141 Brackets Sequence // 也是在紫书上看的一题,uva就是多了一个t组数据. // 经典区间dp // dp(i,j)表示区间[i,j]内所需要增加的括号数目 // 则分为两种情况 // 一种是s[i]和s[j]是匹配的则 // dp[i][j] = min(dp[i][j],dp[i+1][j-1]) // 另外一种情况是不匹配 // dp[i][j] = min(dp[i][j],dp[i][k]+dp[k+1][j]){i<k<j}; // 但是无

poj 1141 Brackets Sequence 区间dp,分块记录

Brackets Sequence Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 35049   Accepted: 10139   Special Judge Description Let us define a regular brackets sequence in the following way: 1. Empty sequence is a regular sequence. 2. If S is a r

[ACM] POJ 1141 Brackets Sequence (区间动态规划)

Brackets Sequence Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 25087   Accepted: 7069   Special Judge Description Let us define a regular brackets sequence in the following way: 1. Empty sequence is a regular sequence. 2. If S is a re

POJ 1141 Brackets Sequence (线性dp 括号匹配 经典题)

Brackets Sequence Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 26407   Accepted: 7443   Special Judge Description Let us define a regular brackets sequence in the following way: 1. Empty sequence is a regular sequence. 2. If S is a re

poj 1141 Brackets Sequence(线性dp)

题意:给出一个括号串,求最短的满足要求的括号串: 思路:枚举长度,枚举起点和终点,找到匹配括号是可递推到子序列,枚举中间指针求最优解:打印时通过记忆表path存储最优解,递归求出最短序列: #include<cstdio> #include<cstring> #include<algorithm> #define INF 0x7fffffff using namespace std; char str[505]; int dp[505][505]; int path[5

POJ #1141 - Brackets Sequence - TODO: POJ website issue

A bottom-up DP. To be honest, it is not easy to relate DP to this problem. Maybe, all "most"\"least" problems can be solved using DP.. Reference: http://blog.sina.com.cn/s/blog_8e6023de01014ptz.html There's an important details to AC:

ZOJ1463:Brackets Sequence(区间DP)

Let us define a regular brackets sequence in the following way: 1. Empty sequence is a regular sequence. 2. If S is a regular sequence, then (S) and [S] are both regular sequences. 3. If A and B are regular sequences, then AB is a regular sequence. F

区间DP [POJ 1141] Brackets Sequence

Brackets Sequence Description Let us define a regular brackets sequence in the following way: 1. Empty sequence is a regular sequence. 2. If S is a regular sequence, then (S) and [S] are both regular sequences. 3. If A and B are regular sequences, th