POJ 1860 Currency Exchange(最短路)

Currency Exchange

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 20482   Accepted: 7352

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies.
Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges,
and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative
sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description
of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations
will be less than 104.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

Source

Northeastern Europe 2001, Northern Subregion

题意:有N种货币,货币之间通过汇率进行兑换,一个人持有一种货币,并且拥有一定数目的金额,问是否能通过货币之间的相互兑换实现他手中的货币的金额数增加,如果增加输出“YES” 反之输出“NO”。另外,货币之间的兑换是需要手续费的。例如,如果你想把100美元兑换成俄罗斯卢布,其中的汇率是29.75,而佣金是0.39,你会得到(100
- 0.39)*29.75=2963.3975俄罗斯卢布。明白这些就很好做了。

第一行输入的数据:N种货币,M组数据,所持有的货币类别,所持有的货币的金额,

第二行至第M+1行输入的数据:可以兑换的两种货币的种类x,y,后面的四个数分别代表把x兑换成y的汇率以及需要的手续费。和把y兑换成x的汇率以及所需要的手续费。

可以看成是一个最短路问题:

贝尔曼福特算法代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

struct node
{
    int x,y;
    double a,b;
} q[1000100];

int n,m,s;
double k;
int t = 0;
double num[100010];

void add(int x,int y,double a,double b)
{
    q[t].x = x;
    q[t].y = y;
    q[t].a = a;
    q[t++].b = b;
}

int BF()
{
    for(int i=1; i<=n; i++)
    {
        num[i] = 0;
    }
    num[s] = k;
    for(int i=1; i<=n; i++)
    {
        int flag = 0;
        for(int j=0; j<t; j++)
        {
            if(num[q[j].y]<(num[q[j].x] - q[j].b) * q[j].a)
            {
                num[q[j].y] = (num[q[j].x] - q[j].b) * q[j].a;
                flag = 1;
                if((q[j].y == s && num[s]>k) || (q[i].x == s && num[s]>k))
                {
                    return 1;
                }
            }
        }
        if(flag == 0)
        {
            break;
        }
    }
    for(int j=0; j<t; j++)
    {
        if(num[q[j].y]<(num[q[j].x] - q[j].b) * q[j].a)
        {
            num[q[j].y] = (num[q[j].x] - q[j].b) * q[j].a;
            return 1;
        }
    }
    return 0;
}

int main()
{
    while(scanf("%d%d%d%lf",&n,&m,&s,&k)!=EOF)
    {
        double a1,b1,a2,b2;
        int x1,y1;
        t = 0;
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%lf%lf%lf%lf",&x1,&y1,&a1,&b1,&a2,&b2);
            add(x1,y1,a1,b1);
            add(y1,x1,a2,b2);
        }
        int kk = BF();
        if(kk == 1)
        {
            printf("YES\n");
        }
        else
        {
            printf("NO\n");
        }
    }
    return 0;
}
时间: 2024-10-06 02:17:13

POJ 1860 Currency Exchange(最短路)的相关文章

最短路(Bellman_Ford) POJ 1860 Currency Exchange

题目传送门 1 /* 2 最短路(Bellman_Ford):求负环的思路,但是反过来用,即找正环 3 详细解释:http://blog.csdn.net/lyy289065406/article/details/6645778 4 */ 5 #include <cstdio> 6 #include <iostream> 7 #include <algorithm> 8 #include <cstring> 9 #include <vector>

Dijkstra算法(求解单源最短路)详解 + 变形 之 poj 1860 Currency Exchange

/* 求解单源最短路问题:Dijkstra算法(该图所有边的权值非负) 关键(贪心): (1)找到最短距离已经确定的节点,从它出发更新与其相邻节点的最短距离: (2)此后不再关心(1)中“最短距离已经确定的节点”. 时间复杂度(大概的分析,不准确): “找到最短距离已经确定的节点” => O(|V|) "从它出发更新与其相邻节点的最短距离" => 邻接矩阵:O(|V|),邻接表:O(|E|) 需要循环以上两个步骤V次,所以时间复杂度:O(V^2) 即:在|E|较小的情况下,

poj 1860 Currency Exchange 解题报告

题目链接:http://poj.org/problem?id=1860 题目意思:给出 N 种 currency, M种兑换方式,Nick 拥有的的currency 编号S 以及他的具体的currency(V).M 种兑换方式中每种用6个数描述: A, B, Rab, Cab, Rba, Cba.其中,Rab: 货币A 兑换 货币B 的汇率为Rab,佣金为Cab.Rba:货币B 兑换 货币 A 的汇率,佣金为Cba.假设含有的A货币是x,那么如果兑换成B,得到的货币B 就是:(x-Cab) *

[2016-04-13][POJ][1860][Currency Exchange]

时间:2016-04-13 23:48:46 星期三 题目编号:[2016-04-13][POJ][1860][Currency Exchange] 题目大意:货币对换,问最后能否通过对换的方式使钱变多, 分析: 直接spfa判断是否存在环,如果存在那么就能无限增值 如果不存在正环,那么直接判断最终d[s] 是否 大于初始值 #include<cstdio> #include<vector> #include<cstring> #include<queue>

poj 1860 Currency Exchange (SPFA、正权回路 bellman-ford)

链接:poj 1860 题意:给定n中货币,以及它们之间的税率,A货币转化为B货币的公式为 B=(V-Cab)*Rab,其中V为A的货币量, 求货币S通过若干此转换,再转换为原本的货币时是否会增加 分析:这个题就是判断是否存在正权回路,可以用bellman-ford算法,不过松弛条件相反 也可以用SPFA算法,判断经过转换后,转换为原本货币的值是否比原值大... bellman-ford    0MS #include<stdio.h> #include<string.h> str

图论 --- spfa + 链式向前星 : 判断是否存在正权回路 poj 1860 : Currency Exchange

Currency Exchange Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 19881   Accepted: 7114 Description Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and pe

poj 1860 Currency Exchange(SPFA)

题目链接:http://poj.org/problem?id=1860 Description Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can b

poj 1860 Currency Exchange(Bellman-Ford 改)

poj 1860 Currency Exchange Description Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several

POJ 1860——Currency Exchange——————【最短路、SPFA判正环】

Currency Exchange Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 1860 Description Several currency exchange points are working in our city. Let us suppose that each point specializes in two par