poj 2421 Constructing Roads(kruskal)(基础)

Constructing Roads

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 20643   Accepted: 8697

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village
C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village
i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

题意:

首先给一个数字N,代表多少个村庄,然后就是N*N的矩阵,代表两两村庄的距离。再给一个数Q,接下来Q行:a,b表示第a个与第b个村庄已经相连。求全部村庄联通情况下还需要连接的最短路长。

思路:

很明显的kruskal算法的应用。不过让我想郁闷的是因为我从早上写到晚上,到了晚上十点多有点累就不愿看英文题,直接找题解了解题意,结果别人题意解释的好复杂,我看完好像抽人。。。

代码:

//252K	63MS
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
#define inf 0xfffffff
typedef struct node
{
    int l,r;
    int w;
    bool operator < (const node &a) const
    {
        return w < a.w;
    }
}node;
node p[10010];
int pre[110];
int n,m;
int num;//边的个数

int Find(int x)
{
    return pre[x]==x?pre[x]:Find(pre[x]);
}

int Union(int a,int b)
{
    int f1=Find(a),f2=Find(b);
    if(f1!=f2)
    {
        pre[f1]=f2;
        return 1;
    }
    return 0;
}

void kruskal()
{
    int sum=0;
    for(int i=0;i<num;i++)
    {
        if(!Union(p[i].l,p[i].r))
            continue;
        sum+=p[i].w;
    }
    printf("%d\n",sum);
}

int main()
{
    scanf("%d",&n);
    num=0;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            p[num].l=i;
            p[num].r=j;
            scanf("%d",&p[num++].w);
        }
    }
    for(int i=0;i<=n;i++)
        pre[i]=i;
    scanf("%d",&m);
    int a,b;int f1,f2;
    while(m--)
    {
        scanf("%d%d",&a,&b);
        Union(a,b);
    }
    sort(p,p+num);
    kruskal();
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-08-03 07:36:39

poj 2421 Constructing Roads(kruskal)(基础)的相关文章

POJ 2421 Constructing Roads(Kruskal算法)

题意:给出n个村庄之间的距离,再给出已经连通起来了的村庄.求把所有的村庄都连通要修路的长度的最小值. 思路:Kruskal算法 课本代码: //Kruskal算法 #include<iostream> using namespace std; int fa[120]; int get_father(int x){ return fa[x]=fa[x]==x?x:get_father(fa[x]);//判断两个节点是否属于一颗子树(并查集) } int main(){ int n; int p[

POJ 2421 Constructing Roads (Kruskal算法+压缩路径并查集 )

Constructing Roads Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 19884   Accepted: 8315 Description There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each

POJ 2421 Constructing Roads 修建道路 最小生成树 Kruskal算法

题目链接:POJ 2421 Constructing Roads 修建道路 Constructing Roads Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 19698   Accepted: 8221 Description There are N villages, which are numbered from 1 to N, and you should build some roads such that e

HDU 1102 &amp;&amp; POJ 2421 Constructing Roads (经典MST~Prim)

链接:http://poj.org/problem?id=2421  或   http://acm.hdu.edu.cn/showproblem.php?pid=1102 Problem Description There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We

POJ 2421 Constructing Roads (最小生成树)

Constructing Roads Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 2421 Appoint description:  System Crawler  (2015-05-27) Description There are N villages, which are numbered from 1 to N, and y

POJ 2421 Constructing Roads(最小生成树)

题意  在n个村庄之间修路使所有村庄连通  其中有些路已经修好了  求至少还需要修多长路 还是裸的最小生成树  修好的边权值为0就行咯 #include<cstdio> #include<cstring> #include<cmath> #include<algorithm> using namespace std; const int N = 105, M = 10050; int par[N], n, m, mat[N][N]; int ans; str

POJ 2421 Constructing Roads

题意:要在n个城市之间建造公路,使城市之间能互相联通,告诉每个城市之间建公路的费用,和已经建好的公路,求最小费用. 解法:最小生成树.先把已经建好的边加进去再跑kruskal或者prim什么的. 代码: #include<stdio.h> #include<iostream> #include<algorithm> #include<string> #include<string.h> #include<math.h> #includ

[kuangbin带你飞]专题六 最小生成树 POJ 2421 Constructing Roads

给一个n个点的完全图 再给你m条道路已经修好 问你还需要修多长的路才能让所有村子互通 将给的m个点的路重新加权值为零的边到边集里 然后求最小生成树 1 #include<cstdio> 2 #include<iostream> 3 #include<algorithm> 4 #include<cmath> 5 #include<cstring> 6 #include<string> 7 #define cl(a,b) memset(a

POJ - 2421 Constructing Roads (最小生成树)

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a