kmp算法(Oulipo)

http://www.cnblogs.com/dolphin0520/archive/2011/08/24/2151846.html

http://www.matrix67.com/blog/archives/115

Oulipo

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 22468   Accepted: 8962

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program
that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘‘B‘‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T,
count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

bf算法RE=。=

#include<iostream>
#include<string>
using namespace std;
int main()
{
	int n,c;
	cin>>n;
	for(c=1;c<=n;c++)
	{
		char s[100005],t[10005];
		cin>>t;
		cin>>s;
		int slen,tlen;
		tlen=strlen(t);
		slen=strlen(s);
		int i,j;
		int sum=0;
		for(i=0;i<slen;i++)
		{
			j=0;
			while(t[j]==s[i]&&j<tlen)
			{
				i++;
				j++;
			}
			if(j==tlen)
				sum=sum+1;
            i=i-j+1;
		}
		cout<<sum<<endl;
	}
    return 0;
}

kmp算法求next[]数组~

#include<iostream>
#include<string>
using namespace std;
int next[10005];
char s[1000005],t[10005];
void getnext(char *p,int *next)
{
    int j=0,k=-1;
     next[0]=-1;
     while(!j || t[j]!='\0')
     {
         if(k==-1 || t[j]==t[k])
         {
             j++;
             k++;
             if(t[j]!=t[k])
                 next[j]=k;
             else
                 next[j]=next[k];
         }
         else k=next[k];
     }
}
int main()
{
	int n,c;
	cin>>n;
	for(c=1;c<=n;c++)
	{
		cin>>t>>s;
		int slen,tlen;
		slen=strlen(s);
		tlen=strlen(t);
		getnext(t,next);
		int i=0,j=0,sum=0;
		while(i<slen)
		{
			if(j==-1||s[i]==t[j])
			{
				i++;
				j++;
			}
			else
			{
				j=next[j];
			}
			if(j==tlen)
			{
				sum=sum+1;
				j=next[j];
			}
		}
		cout<<sum<<endl;
	}
	return 0;
}

/*

  3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
*/

kmp算法(Oulipo)

时间: 2024-10-31 16:42:32

kmp算法(Oulipo)的相关文章

POJ 3461 Oulipo KMP算法题解

本题就是给出很多对字符串,然后问一个字符串在另外一个字符串出现的次数. 就是所谓的Strstr函数啦. Leetcode有这道几乎一模一样的题目. 使用KMP算法加速,算法高手必会的算法了. 另外看见讨论说什么使用KMP还超时,最大可能是没有真正理解next table的含义,写了错误的代码,故此虽然自己运行结果正确,但是却没有真正发挥next table的作用,使得算法退化为暴力法了,所以运行正确,但超时. KMP参考: http://blog.csdn.net/kenden23/articl

KMP算法之Oulipo

Oulipo Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 8137    Accepted Submission(s): 3280 Problem Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, wit

KMP算法 hdu4686 Oulipo

Problem Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book: Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair

[POJ] 3461 Oulipo [KMP算法]

Oulipo Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 23667   Accepted: 9492 Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote

hdoj 1686 Oulipo(KMP算法)

Oulipo http://acm.hdu.edu.cn/showproblem.php?pid=1686 Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 5903    Accepted Submission(s): 2370 Problem Description The French author Georges Perec (1

poj 3461 - Oulipo 经典kmp算法问题

2017-08-13 19:31:47 writer:pprp 对kmp算法有了大概的了解以后,虽然还不够深入,但是已经可以写出来代码,(可以说是背会了) 所以这道题就作为一个模板,为大家使用吧. 题目大意:给你一个子串P和一个主串S,求在主串中有多少个子串? 代码如下:(需要注意的点我都标记好了,两个函数可以直接用) #include <iostream> #include <cstdio> #include <cstdlib> #include <cstrin

POJ3461 Oulipo KMP算法应用

题目描述 给定主串和模式串,问模式串在主串中出现的次数 Sample Input 3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN Sample Output 1 3 0 解题思路:KMP算法是找到一个匹配就跳出,这题是要计数,所以我们把KMP算法稍微改一下即可,在找到一个匹配(即j=模式串长度)时计数器++,再从next[j]开始找就好了.详见代码 #include <cstdio> #include <cstring> void Get

KMP算法 初见

KMP算法 poj3461 Oulipo 题目大意:模板题. 思路:模板题. #include<iostream> #include<cstdio> #include<cstring> using namespace std; int f[10010],ans; char s1[10000],s2[1000000]; void prework() { int i,j,n; n=strlen(s1); f[0]=f[1]=0; for (i=1;i<n;++i) {

【KMP】Oulipo

KMP算法 求串内匹配数,计数时返回next[]位置. Problem Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:Tout avait Pair normal, mais tout s’affi