计蒜客——踩蚂蚁

首先将蚂蚁按照血量从大到小排序,并把鞋子(可以使用结构体或pair来保存鞋子的伤害值和费用)按照伤害值从高到低排序。

逐个计算每只蚂蚁需要用哪双鞋子来踩,对于当前蚂蚁的血量 ant,把所有伤害值不小于 ant 的鞋子放入优先队列中。

在这个优先队列中,费用低的鞋子优先级越高。

在每次将鞋子放入优先队列后,让优先队列的队首元素(费用最低的鞋子)出队并累积总费用。

不断循环,直到算出每只蚂蚁对应的鞋子,或者发现没有可用的鞋子时直接输出No

看了提示之后还是写了半天,基础太烂了。。渣渣来讲一下做这题的过程。

贪心策略不多说,挺好理解的。就是对重载不太知道怎么写。用个结构体定义鞋子。

然后重载运算符,这样才可以使用元素类型为shoe的优先队列。

struct shoe
{
    int price;
    int power;
    //定义在优先队列中的优先级 价格低的优先级高
    bool operator < (const shoe & a) const
    {
        return price > a.price;
    }
} shoes[100005];

在网上看到另外一个方法,感觉挺有用,但是代码比较长,就换成了上面的。同时使用下面的方法定义优先级时

声明优先队列的方式要变化  priority_queue<shoe,vector<shoe>,Cmp> q;

//定义在优先队列中的优先级的另一种方式 价格低的优先级高
//priority_queue<shoe,vector<shoe>,Cmp> q;
struct Cmp
{
    bool operator() (shoe s1, shoe s2)
    {
        if(s1.price==s2.price) return s1.power>s2.power;
        return s1.price > s2.price;
    }
};

然后就开始暴露我的智商了。先贴一波第五组数据超时的代码

#include <cstdio>
#include <algorithm>
#include <set>
#include <map>
#include <iostream>
#include <string>
#include <queue>
#include <memory.h>
using namespace std;
int n,m;
int ants[100005];
int vis[100005];
struct shoe
{
    int index;
    int price;
    int power;
    //定义在优先队列中的优先级 价格低的优先级高
    bool operator < (const shoe & a) const
    {
        return price > a.price;
    }
} shoes[100005];

//定义在优先队列中的优先级的另一种方式 价格低的优先级高
//priority_queue<shoe,vector<shoe>,Cmp> q;
struct Cmp
{
    bool operator() (shoe s1, shoe s2)
    {
        if(s1.price==s2.price) return s1.power>s2.power;
        return s1.price > s2.price;
    }
};

bool cmp(int x,int y)
{
    return x>y;
}

bool cmpshoes(shoe &s1,shoe &s2)
{
    return s1.power>s2.power;
}

int main ()
{
    memset(vis,0,sizeof(vis));
    scanf("%d%d",&n,&m);
    for(int i=0; i<n; i++)
        scanf("%d",&ants[i]);
    for(int i=0; i<m; i++)
    {
        scanf("%d",&shoes[i].power);
        shoes[i].index=i;
    }
    for(int i=0; i<m; i++)
        scanf("%d",&shoes[i].price);
    sort(ants,ants+n,cmp);
    sort(shoes,shoes+m,cmpshoes);

    long long ans=0;
    int flag=1;
    for(int i=0; i<n; i++)
    {
        //priority_queue<shoe,vector<shoe>,Cmp> q;
        priority_queue<shoe> q;
        int j=0;
        while(j<m&&shoes[j].power>=ants[i])
        {
            if(!vis[shoes[j].index])
                q.push(shoes[j]);
            j++;
        }
        //while(vis[q.top().index]&&!q.empty()) q.pop();

        if(q.empty())
        {
            flag=0;
            break;
        }
        //cout<<"top:"<<q.top().index<<" "<<q.top().power<<" "<<q.top().price<<endl;
        ans+=q.top().price;
        vis[q.top().index]=1;
    }
    if(flag) printf("%lld\n",ans);
    else printf("No\n");
    return 0;
}

在此之前第四组数据都超时。。因为我把每双鞋子都往里塞,再把用过的慢慢弹...

然后想了半天要怎么优化才能过最后一组数据。然后突然想到

优先队列应该开在外部,不应该开在内部,因为蚂蚁的血量是从大到小排序的,
下一只蚂蚁的血量一定能用能踩死当前蚂蚁的鞋子踩死,只要加入新的能踩死的鞋子就好。

然后用掉的鞋子弹出队列,也不需要vis数组来标记了。好吧 我是zz。。

#include <cstdio>
#include <algorithm>
#include <set>
#include <map>
#include <iostream>
#include <string>
#include <queue>
#include <memory.h>
using namespace std;
int n,m;
int ants[100005];
int vis[100005];
struct shoe
{
    int price;
    int power;
    //定义在优先队列中的优先级 价格低的优先级高
    bool operator < (const shoe & a) const
    {
        return price > a.price;
    }
} shoes[100005];

//定义在优先队列中的优先级的另一种方式 价格低的优先级高
//priority_queue<shoe,vector<shoe>,Cmp> q;
struct Cmp
{
    bool operator() (shoe s1, shoe s2)
    {
        if(s1.price==s2.price) return s1.power>s2.power;
        return s1.price > s2.price;
    }
};

bool cmp(int x,int y)
{
    return x>y;
}

bool cmpshoes(shoe &s1,shoe &s2)
{
    return s1.power>s2.power;
}

int main ()
{
    memset(vis,0,sizeof(vis));
    scanf("%d%d",&n,&m);
    for(int i=0; i<n; i++)
        scanf("%d",&ants[i]);
    for(int i=0; i<m; i++)
    {
        scanf("%d",&shoes[i].power);
    }
    for(int i=0; i<m; i++)
        scanf("%d",&shoes[i].price);
    sort(ants,ants+n,cmp);
    sort(shoes,shoes+m,cmpshoes);

    long long ans=0;
    int flag=1;

    //优先队列开在外部 不应该开在内部 因为蚂蚁的血量是从大到小排序的
    //下一只蚂蚁的血量一定能用能踩死当前蚂蚁的鞋子踩死
    //priority_queue<shoe,vector<shoe>,Cmp> q;
    priority_queue<shoe> q;
    int j=0;
    for(int i=0; i<n; i++)
    {
        while(j<m&&shoes[j].power>=ants[i])
        {
            q.push(shoes[j]);
            j++;
        }
        if(q.empty())
        {
            flag=0;
            break;
        }
        ans+=q.top().price;
        q.pop();
    }
    if(flag) printf("%lld\n",ans);
    else printf("No\n");
    return 0;
}
时间: 2024-12-27 09:10:38

计蒜客——踩蚂蚁的相关文章

计蒜客 无脑博士和他的试管们

无脑博士有三个容量分别是A,B,C升的试管,A,B,C分别是三个从1到20的整数,最初,A和B试管都是空的,而C试管是装满硫酸铜溶液的.有时,无脑博士把硫酸铜溶液从一个试管倒到另一个试管中,直到被灌试管装满或原试管空了.当然每一次灌注都是完全的.由于无脑博士天天这么折腾,早已熟练,溶液在倒的过程中不会有丢失. 写一个程序去帮助无脑博士找出当A是个是空的时候,C试管中硫酸铜溶液所剩量的所有可能性. 输入包括一行,为空格分隔开的三个数,分别为整数A,B和C. 输出包括一行,升序地列出当A试管是空的时

简单斐波那契——计蒜客(4)

题目来自“计蒜客”第4题. 解算法题之前,务必先写出与之对应的数学表达式,用于描述算法. 数学描述如图: 根据“数学描述“,写出代码如下: #include <stdio.h> int main() { int N =0 ; scanf("%d", &N); int i, fn1 = 1, fn2 = 0, fn; switch(N) { case 0: printf("0"); break; case 1: printf("1&quo

计蒜客普及组模拟赛

今天没事闲的看到计蒜客有个普及组模拟赛,就当练了练手去打了,成绩低的可怜...400分崩成280分AK梦想化作泡影 第一题 同学的爱好 链接:https://nanti.jisuanke.com/t/17291 小学应用题难度?大概画个图就能懂,把每个部分都标上号,算出a,b,c,d,e,f的部分,进行运算就行了. 不多解释了,直接上代码 #include<iostream> #include<cstdio> #include<algorithm> #include&l

计蒜客 作弊揭发者(string的应用)

鉴于我市拥堵的交通状况,市政交管部门经过听证决定在道路两侧安置自动停车收费系统.当车辆驶入车位,系统会通过配有的摄像头拍摄车辆画面,通过识别车牌上的数字.字母序列识别车牌,通过连接车管所车辆信息数据库确认车辆,进行扣费. 斗智斗勇的好戏一般从此处展开… 一些车主通过在停车时遮挡车牌上的一个或多个数字.字母序列,来阻碍识别系统的识别工作,以此逃避停车费用的缴纳. 车主这简直是用轻轻的一挡搞出来一个世界难题有木有?!管理是一方面,技术解决才是王道啊. 这么难的项目不得不交给计蒜客实验室了.D 神负责

计蒜客 删除字母&#39;c&#39;

删除字母'c' 右侧的程序实现的功能是从字符串s中删除所有的小写字母c,请改正程序错误的地方. 注意:main函数不可以改动,程序结构也不能修改. 很简单的哦,加油吧- 样例输入 abccabcn 样例输出 ababn 1 #include <stdio.h> 2 3 #define N 1024 4 5 void del(char *s) 6 { 7 int i, j; 8 for(i = j = 0; s[i] != '\0'; i++) 9 { 10 if(s[i] != 'c') 11

计蒜客 教科书般的亵渎

Description: 环境里有 nn 个怪物,他们的生命值用一个正整数表示.现在,你可以使用两种魔法,对怪物进行攻击.当怪物的生命值小于等于 00 时,他便被消灭了. 魔法箭,对摸个生物造成 kk 点伤害,对一个生物最多使用一次,但没有使用次数限制. 亵渎,对所有生物造成一点伤害,如果杀死了某个生物,则继续自动重新使用该法术.只能主动使用一次,且必须最后使用. 请问,最多能消灭多少个怪物?亵渎法术最多能释放几次? Input: 第一行两个整数 nn 和 kk ,表示怪物的数量和法术的伤害.第

2017计蒜客

1 #include <bits/stdc++.h> 2 using namespace std; 3 int x[100],y[100]; 4 int n,m; 5 bool find(int a,int b) 6 { 7 for(int i=0;i<n;i++) if(x[i]==a && y[i]==b) return true; 8 return false; 9 } 10 int main() 11 { 12 while(scanf("%d%d&quo

2017计蒜客(四,五,六)

2017 计蒜之道 初赛 第四场 rank 178 题解 1A 1 #include <bits/stdc++.h> 2 using namespace std; 3 int n,m,k,v[110][110]; 4 void setrow(int c) 5 { 6 for(int j=1;j<=m;j++) v[c][j]=1; 7 } 8 void setcol(int c) 9 { 10 for(int j=1;j<=n;j++) v[j][c]=1; 11 } 12 int

2018计蒜客复赛 贝壳找房函数最值(贪心+优先队列)

贝壳找房函数最值 35.12% 1000ms 262144K 贝壳找房的攻城狮最近在研究一次函数 f(x) = ax + bf(x)=ax+b. 现在有 nn 个一次函数,f_i(x) = a_ix+b_i,\ i = \{1 \mathellipsis n\}fi?(x)=ai?x+bi?, i={1…n}. 容易发现,一次函数嵌套一次函数,还是一次函数. \displaystyle f_{i}(f_{j}(x)) = a_{i} ( a_{j}x + b_{j}) + b_{i}fi?(fj