hdu 1686 Oulipo

Oulipo

http://acm.hdu.edu.cn/showproblem.php?pid=1686

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description

The French author Georges Perec (1936–1982) once wrote
a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo
group. A quote from the book:

Tout avait Pair normal, mais tout
s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain,
l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait
au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un
non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la
raison : tout avait l’air normal mais…

Perec would probably have scored
high (or rather, low) in the following contest. People are asked to write a
perhaps even meaningful text on some subject with as few occurrences of a given
“word” as possible. Our task is to provide the jury with a program that counts
these occurrences, in order to obtain a ranking of the competitors. These
competitors often write very long texts with nonsense meaning; a sequence of
500,000 consecutive ‘T‘s is not unusual. And they never use spaces.

So we
want to quickly find out how often a word, i.e., a given string, occurs in a
text. More formally: given the alphabet {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘} and two finite
strings over that alphabet, a word W and a text T, count the number of
occurrences of W in T. All the consecutive characters of W must exactly match
consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single
number: the number of test cases to follow. Each test case has the following
format:

One line with the word W, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘},
with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line
with the text T, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤
1,000,000.

Output

For every test case in the input file, the output
should contain a single number, on a single line: the number of occurrences of
the word W in the text T.

Sample Input

3

BAPC

BAPC

AZA

AZAZAZA

VERDI

AVERDXIVYERDIAN

Sample Output

1

3

0

题目大意:输出第一个字符串在第二个字符串中出现的次数

KMP模板题

初次写,1个错误:

getnext函数中i的枚举要从1开始,不能从0,

如果从0开始,j=f[0]=0,i=0 ,两者相等 f[1]=1

然后j=f[1]=1,i=1,两者相等

……

会导致一直相等

因为f[i]表示的是0——i-1位的最大匹配长度

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int n,len1,len2,f[1000001],ans;
char s1[1000001],s2[1000001];
void getnext()
{
    for(int i=1;i<len1;i++)
    {
        int j=f[i];
        while(j&&s1[i]!=s1[j]) j=f[j];
        f[i+1]= s1[i]==s1[j] ? j+1 : 0;
    }
}
void getans()
{
    int j=0;
    for(int i=0;i<len2;i++)
    {
        while(j&&s1[j]!=s2[i]) j=f[j];
        if(s1[j]==s2[i]) j++;
        if(j==len1) ans++;
    }
    printf("%d\n",ans);
}
int main()
{
    scanf("%d",&n);
    while(n--)
    {
        cin>>s1>>s2;
        len1=strlen(s1);len2=strlen(s2);
        memset(f,0,sizeof(f));
        getnext();
        getans();
        ans=0;
    }
}

//由于字符串位置从0开始存
//所以f[i]在数值上=最大前缀子串=i的最大后缀子串=下一个要检验的位置
//也就是保证了 0——f[i]-1是相等的,再匹配i与f[i]
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int n,len1,len2,f[1000001],ans;
char s1[1000001],s2[1000001];
void getnext()
{
    for(int i=1;i<len1;i++)//注意这里从1开始
    {
        int j=f[i];//j=下一个要匹配的位置
        while(j&&s1[i]!=s1[j]) j=f[j];
        f[i+1]= s1[i]==s1[j] ? j+1 : 0;//j+1:字符串从0开始,所以长度+1
    }
}
void getans()
{
    int j=0;
    for(int i=0;i<len2;i++)//这里从1开始
    {
        while(j&&s1[j]!=s2[i]) j=f[j];
        if(s1[j]==s2[i]) j++;
        if(j==len1) ans++;
    }
    printf("%d\n",ans);
}
int main()
{
    scanf("%d",&n);
    while(n--)
    {
        cin>>s1>>s2;
        len1=strlen(s1);len2=strlen(s2);
        memset(f,0,sizeof(f));
        getnext();
        getans();
        ans=0;
    }
}

一点儿注释

时间: 2024-10-12 10:18:30

hdu 1686 Oulipo的相关文章

HDU 1686 Oulipo(KMP)

Problem Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book: Tout avait Pair normal, mais tout s'affirmait faux. Tout avait Fair

HDU - 1686 Oulipo KMP匹配运用

HDU - 1686 Oulipo Time Limit: 1000MS   Memory Limit: 32768KB   64bit IO Format: %I64d & %I64u Submit Status Description The French author Georges Perec (1936?1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Ouli

hdu 1686 Oulipo (kmp)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1686 题目大意:寻找子链在母链中出现的次数. 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 using namespace std; 5 int next[10010],sum,lens,lenc; 6 char str[10010],ch[1000010]; 7 8 int get_nex

HDU 1686 Oulipo 求大串中最多可匹配多少个小串(kmp)

http://acm.hdu.edu.cn/showproblem.php?pid=1686 Oulipo Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 6098    Accepted Submission(s): 2448 Problem Description The French author Georges Perec (19

hdu 1686 Oulipo kmp算法

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1686 题目: Problem Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book: Tout avait

HDU 1686 Oulipo(kmp)

Problem Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book: Tout avait Pair normal, mais tout s'affirmait faux. Tout avait Fair

HDU 1686 Oulipo【kmp求子串出现的次数】

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book: Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, pu

HDU - 1686 Oulipo (KMP)

Problem Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book: Tout avait Pair normal, mais tout s'affirmait faux. Tout avait Fair

hdu 1686 Oulipo【kmp】

Problem Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book: Tout avait Pair normal, mais tout s'affirmait faux. Tout avait Fair