Box of Bricks(南阳oj)

Box of Bricks

时间限制:1000 ms  |  内存限制:65535 KB

描述
Bob在垒砖块,但是他垒的有些乱,但是他很懒,所以想花费最少的体力来让他垒好的砖块一样高,所以你需要做的就是算出最少需要移动的砖块

输入
多组测试数据,以EOF结束,第一行是一个n(1<=n<=50)表示有n摞砖

第二行是n个正整数k(1<=k<=100)表示每摞砖的砖块数量

输出
对于每组输入数据有两行输出,第一行是一个Case #x,表示x组测试数据,第二行是一句话The minimum number of moves is y.表示最小的移动砖块的数量为y,若无解就输出No solution,每两组输出数据用一个分割线隔开
样例输入
6
5 2 4 1 7 5
2
1 2
样例输出
Case #1
The minimum number of moves is 5.
<---华丽的分割线--->
Case #2
No solution
来源
hdu改编
上传者

ACM_孙毓阳

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
	int i,n,a[100],sum,kase=1,ans;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0,sum=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			sum+=a[i];
		}
		if(kase==1)
		    printf("Case #%d\n",kase++);
		else
		{
		    printf("<---华丽的分割线--->\n");
		    printf("Case #%d\n",kase++);
		}
		if(sum%n)
		printf("No solution\n");
		else
		{
			ans=sum/n;
			sort(a,a+n);
			for(i=0,sum=0;a[i]<ans;i++)
			{
				sum+=ans-a[i];
			}
			printf("The minimum number of moves is %d.\n",sum);
		}
	}
	return 0;
} 
时间: 2024-10-10 16:36:04

Box of Bricks(南阳oj)的相关文章

【南阳OJ分类之语言入门】80题题目+AC代码汇总

声明: 题目部分皆为南阳OJ题目. 代码部分包含AC代码(可能不止一个)和最优代码,大部分都是本人写的,并且大部分为c代码和少部分c++代码and极少java代码,但基本都是c语言知识点,没有太多差别,可能代码有的写的比较丑,毕竟知识有限. 语言入门部分题基本都较为简单,是学习编程入门的很好练习,也是ACM的第一步,入门的最佳方法,望认真对待. 本文由csdn-jtahstu原创,转载请注明出处,欢迎志同道合的朋友一起交流学习.本人QQ:1373758426和csdn博客地址. now begi

zoj 1251 Box of Bricks

Box of Bricks Time Limit: 2 Seconds      Memory Limit: 65536 KB Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice.

HDOJ 1326. Box of Bricks 纯水题

Box of Bricks Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5994    Accepted Submission(s): 2599 Problem Description Little Bob likes playing with his box of bricks. He puts the bricks one up

POJ 1477. Box of Bricks 纯水题

Box of Bricks Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 19552   Accepted: 7889 Description Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. "Look, I've buil

Box of Bricks最小移动砖块数目

Description Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I've built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. The

杭电 HDU ACM 1326 Box of Bricks

Box of Bricks Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5457    Accepted Submission(s): 2358 Problem Description Little Bob likes playing with his box of bricks. He puts the bricks one up

HDU 1326 Box of Bricks(简单数学题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1326 Problem Description Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older siste

1177: 零起点学算法84——Box of Bricks

1177: 零起点学算法84--Box of Bricks Time Limit: 1 Sec  Memory Limit: 32 MB   64bit IO Format: %lldSubmitted: 769  Accepted: 268[Submit][Status][Web Board] Description Little Bob likes playing with his box of bricks. He puts the bricks one upon another and

uva 591 Box of Bricks

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. Look, I've built a wall!'', he tells his older sister Alice.Nah, you should make all stacks the same height. Then you would ha