POJ 2031 prim

Building a Space Station

Time Limit: 1000MS Memory Limit: 30000K

Total Submissions: 4400 Accepted: 2255

Description

You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task.

The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is
quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible.

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor‘, or
(3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively.

You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least
three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with
the shortest total length of the corridors.

You can ignore the width of a corridor. A corridor is built between points on two cells‘ surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form
a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect.

Input

The input consists of multiple data sets. Each data set is given in the following format.

n

x1 y1 z1 r1

x2 y2 z2 r2

...

xn yn zn rn

The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100.

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after
the decimal point. Values are separated by a space character.

Each of x, y, z and r is positive and is less than 100.0.

The end of the input is indicated by a line containing a zero.

Output

For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001.

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000.

Sample Input

3

10.000 10.000 50.000 10.000

40.000 10.000 50.000 10.000

40.000 40.000 50.000 10.000

2

30.000 30.000 30.000 20.000

40.000 40.000 40.000 20.000

5

5.729 15.143 3.996 25.837

6.013 14.372 4.818 10.671

80.115 63.292 84.477 15.120

64.095 80.924 70.029 14.881

39.472 85.116 71.369 5.553

0

Sample Output

20.000

0.000

73.834

Source

Japan 2003 Domestic

<span style="color:#6600cc;">/*********************************************

        author    :    Grant Yuan
        time      :    2014.7.31
        algorithm :    prim
        source    :    POJ 2031

**********************************************/

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#define INF 0x3fffffff
#define MAX 103

using namespace std;

struct edge{double x,y,z,r;};
double cost[MAX][MAX];
int n;
edge e[MAX];
double ans;
double mincost[MAX];
bool used[MAX];

void prim()
{
  ans=0;
  memset(used,0,sizeof(used));
  for(int i=1;i<=n;i++)
  {
      mincost[i]=INF;;
  }
  mincost[1]=0;
  while(1){
    int v=-1;
    for(int i=1;i<=n;i++)
    {
        if(!used[i]&&(v==-1||mincost[i]<mincost[v]))
            v=i;}
        if(v==-1) break;
        used[v]=true;
        ans+=mincost[v];
        for(int i=1;i<=n;i++)
        {
           mincost[i]=min(mincost[i],cost[v][i]);
        }

  }

}

int main()
{
    while(1){
    scanf("%d",&n);
    if(!n) break;
    for(int i=1;i<=n;i++)
    {
        scanf("%lf%lf%lf%lf",&e[i].x,&e[i].y,&e[i].z,&e[i].r);

    }
    for(int i=1;i<=n;i++)
        for(int j=i+1;j<=n;j++)
    {
        cost[i][j]=INF;
        cost[i][j]=cost[j][i]=sqrt((e[i].x-e[j].x)*(e[i].x-e[j].x)+(e[i].y-e[j].y)*(e[i].y-e[j].y)+(e[i].z-e[j].z)*(e[i].z-e[j].z))-e[i].r-e[j].r;
        if(cost[i][j]<0)
            cost[i][j]=cost[j][i]=0;
    }
    prim();
    printf("%.3f\n",ans);
    }
    return 0;

}

</span>

POJ 2031 prim

时间: 2024-11-05 17:32:14

POJ 2031 prim的相关文章

ZOJ 1718 POJ 2031 Building a Space Station 修建空间站 最小生成树 Kruskal算法

题目链接:ZOJ 1718 POJ 2031 Building a Space Station 修建空间站 Building a Space Station Time Limit: 2 Seconds      Memory Limit: 65536 KB You are a member of the space station engineering team, and are assigned a task in the construction process of the statio

poj——2031 最小生成树(MST) Kruskal算法

poj——2031 最小生成树(MST)  Kruskal算法 Building a Space Station Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 4985   Accepted: 2503 Description You are a member of the space station engineering team, and are assigned a task in the constructio

poj 2485(prim最小生成树)

Highways Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways

POJ 2349 Prim

Arctic Network Time Limit: 2000MS Memory Limit: 65536K Total Submissions: 9973 Accepted: 3302 Description The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technolo

Building a Space Station POJ 2031 【最小生成树 prim】

http://poj.org/problem?id=2031 Description You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task. The space statio

poj 2031 Building a Space Station 【最小生成树 Prim】

Building a Space Station Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 5778   Accepted: 2874 Description You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You ar

Prim POJ 2031 Building a Space Station

题目传送门 题意:给出n个三维空间的球体,球体是以圆心坐标+半径来表示的,要求在球面上建桥使所有的球联通,求联通所建桥的最小长度. 分析:若两点距离大于两半径和的长度,那么距离就是两点距离 - 半径和,否则为0,Prim写错了,算法没有完全理解 /************************************************ * Author :Running_Time * Created Time :2015/10/25 12:00:48 * File Name :POJ_2

POJ - 2031 Building a Space Station (prim)

题意:给出球形空间站数目N,以及各个空间站的三维坐标x,y,z 以及 半径r ,求将所有空间站连接的最小cost (cost就等于空间站之间的距离) 如果接触,包含,或者相交则不需要搭建桥 思路:还是一道最小生成树的题目,我们先记录每个空间站的信息,然后将所有空间站两两相连接,如果 如果接触,包含,或者相交 我们就把cost 置为1 ,否则就用距离半径之和. 把每个空间站用一个标号表示,然后记录到 向前星中 . 用prim算法 去找最小生成树即可 . 还有一点要注意的是,最后结过的输出:G++下

(最小生成树) Building a Space Station -- POJ -- 2031

链接: http://poj.org/problem?id=2031 代码: #include <cstdio> #include <cstring> #include <cstdlib> #include <cmath> #include <iostream> #include <algorithm> using namespace std; const int N = 110; const int INF = 0xfffffff;