ZOJ 3609 Modular Inverse(扩展欧几里德)

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4712

The modular modular multiplicative inverse of an integer a modulo
m
is an integer x such that a-1x (mod
m)
. This is equivalent to ax≡1 (mod
m)
.

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn‘t exist, output "Not Exist".

Sample Input

3
3 11
4 12
5 13

Sample Output

4
Not Exist
8

References

代码如下:

#include <cstdio>
#include <cstring>
#include <cmath>
typedef long long LL;

LL exgcd(LL a,LL b,LL &x,LL &y)
{
    if(b == 0)
    {
        x = 1;
        y = 0;
        return a;
    }
    else
    {
        LL r = exgcd(b,a%b,x,y);
        LL t = x;
        x = y;
        y = t-a/b*y;
        return r;
    }
}

LL cal(LL a, LL b, LL c)
{
    LL x, y;
    LL tt = exgcd(a, b, x, y);
    if(c%tt)//无整数解
    {
        return -1;
    }
    x*=c/tt;
    b/=tt;
    if(b<0)
        b=-b;
    LL ans=x%b;
    if(ans<=0)
        ans+=b;
    return ans;
}

int main()
{
    LL a, b, t;
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%lld%lld",&a,&b);
        LL ans = cal(a, b, 1);
        if(ans == -1)
        {
            printf("Not Exist\n");
            continue;
        }
        printf("%lld\n",ans);
    }
    return 0;
}
时间: 2024-08-12 07:08:36

ZOJ 3609 Modular Inverse(扩展欧几里德)的相关文章

ZOJ 3609 Modular Inverse (水题)

Modular Inverse Time Limit: 2 Seconds      Memory Limit: 65536 KB The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m). Input There are multiple test cases. Th

ZOJ 3609 Modular Inverse 解线性模方程

点击打开链接 Modular Inverse Time Limit: 2 Seconds      Memory Limit: 65536 KB The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m). Input There are multiple test ca

ZOJ 3609 Modular Inverse

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3609 题面: Modular Inverse Time Limit: 2 Seconds      Memory Limit: 65536 KB The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m).

ZOJ - 3609 —— Modular Inverse 【乘法逆,扩展欧几里得】

题目:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4712 1. 这题数据范围太小,直接暴力即可 2. 不过其实这题也是很“直白的”求乘法逆的题目,即当b=1的特殊的模线性方程问题ax≡b mod(n),可以通过扩展欧几里得算法求解:   ax≡b mod(n) => (ax) mod n = b mod n => ax=k1*n+r ... (1) b=k2n+r    ... (2)  (1)-(2)=>ax-

ZOJ 4712: Modular Inverse

Modular Inverse ///@author Sycamore, ZJNU; ///@date 8/6/2017 ///@ref stanford-acm-master #include<bits/stdc++.h> using namespace std; typedef long long ll; int mod(int a, int b) { return ((a%b) + b) % b; } int extended_euclid(int a, int b, int &

Modular Inverse(扩展欧几里得)

Modular Inverse Time Limit: 2 Seconds      Memory Limit: 65536 KB The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m). Input There are multiple test cases. Th

【ZOJ】3609 Modular Inverse

1. 题目描述求乘法逆元. 2. 基本思路利用扩展gcd求逆元,模板题目. 3. 代码 1 /* 3609 */ 2 #include <iostream> 3 #include <sstream> 4 #include <string> 5 #include <map> 6 #include <queue> 7 #include <set> 8 #include <stack> 9 #include <vector

Modular Inverse(模逆元,扩展欧几里德)

Modular Inverse Time Limit: 2 Seconds      Memory Limit: 65536 KB The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m). Input There are multiple test cases. Th

扩展欧几里得算法模板题 zoj 3609

Modular Inverse Time Limit: 2 Seconds      Memory Limit: 65536 KB The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m). Input There are multiple test cases. Th