POJ 1001

Exponentiation

Time Limit: 500MS   Memory Limit: 10000K
Total Submissions: 143401   Accepted: 34998

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don‘t print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001

1.126825030131969720661201
import java.math.BigDecimal;
import java.util.Scanner;

/**
 *
 * @author bear
 *
 *         stripTrailingZeros():如果小数点后面都是0的话,则把小数点和后面的0都去掉;
 *         toPlainString()是什么样子的小数就显示什么样子,toString()将小数用科学计数法表示。
 */

public class Poj1001 {

	public static void main(String[] args) {

		Scanner sc = new Scanner(System.in);
		while (sc.hasNext()) {
			String input = sc.nextLine();
			String rStr = input.substring(0, 6);
			String n = input.substring(7).trim();

			BigDecimal r = new BigDecimal(rStr);
			//pow求幂
			BigDecimal result = r.pow(Integer.valueOf(n));
			//抹零+普通字符串
			String resultStr = result.stripTrailingZeros().toPlainString();
			if (resultStr.startsWith("0.")) {
				resultStr = resultStr.substring(1);
			}

			System.out.println(resultStr);
		}

	}
}

时间: 2024-10-05 05:31:41

POJ 1001的相关文章

POJ 1001 Exponentiation(JAVA,BigDecimal-&gt;String)

题目 计算实数a的n次方,具体输出格式看案例 import java.util.*; import java.math.*; public class Main { public static void main(String[] args) { Scanner in = new Scanner(System.in); BigDecimal a = BigDecimal.ONE; BigDecimal ans = BigDecimal.ONE; int n; while(in.hasNextBi

POJ 1001 Exponentiation 无限大数的指数乘法 题解

POJ做的非常好,本题就是要求一个无限位大的指数乘法结果. 要求基础:无限大数位相乘 额外要求:处理特殊情况的能力 -- 关键是考这个能力了. 所以本题的用例特别重要,再聪明的人也会疏忽某些用例的. 本题对程序健壮性的考查到达了变态级别了. 某人贴出的測试用例数据地址: http://poj.org/showmessage?message_id=76017 有了这些用例,几下调试就过了. 我关键漏了的用例: 000.10  1 000000  1 000.00  1 .00000  0 0000

solution for POJ 1001

http://poj.org/problem?id=1001 POJ的前几道题理解起来很简单,算法也不复杂,只是需要花很长的时间去调试.1001本质上就是一个大数运算的问题,大数乘法的问题可以采用分治法,具体参考这篇文章:http://blog.csdn.net/tjsinor2008/article/details/5625849.代码如下: 1 #include<stdio.h> 2 #include<memory.h> 3 4 unsigned char a[200],b[2

POJ 1001 高精度

链接: http://poj.org/problem?id=1001 题意: 计算小数的幂,高精度 题解: 第一次用java ac,^-^ 代码: 1 import java.util.*; 2 import java.math.*; 3 4 public class Main { 5 public static void main(String args[]) { 6 Scanner cin = new Scanner(System.in); 7 while (cin.hasNext()) {

POJ 1001 Exponentiation(大数幂,还是Java大发好!需调用多个方法)

Exponentiation Time Limit: 500MS   Memory Limit: 10000K Total Submissions: 156303   Accepted: 38063 Description Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the n

POJ 1001 解题报告 高精度大整数乘法模版

题目是POJ1001 Exponentiation  虽然是小数的幂 最终还是转化为大整数的乘法 这道题要考虑的边界情况比较多 做这道题的时候,我分析了 网上的两个解题报告,发现都有错误,说明OJ对于错误的判断还不够严厉. 对边界情况的讨论其实应该是思维严密的表现,当然这并不能表明我写的一点错误都没有,只是多多分析一下还是很有好处的. #include <iostream> #include <fstream> #include <string> #include &l

POJ 1001 Exponentiation

Exponentiation Time Limit: 500MS   Memory Limit: 10000K Total Submissions: 171995   Accepted: 41641 Description Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the n

POJ 1001 题解

题目大意是求一个实数R的N次方,此题第一次想到用快速幂做,后来发现快速幂只适用于整数计算,就没有采用.此题的突破点在于题目中给的R是一个固定长度的字符串,这就提示我们R可以看做字符串,读入以后提取小数点,并转化为一个整数计算,完成后的结果可以再用记录下的小数长度确定小数点的位置. 那么,输入的问题解决了,后来在写快速幂的时候发现最终的数据过大,没有办法用64位整数存储.就以为是高精快速幂.后来观察数据,发现指数数据范围较小,可以用高精度乘法解决这个问题.于是最终确定为使用高精乘解决这个问题. #

poj 1001 java大精度

import java.io.* ; import java.math.* ; import java.util.* ; import java.text.* ; public class Main { public static void main(String[] args) { Scanner cin=new Scanner (System.in) ; BigDecimal A; int B ; while(cin.hasNext()){ A=cin.nextBigDecimal() ;

POJ 1001 Exponentiation 模拟小数幂

模拟小数幂 小数点位 pos 非零末位 e 长度 len 只有三种情况 pos > len pos < e e < pos < len 1 #include <iostream> 2 #include <cstring> 3 using namespace std; 4 int a[500], b[500], c[500]; 5 void Cal() 6 { 7 memset(c, 0, sizeof(c)); 8 for(int i = 0; i <