题目1145:Candy Sharing Game

题目描述:

A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the
right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.

Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

输入:

The input may describe more than one game. For each game, the input begins with the number N of students,followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number
is on a line by itself.

输出:

For each game, output the number of rounds of the game followed by the amount of candy each child ends up with,both on one line.

样例输入:
6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0
样例输出:
15 14
17 22
4 8
提示:

The game ends in a finite number of steps because:

1. The maximum candy count can never increase.

2. The minimum candy count can never decrease.

3. No one with more than the minimum amount will ever decrease to the minimum.

4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase

来源:

2009年北京大学计算机研究生机试真题

 #include<stdio.h>
    int a[1000],b[1000];
    int main(){
           int n,i;
            while(scanf("%d",&n)!=EOF){
                        if(n==0)
                            break;
                       int count=0,k=1,signal=0;
                       for(i=0;i<n;i++)
                     scanf("%d",&a[i]);
                               while(signal!=1){
                               for(i=0;i<n;i++){
                                            a[i]=a[i]/2;
                                            if(i==n-1)
                                                    b[0]=a[i];
                                            else
                                                    b[k++]=a[i];
                               }
                               for(i=0;i<n;i++){
                                      a[i]=a[i]+b[i];
                                      if(a[i]%2==1)
                                              a[i]++;
                               }
                               count++;//进行的次数
                               int t=0;
                   for(i=0;i<n;i++){
                                    if(a[i]==a[0])
                                       t++;
                               }
                               if(t==n){
                                      signal=1;
                               }
                            k=1;
                               }
                               printf("%d %d\n",count,a[0]);

            }
    return 0;
    }
/**************************************************************
    Problem: 1145
    User: Carvin
    Language: C++
    Result: Accepted
    Time:10 ms
    Memory:1028 kb
****************************************************************/

时间: 2024-08-03 12:18:08

题目1145:Candy Sharing Game的相关文章

ACM-模拟之Candy Sharing Game——hdu1034

Candy Sharing Game Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2897    Accepted Submission(s): 1811 Problem Description A number of students sit in a circle facing their teacher in the cent

hdu 1034 Candy Sharing Game

Candy Sharing Game Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4942    Accepted Submission(s): 3020 Problem Description A number of students sit in a circle facing their teacher in the cente

HDU 1034 Candy Sharing Game 模拟题

一个分糖游戏,找了会规律,没找到,只能直接模拟玩了. 果然0ms过了,看来数据不大,只是考编码能力罢了. #include <stdio.h> #include <vector> #include <string.h> #include <algorithm> #include <iostream> #include <string> #include <limits.h> #include <stack> #

POJ 题目1145/UVA题目112 Tree Summing(二叉树遍历)

Tree Summing Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 8132   Accepted: 1949 Description LISP was one of the earliest high-level programming languages and, with FORTRAN, is one of the oldest languages currently being used. Lists, w

J - Candy Sharing Game(模拟题)

主要是理解题目意思,然后就按照它说的来模拟就好了. Description A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of h

题目1468:Sharing

题目描述: To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are st

Candy Sharing Game(hdoj1034)

Problem Description A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to

sicily 1052. Candy Sharing Game

Constraints Time Limit: 1 secs, Memory Limit: 32 MB Description A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simu

ACM训练方案-POJ题目分类

ACM训练方案-POJ题目分类 博客分类: 算法 ACM online Judge 中国: 浙江大学(ZJU):http://acm.zju.edu.cn/ 北京大学(PKU):http://acm.pku.edu.cn/JudgeOnline/ 杭州电子科技大学(HDU):http://acm.hdu.edu.cn/ 中国科技大学(USTC):http://acm.ustc.edu.cn/ 北京航天航空大学(BUAA)http://acm.buaa.edu.cn/oj/index.php 南京