ACM学习历程—POJ1151 Atlantis(扫描线 && 线段树)

Description

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

Input

The input consists of several test cases. Each test case starts with a line containing a single integer n (1 <= n <= 100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0 <= x1 < x2 <= 100000;0 <= y1 < y2 <= 100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.         The input file is terminated by a line containing a single 0. Don‘t process it.

Output

For each test case, your program should output one section. The first line of each section must be "Test case #k", where k is the number of the test case (starting with 1). The second one must be "Total explored area: a", where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.         Output a blank line after each test case.

Sample Input

2
10 10 20 20
15 15 25 25.5
0

Sample Output

Test case #1
Total explored area: 180.00 

题目就是求所有矩形的并面积。

通过查阅知道了是扫描线,了解了扫描线的原理,用线段树手写了一下,结果PushUp函数写搓了。。看了AC的代码才知道了原因。

做法就是通过对纵坐标有序化,然后创建区间。

然后通过横向扫描过去,得到每段横向段的高度,乘以宽度就是面积了。

代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#define LL long long

using namespace std;

//线段树
//扫描线
const int maxn = 205;
struct node
{
    int lt, rt;
    double height;
    int num;
}tree[4*maxn];

struct Line
{
    double x;
    double y1, y2;
    bool isLeft;
}line[maxn];

bool cmp(Line a, Line b)
{
    return a.x < b.x;
}

double y[maxn];

//向上更新
void PushUp(int id)
{
    if(tree[id].num > 0)
    {
        tree[id].height = y[tree[id].rt] - y[tree[id].lt];
        return;
    }
    if(tree[id].lt+1 == tree[id].rt)
        tree[id].height = 0;
    else
        tree[id].height = tree[id<<1].height + tree[id<<1|1].height;
}

//建立线段树
void Build(int lt, int rt, int id)
{
    tree[id].lt = lt;
    tree[id].rt = rt;
    tree[id].height = 0;//每段的初值,根据题目要求
    tree[id].num = 0;
    if (lt+1 == rt)
    {
        //tree[id].val = 1;
        return;
    }
    int mid = (lt + rt) >> 1;
    Build(lt, mid, id<<1);
    Build(mid, rt, id<<1|1);
    //PushUp(id);
}

//寻找符合修改的区间通过判断num进行修改
void Updata(int id,Line p)
{
    if(p.y1 <= y[tree[id].lt] && p.y2 >= y[tree[id].rt])
    {
        if (p.isLeft > 0)
            tree[id].num++;
        else
            tree[id].num--;
        PushUp(id);
        return;
    }
    int mid = (tree[id].lt+tree[id].rt) >> 1;
    if (p.y1 < y[mid])
        Updata(id<<1, p);
    if (p.y2 > y[mid])
        Updata(id<<1|1, p);
    PushUp(id);
}

int n;

void Input()
{
    double x1, y1, x2, y2;
    int cnt = 1;
    for (int i = 0; i < n; ++i)
    {
        scanf("%lf%lf%lf%lf", &x1, &y1, &x2, &y2);
        y[cnt] = y1;
        y[cnt+1] = y2;

        line[cnt].x = x1;
        line[cnt].y1 = y1;
        line[cnt].y2 = y2;
        line[cnt].isLeft = true;

        line[cnt+1].x = x2;
        line[cnt+1].y1 = y1;
        line[cnt+1].y2 = y2;
        line[cnt+1].isLeft = false;
        cnt += 2;
    }
    sort(y+1, y+1+2*n);
    sort(line+1, line+1+2*n, cmp);
    Build(1, 2*n, 1);
}

double Work()
{
    double ans = 0;
    Updata(1, line[1]);
    int len = 2*n;
    for (int i = 2; i <= len; ++i)
    {
        ans +=  (line[i].x-line[i-1].x) * tree[1].height;
        Updata(1, line[i]);
    }
    return ans;
}

int main()
{
    //freopen("test.in", "r", stdin);
    int times = 1;
    while (scanf("%d", &n) != EOF && n)
    {
        Input();
        double ans = Work();
        printf("Test case #%d\n", times);
        printf("Total explored area: %.2lf\n\n", ans);
        times++;
    }
    return 0;
}
时间: 2024-11-10 11:09:43

ACM学习历程—POJ1151 Atlantis(扫描线 && 线段树)的相关文章

poj1151 Atlantis——扫描线+线段树

题目:http://poj.org/problem?id=1151 经典的扫描线问题: 可以用线段树的每个点代表横向被矩形上下边分割开的每一格,这样将一个矩形的出现或消失化为线段树上的单点修改: 每个格子记录两个值:c(矩形存在情况),sum(对当前答案作出贡献的长度): 将y离散化作为建树的依据: 一开始没想到线段树上的点应该是横向的格子,写了个乱七八糟: #include<iostream> #include<cstdio> #include<cstring> #i

ACM学习历程—HDU 2795 Billboard(线段树)

Description At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in th

ACM学习历程—HDU 5289 Assignment(线段树)

Problem Description Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a gr

POJ 1151 Atlantis 扫描线+线段树

点击打开链接 Atlantis Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 17252   Accepted: 6567 Description There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of pa

ACM学习历程—HDU 5023 A Corrupt Mayor&#39;s Performance Art(广州赛区网赛)(线段树)

Problem Description Corrupt governors always find ways to get dirty money. Paint something, then sell the worthless painting at a high price to someone who wants to bribe him/her on an auction, this seemed a safe way for mayor X to make money. Becaus

【POJ1151】Atlantis(线段树,扫描线)

[POJ1151]Atlantis(线段树,扫描线) 题面 Vjudge 题解 学一学扫描线 其实很简单啦 这道题目要求的就是若干矩形的面积和 把扫描线平行于某个轴扫过去(我选的平行\(y\)轴扫) 这样只需要求出每次和\(x\)轴覆盖的长度 就可以两两相乘,求出面积 最后累计和就行啦 #include<iostream> #include<cstdio> #include<cstdlib> #include<cstring> #include<cma

poj 1151 Atlantis (离散化 + 扫描线 + 线段树)

题目链接题意:给定n个矩形,求面积并,分别给矩形左上角的坐标和右上角的坐标. 分析: 1 #include <iostream> 2 #include <cstdio> 3 #include <vector> 4 #include <cstring> 5 #include <cstdlib> 6 #include <algorithm> 7 #define LL __int64 8 #define lson l, mid, 2*rt

hdu1542 Atlantis(扫描线+线段树+离散)矩形相交面积

题目链接:点击打开链接 题目描写叙述:给定一些矩形,求这些矩形的总面积.假设有重叠.仅仅算一次 解题思路:扫描线+线段树+离散(代码从上往下扫描) 代码: #include<cstdio> #include <algorithm> #define MAXN 110 #define LL ((rt<<1)+1) #define RR ((rt<<1)+2) using namespace std; int n; struct segment{ double l

POJ 1151 Atlantis(线段树 + 扫描线)

转载请注明原文:http://www.cnblogs.com/burning-flame/p/5934653.html 题目链接:http://poj.org/problem?id=1151 题意: 给你 n 个矩形的对角线坐标,求 n 个矩形并集的面积. 做法: 扫描线 + 线段树. 因为作线段树的题遇到了扫描线,只是粗浅的了解了一下. 就像字面上的:线性扫描一遍,对于每个单元,因为某些事件的发生会有一些变化. 举个例子: 现有长度为 n 的数组a,同时有 n 个区间覆盖[li, ri],对于