二分原理
在高中方程根这一相关内容中我们就接触过二分法;二分原理并不是很陌生
就是在一个大范围内每次根据数据不断折半缩小范围,找到近似解。(不再过多赘述)
Pie
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 17735 Accepted Submission(s): 6215
Problem Description
My birthday is coming up and traditionally I‘m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.
My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.
What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327
3.1416
50.2655
解题思路
若干的小伙伴分若干块饼。小饼扔掉;大饼分开;所以每次用二分法求出分饼的大小后代回判断是否满足每个小伙伴都有形同大小饼的要求。
代码样例
#include <bits/stdc++.h>
using namespace std;
const double PI=acos(-1.0);
const double jd=1e-6; //这里控制精度,本题要求精度到小数点后四位,可以改为1e-4
double pine[10005];
int t,nr,np;
int check(double mid)
{
int sum=0;
for(int i=0; i < nr; i++)
sum+=(int)(pine[i]/mid);
if(sum > np)
return 1;
else
return 0;
}
int main()
{
cin >> t;
while(t--)
{
double ri=0;
double le=0,mid;
cin >> nr >> np;
for(int i=0; i < nr; i++)
{
int r;
cin >> r;
pine[i]=PI*r*r;
ri+=pine[i]; //这里的二分初始最大边界可以另设一个大数
}
while(ri-le > jd)
{
mid=(ri+le)/2;
if(check(mid))
le=mid;
else
ri=mid;
}
printf("%.4lf\n",mid);
}
return 0;
}
原文地址:https://www.cnblogs.com/cafu-chino/p/10262470.html