Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14870 Accepted Submission(s): 10469
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4 10 20
Sample Output
5 42 627
Author
Ignatius.L
题目不能再经典了!简直就是 模版的雏形!
#include<iostream> using namespace std; int main() { int n,i,j,k,cnt[125],dic[125]; while(cin>>n) { for(i=0; i<=n; i++) { cnt[i]=1; dic[i]=0; } for( int m=2; m<=n; m++) { for(j=0; j<=n; j++) for(k=0; k+j<=n; k+=m) { dic[j+k]+=cnt[j]; } for(int p=0; p<=n; p++) { cnt[p]=dic[p]; dic[p]=0; } } cout<<cnt[n]<<endl; } }