(poj)3268 Silver Cow Party 最短路

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow‘s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output

Line 1: One integer: the maximum of time any one cow must walk.
Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output

10

题目网址:http://poj.org/problem?id=3268

题意:有N只牛,编号从1到N他们从自己的地方到X去开会然后再回来,他们都选择最短的路径,问从去到回来,每只牛走的最远距离是多少?

方法:先求从X到各个点的最短路,然后把路径交换一下,再求一次从x到各点的最短路

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <math.h>
#include <vector>
using namespace std;
#define N  1010
#define ll long long
#define INF 0x3f3f3f3f
#define met(a,b) memset(a,b,sizeof(a));
vector<vector<int> >Q;
struct node
{
    int u,l,next;
}s[200020];
int a[N],b[N],k,n;
int vis[N],used[N],dis1[N],dis[N];
void add(int e,int f,int l)
{
    s[k].u=f;
    s[k].l=l;
    s[k].next=a[e];
    a[e]=k++;
    s[k].u=e;
    s[k].l=l;
    s[k].next=b[f];
    b[f]=k++;
}
void spfa1(int x)
{
    met(vis,0);met(used,0);
    for(int i=1;i<=n;i++)
        dis1[i]=INF;
    queue<int>q;
    int p=x,v;
    q.push(p);
    vis[x]=1;
    dis1[x]=0;
    used[x]=1;
    while(q.size())
    {
        p=q.front();
        vis[p]=0;
        q.pop();
        for(int i=a[p];i!=-1;i=s[i].next)
        {
            v=s[i].u;
            if(dis1[v]>dis1[p]+s[i].l)
            {
                dis1[v]=dis1[p]+s[i].l;
                q.push(v);
                vis[v]=1;
            }

        }

    }
}
void spfa2(int x)
{
    met(vis,0);met(used,0);
    for(int i=1;i<=n;i++)
        dis[i]=INF;
    queue<int>q;
    int p=x,v;
    q.push(p);
    vis[x]=1;
    dis[x]=0;
    used[x]=1;
    while(q.size())
    {
        p=q.front();
        vis[p]=0;
        q.pop();
        for(int i=b[p];i!=-1;i=s[i].next)
        {
            v=s[i].u;
            if(dis[v]>dis[p]+s[i].l)
            {
                dis[v]=dis[p]+s[i].l;
                q.push(v);
                vis[v]=1;
            }

        }

    }
}
int main()
{
    int m,x,e,f,l;
    while(scanf("%d %d %d",&n,&m,&x)!=EOF)
    {
        k=0;
        met(a,-1);met(b,-1);
        for(int i=0;i<m;i++)
        {
            scanf("%d %d %d",&e,&f,&l);
            add(e,f,l);
        }
        //int ans=spfa1();
        int ans=0;
        spfa1(x);
          spfa2(x);
        for(int i=1;i<=n;i++)
        {
            ans=max(ans,dis[i]+dis1[i]);
        }

        printf("%d\n",ans);
    }
    return 0;
}
时间: 2024-10-10 17:50:05

(poj)3268 Silver Cow Party 最短路的相关文章

POJ 3268 Silver Cow Party 最短路—dijkstra算法的优化。

POJ 3268 Silver Cow Party Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects

poj 3268 Silver Cow Party(最短路)

poj 3268 Silver Cow Party Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects

POJ 3268 Silver Cow Party dijkstra单源最短路

裸dijkstra 思路:以x为源点,求到其他点的最短路,之后把邻接矩阵转置,再求一次x源 点的最短路,这样就一次是来的,一次是走的,相加迭代最大值即可 代码: /* poj 3268 8108K 47MS */ #include<cstdio> #include<iostream> #define MAXN 1005 #define MAX_INT 2147483647 using namespace std; int gra_in[MAXN][MAXN],gra_out[MAX

POJ 3268 Silver Cow Party(SPFA)

Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i re

图论 ---- spfa + 链式向前星 ---- poj 3268 : Silver Cow Party

Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 12674   Accepted: 5651 Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X 

poj 3268 Silver Cow Party , spfa , dijkstra

点击打开链接 两次求最短路(第二次把边反向求) 1.spfa //poj 3268 Silver Cow Party //SPFA #include <cstdio> #include <cstring> #include <queue> using namespace std; const int M = 100000 + 100; const int N = 1000 + 100; const int inf = 1<<25; struct Graph

POJ 3268 Silver Cow Party (来回最短路 SPFA)

Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 14384   Accepted: 6490 Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤X ≤

poj 3268 Silver Cow Party (最短路)

Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 12913   Accepted: 5778 Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X 

poj 3268 Silver Cow Party 【最短路Dijkstra + 结构体妙用】

Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u Submit Status Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (

POJ 3268 Silver Cow Party(最短路dijkstra)

Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 15451   Accepted: 6997 Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X