POJ 题目2983 Is the Information Reliable?(差分约束)

Is the Information Reliable?

Time Limit: 3000MS   Memory Limit: 131072K
Total Submissions: 11859   Accepted: 3742

Description

The galaxy war between the Empire Draco and the Commonwealth of Zibu broke out 3 years ago. Draco established a line of defense called Grot. Grot is a straight line with N defense stations. Because of the cooperation of the stations, Zibu’s Marine
Glory cannot march any further but stay outside the line.

A mystery Information Group X benefits form selling information to both sides of the war. Today you the administrator of Zibu’s Intelligence Department got a piece of information about Grot’s defense stations’ arrangement from Information Group X. Your task
is to determine whether the information is reliable.

The information consists of M tips. Each tip is either precise or vague.

Precise tip is in the form of P A B X, means defense station A is X light-years north of defense station B.

Vague tip is in the form of V A B, means defense station A is in the north of defense station B, at least 1 light-year, but the precise distance is unknown.

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 1000) and M (1 ≤ M ≤ 100000).The next M line each describe a tip, either in precise form or vague form.

Output

Output one line for each test case in the input. Output “Reliable” if It is possible to arrange N defense stations satisfying all the M tips, otherwise output “Unreliable”.

Sample Input

3 4
P 1 2 1
P 2 3 1
V 1 3
P 1 3 1
5 5
V 1 2
V 2 3
V 3 4
V 4 5
V 3 5

Sample Output

Unreliable
Reliable

Source

POJ Monthly--2006.08.27, Dagger

http://blog.csdn.net/lyy289065406/article/details/6648688

ac代码

#include<stdio.h>
#include<string.h>
#include<queue>
#include<string>
#include<iostream>
#define INF 0xfffffff
using namespace std;
int head[1010],vis[1010],cnt,dis[1010],s,cot[1010];
int n,m;
struct s
{
	int u,v,w,next;
}edge[300200];
void add(int u,int v,int w)
{
	edge[cnt].u=u;
	edge[cnt].v=v;
	edge[cnt].w=w;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}
int spfa(int s)
{
	int i;
	for(i=1;i<=n;i++)
	{
		dis[i]=INF;
	}
	memset(vis,0,sizeof(vis));
	memset(cot,0,sizeof(cot));
	dis[s]=0;
	vis[s]=1;
	queue<int>q;
	q.push(s);
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=0;
		cot[u]++;
		if(cot[u]>n)
			return 0;
		for(i=head[u];i!=-1;i=edge[i].next)
		{
			int v=edge[i].v;
			int w=edge[i].w;
			if(dis[v]>dis[u]+w)
			{
				dis[v]=dis[u]+w;
				if(!vis[v])
				{
					vis[v]=1;
					q.push(v);
				}
			}
		}
	}
	return 1;
}
int main()
{
	//	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		char str[2];
		int i;
		memset(head,-1,sizeof(head));
		cnt=0;
		for(i=0;i<m;i++)
		{
			scanf("%s",str);
			if(str[0]=='P')
			{
				int a,b,c;
				scanf("%d%d%d",&a,&b,&c);
				add(a,b,c);
				add(b,a,-c);
			}
			else
			{
				int a,b;
				scanf("%d%d",&a,&b);
				add(b,a,-1);
			}
		}
		s=n+1;
		for(i=1;i<=n;i++)
		{
			add(s,i,0);
		}
		if(spfa(s))
			printf("Reliable\n");
		else
			printf("Unreliable\n");
	}
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-08-07 21:16:54

POJ 题目2983 Is the Information Reliable?(差分约束)的相关文章

POJ 2983 Is the Information Reliable? 差分约束

裸差分约束. //#pragma comment(linker, "/STACK:1024000000,1024000000") #include<cstdio> #include<cstring> #include<cstdlib> #include<algorithm> #include<iostream> #include<sstream> #include<cmath> #include<

【poj 2983】Is the Information Reliable? 差分约束

题目:http://poj.org/problem?id=2983 Is the Information Reliable? Time Limit: 3000MS Memory Limit: 131072K Total Submissions: 12535 Accepted: 3943 Description The galaxy war between the Empire Draco and the Commonwealth of Zibu broke out 3 years ago. Dr

POJ训练计划2983_Is the Information Reliable?(差分约束)

解题报告 思路: 求解: p:a-b=x v:a-b>=1 的方程 #include <iostream> #include <cstring> #include <cstdio> #include <queue> #define inf 0x3f3f3f3f using namespace std; struct node { int v,w,next; } edge[220000]; int head[1111],dis[1111],vis[111

【POJ2983】Is the Information Reliable? ——差分约束

题目大意:一天南北线上有n个防御站,给出他们之间的位置关系,问有没有可能存在这样一种位置布置符合所给的位置关系.关系有两种,一种是 P A B X,表示A在B北边X光年的位置,V A B表示A在B北边至少1光年位置. 分析:仍然考虑差分约束,容易想到,若关系为P,则 s[a]-a[b]=c; 变换一下则变成: s[b]-s[a]<=-c; s[a]-a[b]<=c; 若关系为V,则 s[b]-s[a]<=-1; 这样转换之后就变成了求最短路了,注意这道题可能无解,无解即表现为存在负环,判

POJ 2983 Is the Information Reliable?

/* *POJ 2983 Is the Information Reliable? *差分约束系统 *(1)对于确定信息 P A B X, 有 A - B >= X && A - B <= X 即 B <= A + (-X) && A <= B + X * 即构成边<A, B, -X> 和 <B, A, X> *(2)对于不确定信息 V A B, 有 A - B >= 1, 即 B <= A + (-1) * 即构

POJ 2983 Is the Information Reliable? 信息可靠吗 (差分约束,spfa)

题意:有n个站排成一列,针对每个站的位置与距离关系,现有多个约束条件,约束条件分两种:(1)确定的.明确说明站a距离站b多少个单位距离.(2)不确定的.只知道a在b的左边至少1个单位距离.  根据已知条件,问有没有冲突?不冲突则输出reliable. 思路: 第2种条件比较好确定,如果知道如何用最短路解差分约束的话. 问题在第1种,明确地说明了距离,怎么办?拆成两条式子,比如 dis(a,b)=c,那么可以写成 b-a>=c ,b-a<=c 这样,只要满足这两个条件,原来明确说明的距离也会成立

POJ 2983-Is the Information Reliable?(差分约束系统)

题目地址:POJ 2983 题意:有N个车站.给出一些点的精确信息和模糊信息.精确信息给出两点的位置和距离.模糊信息给出两点的位置.但距离大于等于一.试确定是否全部的信息满足条件. 思路:事实上就是让你推断是否存在负环.好久才看明确.对于精确消息.能够得出两个差分公式:dis[v] <= dist[u] - w  &&  dist[u] <= dist[v] + w.对于模糊信息.能够得出dis[v] <= dis[u] -1. PS:做差分约束感觉还是Bellman_f

POJ 3159 Candies(SPFA+栈)差分约束

题目链接:http://poj.org/problem?id=3159 题意:给出m给 x 与y的关系.当中y的糖数不能比x的多c个.即y-x <= c  最后求fly[n]最多能比so[1] 多多少糖? 差分约束问题, 就是求1-n的最短路,  队列实现spfa 会超时了,改为栈实现,就可以 有负环时,用栈比队列快 数组开小了,不报RE,报超时 ,我晕 #include <iostream> #include <cstdlib> #include <cstdio>

POJ 2983 Is the Information Reliable?(差分约束系统)

题目地址:POJ 2983 这题刚上来完全不知道跟差分约束系统有什么关系.....后来发现只要判个负环就可以.. 因为假如有冲突的话会形成一个负环.之所以建图加上一个正值一个负值,是因为这样的话,像1 2 4和1 2 3这样的数据就会形成一个负环.这个方法还是很巧妙的...然后对于V的那些不清楚的位置,就会跟P的那些等式联立形成一个不等式,然后在用最短路判环的过程中就用松弛来解决. 代码如下: #include <iostream> #include <cstdio> #inclu