蚂蚁问题poj1852

*/-->

pre.src {background-color: Black; color: White;}

pre.src {background-color: Black; color: White;}

pre.src {background-color: Black; color: White;}

pre.src {background-color: Black; color: White;}

蚂蚁问题poj1852

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

错误:

使用 cin和cout去输入和输出,超时....
// CreateTime: 2015-04-07 22:33:03

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>

using namespace std;

const int maxn = 1000005;
int l;
int n;
int a[maxn];

int main(void) {
    int t;
    scanf("%d", &t);
    while(t--) {
        scanf("%d%d", &l, &n);
        for (int i = 0; i < n; i++) {
            scanf("%d", &a[i]);
        }

        int minT = 0;
        for (int i = 0; i < n; i++) {
            minT = max(minT, min(a[i], l-a[i]));
        }

        int maxT = 0;
        for (int i = 0; i < n; i++) {
            maxT = max(maxT, max(a[i], l-a[i]));
        }

        printf("%d %d\n", minT, maxT);
    }
    return 0;
}
时间: 2024-12-15 01:50:42

蚂蚁问题poj1852的相关文章

POJ1852 Ants 题解

题目 An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions

多个蚂蚁过独木桥,求通过的最长时间和最短时间

首先对题目进行分析: 求最长时间也就是最后掉下去的一只蚂蚁需要经历的最长时间: 求最短时间也就是最后掉下去的一只蚂蚁需要经历的最短时间:所以让所有的蚂蚁都向距离它们最近的那一段走,这样它们每个走的时间是短的,再求它们中用时最短的那个时间: 分析最长时间如下图所示: /************************************************************************* > File Name: 162.cpp > Author: > Mail:

蚂蚁问题

最近做了几个蚂蚁问题,还蛮有趣的..... 蚂蚁问题第一弹:poj 1852 Ants: Ants Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 12214   Accepted: 5366 Description An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a w

《挑战程序竞赛》1.6.2 Ants poj1852

题意:n只蚂蚁以每秒1cm的速度在长为Lcm的竿子上爬行.当蚂蚁爬到竿子的端点时就会掉落.由于竿子太细,两只蚂蚁相遇时,它们不能交错通过,只能各自反向爬回去.对于每只蚂蚁,我们知道它距离竿子左端的距离xi,但不知道它当前的朝向.请计算所有蚂蚁落下竿子所需的最短时间和最长时间. 解法:(1)对于最短时间,所有蚂蚁都朝向较近的端点走时时间最短,因为这种情况下不会发生两只蚂蚁相遇的情况,所以只要求出这种情况下最后一只到端点的蚂蚁的时间即可,时间亦最短. (2)对于最长时间,如果不考虑蚂蚁的实际体长等外

2017辽宁冬令营-4.蚂蚁

蚂蚁(ant.pas/c/cpp)题目大意在平面上有 N 只蚂蚁 N 个树洞,每个树洞只能容纳下一只蚂蚁,蚂蚁们都是直线行走的. 现在蚂蚁们希望能进入树洞中, 希望你能构造出一种方案使得任意两个蚂蚁的路线不相交.保证不会出现三点共线的情况.对于有多种不同的解,输出任意一组即可.无解时,输出-1.输入文件输入文件为 ant.in.第一行为一个数 N.接下来 N 行,每行两个非负整数,第 i+1 行为第 i 号蚂蚁的坐标.接下来 N 行,每行两个非负整数,第 i+N+1 行为第 i 号树洞的坐标.输

[zz]蟑螂蚂蚁蚊子已不住在我家了!这个方法100%见效…

http://mt.sohu.com/20150324/n410238511.shtml 蚂蚁怕酸,蚊子怕辣,蟑螂怕香.在下给各位提供一个不杀生又能驱赶蚂蚁.蚊子.蟑螂的妙法. 一.蚂蚁怕酸味 家里的甜食摆没几分钟,蚂蚁大军立即来袭,让人又气又厌,献给各位一项无毒无污染又安全有效的妙招: 整粒的新鲜柠檬,对切成两半,在看得到蚂蚁的地方及其动线,挤出柠檬汁,并拿着切半有果肉的那一面,沿途涂抹,神奇效果让您再一次验证大自然的奥妙! 二.蚊子怕辣味 蒜头呛退.将蒜头分植于花坛四周,其特殊的辛辣味隐隐飘

懒蚂蚁效应:成功的秘诀在于懒于杂物,勤于思考

概念:懒蚂蚁效应 日本北海道大学进化生物研究小组对一群黑蚂蚁进行了研究.他们把蚂蚁分为三个小组,每组30只,观察他们的行为.研究人员发现,大部分蚂蚁都很勤快地工作,寻找.搬运食物,但是却有少部分蚂蚁好像整天无所事事一样地东张西望. 研究人员在这群蚂蚁身上做上标记,并把这群蚂蚁称为:懒蚂蚁,然后,断绝了整个蚁群的食物来源.有趣的是,这时候那些平时工作很勤快的蚂蚁,突然都不知所措了,而那些"懒蚂蚁"们却挺身而出,带领蚂蚁们向他们侦查到的其它食物转移. 原来,这些"懒蚂蚁"

[OpenJudge 3064]坠落的蚂蚁

试题描述 一根长度为1米的木棒上有若干只蚂蚁在爬动.它们的速度为每秒一厘米或静止不动,方向只有两种,向左或者向右.如果两只蚂蚁碰头,则它们立即交换速度并继续爬动.三只蚂蚁碰头,则两边的蚂蚁交换速度,中间的蚂蚁仍然静止.如果它们爬到了木棒的边缘(0或100厘米处)则会从木棒上坠落下去.在某一时刻蚂蚁的位置各不相同且均在整数厘米处(即1,2,3,…99厘米),有且只有一只蚂蚁A速度为0,其他蚂蚁均在向左或向右爬动.给出该时刻木棒上的所有蚂蚁位置和初始速度,找出蚂蚁A从此时刻到坠落所需要的时间. 输入

九度oj 题目1159:坠落的蚂蚁

题目描述: 一根长度为1米的木棒上有若干只蚂蚁在爬动.它们的速度为每秒一厘米或静止不动,方向只有两种,向左或者向右.如果两只蚂蚁碰头,则它们立即交换速度并继续爬动.三只蚂蚁碰头,则两边的蚂蚁交换速度,中间的蚂蚁仍然静止.如果它们爬到了木棒的边缘(0或100厘米处)则会从木棒上坠落下去.在某一时刻蚂蚁的位置各不相同且均在整数厘米处(即1,2,3,…99厘米),有且只有一只蚂蚁A速度为0,其他蚂蚁均在向左或向右爬动.给出该时刻木棒上的所有蚂蚁位置和初始速度,找出蚂蚁A从此时刻到坠落所需要的时间. 输