POJ--2063--Investment--背包

Investment

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 8733   Accepted: 2984

Description

John never knew he had a grand-uncle, until he received the notary‘s letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor.

John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him.

This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized
that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated.

Assume the following bonds are available:

Value Annual

interest

4000

3000

400

250

With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes
sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000,
giving a yearly interest of $1 200.

Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

Input

The first line contains a single positive integer N which is the number of test cases. The test cases follow.

The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40).

The following line contains a single number: the number d (1 <= d <= 10) of available bonds.

The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is
never more than 10% of its value.

Output

For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

Sample Input

1
10000 4
2
4000 400
3000 250

Sample Output

14050

题意:有多个存款方案,每个有两个属性值A和B,表示这个方案你要存A块钱,利息是B块钱每年,最先输入的是N和K,你有N的金钱,要求K年后你能得到的最多的金钱数

解析:这个就是普通的完全背包,不过注意的是数值太大,可以投机取巧,因为每中方案中存钱数A是1000的倍数,所以可以背包的下标可以除以1000之后再记录,但是你可能会想到误差问题,比如本金是1010,这时候1010/1000=1,别担心,你想啊,1000和1010存钱有区别么?这10块钱有用么?,存钱方案中都是1000的倍数,所以这些零头都不用管,到时候加上来就行了,我这里的做法是:因为每个利润都小于10%的,所以我去本金X(110%)^K于是得到最大可能的金钱数,用这个数除以1000当作背包的最大容量,DP[X]中装的是存钱为X块的时候的利息,这样我直接完全背包做完之后,再记录sum=N+(N+DP[M])+(N+DP[N]+DP[N+DP[N]]).....这样K次之后就。。。。你会懂的。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define Max(a,b) a>b?a:b
using namespace std;
int dp[111111];
struct node
{
    int val,interest;
}s[11];
int main (void)
{
    int t,n,m,i,j,k,l,p;
    scanf("%d",&t);
    while(t--&&scanf("%d%d",&m,&l))
    {
        scanf("%d",&n);
        k=m;
        for(i=0;i<l;i++)
        {
            k=1.1*k;	//用K来取m乘以1.1的L次方
        }
        k/=1000;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&s[i].val,&s[i].interest);
            s[i].val/=1000;	//方案中存钱量除以1000
        }
        memset(dp,0,sizeof(dp));
        for(i=0;i<n;i++)	//直接完全背包
        for(j=s[i].val;j<=k;j++)
        dp[j]=Max(dp[j],dp[j-s[i].val]+s[i].interest);
        while(l>0)	//求l年后的总利息
        {
            l--;
            m+=dp[m/1000];	//把每年的利息加起来并把M变成那一年的本金继续求
        }
        printf("%d\n",m);
    }
    return 0;
}

总结:这是把容量根据条件缩小的一种做法,在做题的时候要根据已知条件充分挖掘一切可以简化的方法,有些时候这题目考的就是这个,就像这题一样,不会这么简化的话,你就等着GG到死吧。。。

时间: 2024-10-19 01:47:20

POJ--2063--Investment--背包的相关文章

POJ 2063 Investment

POJ 2063 Investment 完全背包 fakeDescription: 吃土魔法少女经济不景气辣! 变出借来了为1000的倍数的钱打算去投资股票辣! (顺便吃土少女说她最多只能借来1000000元)告诉你吃土少女将会吃土投资几年以及每种股票的年收益和每一股的价格 现在吃土少女任命你为投资顾问制定每年的投资方案最大化收益.吃土少女不关心你怎么买的.只需要你写个程序告诉她她最后持有多少财富.吃土少女等着你来拯救! 以上题目描述都是我口胡的.233.不过意思对了就行了233 由于每年有一次

POJ 2063 Investment (完全背包)

A - Investment Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 2063 Description John never knew he had a grand-uncle, until he received the notary's letter. He learned that his late grand-uncle

POJ 2063 Investment 完全背包

题目链接:http://poj.org/problem?id=2063 今天果然是卡题的一天.白天被hdu那道01背包的变形卡到现在还没想通就不说了,然后晚上又被这道有个不大也不小的坑的完全背包卡了好久.这题主要是说让你选择不同的债券(每种债券的费用和年利率的属性),然后n年后使得本金最大,如果仅仅是问一年的话就是个裸完全背包的题了,不过它是n年,每年得到的总利息都会加入到本金中变为下一年的本金,知道了这个后就很好处理了,在这道题里每年变化的本金就是背包容量,然后债券那两个属性就是物品的费用(o

[POJ 2063] Investment (动态规划)

题目链接:http://poj.org/problem?id=2063 题意:银行每年提供d种债券,每种债券需要付出p[i]块钱,然后一年的收入是v[i],到期后我们把本金+收入取出来作为下一年度本金继续购买债券. 问你起始本金为n元,m年后你手里最多能有多少钱. 其实这题不难..我却想了一会.. 因为题目保证了p[i]是1000的倍数,所以我们可以把本金和p[i]都先除以1000,然后算出每年可能获得的最大收入,然后加到本金当中,在暴力枚举m年就行了. 设计状态dp[j]代表我花了不超过j元钱

POJ 2063 完全背包

Sample Input 1 10000 4 2 4000 400 3000 250 Sample Output 14050 题意: 给你本金 m 和年限 n ,以及 d 种债券(购买一年后就可以卖出)的花费及收益(卖出后的净利润) 在 d 种债券中不限制地购买(如果钱够) 问 n 年后的最大收益(含本金) m <= 1000000n <= 40d <= 10 题目中给出了两个关键的信息 : 债券的花费是1000的倍数,利率不超过10%因为花费是1000的倍数,所以可以将dp的复杂度降低

poj 2063 基础完全背包

这是一题基础的完全背包,适合初学者来理解完全背包 题意:有 n 种债券可以买 ,  每种债券的价格为 w , 每一年的收益为 p , 给你 wi 块钱 , 和 years 年的时间 , 我们最大的收益是是多少? 因为 , 每种债券可以买任意多个 , 所以这是一个简单的完全背包,但是由于基数(体积)太大 , 所以需要优化一下 : 由题意我们知道 , 每种债券的价格都是 1000 的倍数 , 那么我们就让每种债券的价格都 除以 1000 , 并且把 p 也除以 1000 , 这样就MTE , 也不会

POJ 1384 Piggy-Bank 背包DP

所谓的完全背包,就是说物品没有限制数量的. 怎么起个这么intimidating(吓人)的名字? 其实和一般01背包没多少区别,不过数量可以无穷大,那么就可以利用一个物品累加到总容量结尾就可以了. 本题要求装满的,故此增加个限制就可以了. #include <stdio.h> #include <stdlib.h> #include <string.h> inline int min(int a, int b) { return a < b? a : b; } c

poj 2184 0---1背包的变形

这题是0--1背包的变形,对理解0--1背包有很大的帮组 题意:要选一些牛去参见展览,每个牛有幽默.智慧两个选择标准,要求选的这些牛使得幽默和智慧的总和最大且幽默和智慧的每个总和都必须是大于等于0: 刚看的这个题目是时候,知道是一个0--1背包的的题目,但就是不知道怎么来写出状态转移方程,因为题中的两个变量都是有负值的. 看了大牛的解题报告才知道. 我们可以把幽默个变量看成是体积 , 智慧看成是价值. 我们可以把每个牛幽默的值 , 放在一个坐标上,让后整体往右移,使得最小值为 0 , 那么这时候

POJ 1014 Dividing 背包

这道题使用多重背包,不过其实我也不太明白为什么叫这个名字. 因为感觉不是什么多重,而是物体的分解问题. 就是比如一个物体有数量限制,比如是13,那么就需要把这个物体分解为1, 2, 4, 6 如果这个物体有数量为25,那么就分解为1, 2, 4, 8, 10 看出规律吗,就是分成2的倍数加上位数,比如6 = 13 - 1 - 2 - 4, 10 = 25 - 1 - 2 - 4 - 8,呵呵,为什么这么分解? 因为这样分解之后就可以组合成所有1到13的数,为25的时候可以组合成所有1到25的数啦

poj 1837 01背包

Balance Time Limit: 1000 MS Memory Limit: 30000 KB 64-bit integer IO format: %I64d , %I64u Java class name: Main [Submit] [Status] [Discuss] Description Gigel has a strange "balance" and he wants to poise it. Actually, the device is different fr