E - Speed Limit(2.1.1)

E - Speed Limit(2.1.1)

Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

Bill and Ted are taking a road trip. But the odometer in their car is broken, so they don‘t know how many miles they have driven. Fortunately, Bill has a working stopwatch, so they can record their speed and the total time they have driven. Unfortunately, their
record keeping strategy is a little odd, so they need help computing the total distance driven. You are to write a program to do this computation.

For example, if their log shows

Speed in miles perhour Total elapsed time in hours
20 2
30 6
10 7

this means they drove 2 hours at 20 miles per hour, then 6-2=4 hours at 30 miles per hour, then 7-6=1 hour at 10 miles per hour. The distance driven is then (2)(20) + (4)(30) + (1)(10) = 40 + 120 + 10 = 170 miles. Note that the total elapsed time is always
since the beginning of the trip, not since the previous entry in their log.

Input

The input consists of one or more data sets. Each set starts with a line containing an integer n, 1 <= n <= 10, followed by n pairs of values, one pair per line. The first value in a pair, s, is the speed in miles per hour and the second value, t, is the total
elapsed time. Both s and t are integers, 1 <= s <= 90 and 1 <= t <= 12. The values for t are always in strictly increasing order. A value of -1 for n signals the end of the input.

Output

For each input set, print the distance driven, followed by a space, followed by the word "miles"

Sample Input

3
20 2
30 6
10 7
2
60 1
30 5
4
15 1
25 2
30 3
10 5
-1

Sample Output

170 miles
180 miles
90 miles
#include<iostream>
using namespace std;
int main( )
{
	int n;
	int a,b,s,k;
   while(cin>>n&&n>0)
   {
	   s=0,k=0;
	   while(n--)
	   {
		   cin>>a>>b;
		   s=s+a*(b-k);
		   k=b;

	   }
	   cout<<s<<" miles"<<endl;
   }
    return 0;
} 

E - Speed Limit(2.1.1),布布扣,bubuko.com

时间: 2024-10-06 07:12:14

E - Speed Limit(2.1.1)的相关文章

zoj 2176 Speed Limit

Speed Limit Time Limit: 2 Seconds      Memory Limit: 65536 KB Bill and Ted are taking a road trip. But the odometer in their car is broken, so they don't know how many miles they have driven. Fortunately, Bill has a working stopwatch, so they can rec

POJ2017 Speed Limit

水题,用一个变量存一下上一个时间即可. Speed Limit Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 17698   Accepted: 12433 Description Bill and Ted are taking a road trip. But the odometer in their car is broken, so they don't know how many miles they have

[ACM] poj 2017 Speed Limit

Speed Limit Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 17030   Accepted: 11950 Description Bill and Ted are taking a road trip. But the odometer in their car is broken, so they don't know how many miles they have driven. Fortunately

POJ 2017 Speed Limit (直叙式的简单模拟 编程题目 动态属性很少,难度小)

Speed Limit Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 17578   Accepted: 12361 Description Bill and Ted are taking a road trip. But the odometer in their car is broken, so they don't know how many miles they have driven. Fortunately

poj 2017 Speed Limit

Speed Limit Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 17704   Accepted: 12435 Description Bill and Ted are taking a road trip. But the odometer in their car is broken, so they don't know how many miles they have driven. Fortunately

HDU 3030 - Increasing Speed Limits

Problem Description You were driving along a highway when you got caught by the road police for speeding. It turns out that they\'ve been following you, and they were amazed by the fact that you were accelerating the whole time without using the brak

hdu 3030 Increasing Speed Limits (离散化+树状数组+DP思想)

Increasing Speed Limits Time Limit: 2000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 481    Accepted Submission(s): 245 Problem Description You were driving along a highway when you got caught by the road p

HDU 2722 Here We Go(relians) Again (spfa)

Here We Go(relians) Again Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other) Total Submission(s) : 1   Accepted Submission(s) : 1 Font: Times New Roman | Verdana | Georgia Font Size: ← → Problem Description The Gorelians

FTP实战应用——FileZilla

FileZilla简介: FileZilla 客户端是一个快速可靠的.跨平台的FTP,FTPS和SFTP客户端.具有图形用户界面(GUI)和很多有用的特性. 相比较于其它FTP客户端,FileZilla 包含如下特性: 易于使用 支持FTP, FTP并支持SSL/TLS (FTPS)协议,支持SSH文件传输协议(SFTP) 跨平台.在 Windows, Linux, *BSD, Mac OS X 和其它平台下运行 more 支持IPv6协议 多种可用的语言(包含中文) 断点续传且支持容量大于4G