(hdu step 1.3.3)Tian Ji -- The Horse Racing(田忌赛马)

题目:

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4411 Accepted Submission(s): 1069
 

Problem Description

Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian‘s. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king‘s regular, and his super beat the king‘s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian‘s horses on one side, and the king‘s horses on the other. Whenever one of Tian‘s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.


Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.


Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.


Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0


Sample Output

200
0
0

 

Source

2004 Asia Regional Shanghai


Recommend

JGShining

题目大意:

这么长的一段扯淡的话,也是醉了。不过这也是体现实力的一部分啊。当时去成都现场赛的时候,记得有一道题扯了1页半纸,最后的一丝就是让你把空格键换成Tab键输出。。想想也是醉了。。。

题目分析:

一道简单的贪心的题目,挺经典的。田忌赛马这道题可以用很多种做法来做:贪心、DP、二分图的最大匹配什么的都可以做的。以下介绍一下用贪心来怎么做这道题。贪心策略如下:

1、如果田忌最慢的马比齐王最慢的马快,则比之。

2、如果田忌最慢的马比齐王最慢的马慢,则将田忌最慢的马和齐王最快的马比。//贪心的第一步.(横竖都是输,和最快的比能为后面创造有利的局势。如田忌:10   20  80   齐王: 11 30 80 。)

3、如果田忌最慢的马和齐王最慢的马速度一样。则进行以下分析

1)田忌最快的马比齐王最快的马要快,则比之

2)田忌最快的马比齐王最快的马要慢,则用田忌最慢的马比齐王最快的马。(为后面创造有利的局势)

3)田忌最快的马和齐王最快的马速度一样,则用田忌最慢的马比齐王最快的马。

当然这道题倒过来考虑也是可以的,也就是从快的开始分析也是可以的。

代码如下:

/*
 * c.cpp
 *
 *  Created on: 2015年1月29日
 *      Author: Administrator
 */

#include <iostream>
#include <cstdio>
#include <algorithm>//sort()函数在这个头文件里

using namespace std;

const int maxn = 1005;
int a[maxn];
int b[maxn];

int main(){
	int n;
	while(scanf("%d",&n)!=EOF,n){
		int i;
		for(i = 0 ; i < n ; ++i){
			scanf("%d",&a[i]);
		}

		for(i = 0 ; i < n ; ++i){
			scanf("%d",&b[i]);
		}

		//对数据进行排序,利用有序化数据尽心贪心选择.体现贪心思想
		sort(a,a+n);
		sort(b,b+n);

		int tl = 0;//用来标记田忌目前最慢的马
		int ql = 0;
		int tr = n-1;//用来标记天际目前最快的马
		int qr = n-1;

		int sum = 0;//最后田忌可以争取的金钱

		while(tl <= tr){//如果还没有比完
			if(a[tl] > b[ql]){//如果田忌最慢的马比齐王最慢的马要快
				//则田忌慢VS齐王慢
				sum += 200;

				tl++;
				ql++;
			}else if(a[tl] == b[ql]){//如果田忌最慢的马==齐王最慢的马
				while(tl <= tr && ql <= qr){//在还没有结束的情况下不断地进行比较
					if(a[tr] > b[qr]){//如果田忌最快的马比齐王最快的马要快
						//则田忌快VS齐王快
						sum += 200;

						tr--;
						qr--;
					}else{//在田忌最快的马比齐王最快的马要慢的情况下都是田忌慢VS齐王快

						if(a[tl] < b[qr]){//田忌最慢的马不一定要比齐王最快的马要慢。例如双方所有马匹的速度都是一样的
							sum -= 200;
						}

						tl++;
						qr--;
						break;
					}
				}
			}else{//如果田忌最慢的马比齐王最慢的马慢
				//则田忌慢VS齐王快
				sum -= 200;

				tl++;
				qr--;
			}
		}

		printf("%d\n",sum);
	}

	return 0;
}
时间: 2024-08-03 18:29:31

(hdu step 1.3.3)Tian Ji -- The Horse Racing(田忌赛马)的相关文章

hdu acm-step 1.3.2 Tian Ji -- The Horse Racing

本题的题意是:给出n匹马,每匹马都有一个固定的速度,结果有胜平负三种. 代码如下: #include <cstdio> #include <algorithm> using namespace std; int tian[1000]; int king[1000]; int win,lose; int n,i; int lt,lk,rt,rk; namespace IO { char ch; const int M = 0xcf; const int N = 0x30; int s

LA 3266 Tian Ji -- The Horse Racing 田忌赛马 【贪心】

题目链接: http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=33702 贪心: 1,如果田忌的最快马快于齐王的最快马,则两者比. (因为若是田忌的别的马很可能就赢不了了,所以两者比) 2,如果田忌的最快马慢于齐王的最快马,则用田忌的最慢马和齐王的最快马比. (由于所有的马都赢不了齐王的最快马,所以用损失最小的,拿最慢的和他比) 3,若相等,则比较田忌的最慢马和齐王的最慢马 3.1,若田忌最慢马快于齐王最慢马,两者比. (田忌

[HDU1052]Tian Ji -- The Horse Racing(田忌赛马)

题目大意:田忌赛马问题,给出田忌和齐威王的马的数量$n$和每匹马的速度$v$,求田忌最多赢齐威王多少钱(赢一局得200,输一局扣200,平局不得不扣). 思路:贪心. 1.若田忌最慢的马可以战胜齐王最慢的马,那么就让它战胜那匹慢马,胜利场次加1.(田忌最慢马 > 齐王最慢马) 2.若田忌最慢的马不能战胜齐王最慢的马,那么它更加不能战胜其他的马,那就让它输给齐王最快的马,失败场次加1.(田忌最慢马 < 齐王最快马) 3.若田忌最慢的马与齐王最慢的马速度相等.此时,打平是错误的. 因为自己的快马很

HDU 1052 Tian Ji -- The Horse Racing(贪心)(2004 Asia Regional Shanghai)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1052 Problem Description Here is a famous story in Chinese history. "That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and

HDU 1052 Tian Ji -- The Horse Racing【贪心在动态规划中的运用】

算法分析: 这个问题很显然可以转化成一个二分图最佳匹配的问题.把田忌的马放左边,把齐王的马放右边.田忌的马A和齐王的B之间,如果田忌的马胜,则连一条权为200的边:如果平局,则连一条权为0的边:如果输,则连一条权为-200的边. 然而我们知道,二分图的最佳匹配算法的复杂度很高,无法满足N=2000的要求. 我们不妨用贪心思想来分析一下问题.因为田忌掌握有比赛的“主动权”,他总是根据齐王所出的马来分配自己的马,所以这里不妨认为齐王的出马顺序是按马的速度从高到低出的.由这样的假设,我们归纳出如下贪心

HDU Tian Ji -- The Horse Racing (贪心)

Tian Ji -- The Horse Racing Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 56   Accepted Submission(s) : 25 Font: Times New Roman | Verdana | Georgia Font Size: ← → Problem Description Here is a

hdu 1052 Tian Ji -- The Horse Racing 可恶的贪心-------也算是经典贪心题吧,对于一般人来说,不看题解,应该很难做出来吧

Tian Ji -- The Horse Racing Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 20051    Accepted Submission(s): 5869 Problem Description Here is a famous story in Chinese history. "That was about

HDU 1052.Tian Ji -- The Horse Racing【很好的贪心】【8月27】

Tian Ji -- The Horse Racing Problem Description Here is a famous story in Chinese history. "That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others." "Both

hdu1052 Tian Ji -- The Horse Racing

转载请注明出处:http://blog.csdn.net/u012860063 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1052 Tian Ji -- The Horse Racing Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 17346    Accepted Submiss