POJ 3903 Stock Exchange 解题心得

原题:

Description

The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,...,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < ... < pik, with i1 < i2 < ... < ik. John’s problem is to find very quickly the longest rising trend.

Input

Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer). 
White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

Output

The program prints the length of the longest rising trend. 
For each set of data the program prints the result to the standard output from the beginning of a line.

Sample Input

6
5 2 1 4 5 3
3
1 1 1
4
4 3 2 1

Sample Output

3
1
1

Hint

There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.

分析:

这题不能用n^2的算法过,要用LIS的nlogn算法过

下面介绍nlogn算法

这个有点贪心的意思了 ,

定义一个变量数组d[k]:长度为k的上升子序列的最末元素,若有多个长度为k的上升子序列,则记录最小的那个最末元素。

注意d中元素是单调递增的,下面要用到这个性质。
首先len = 1,d[1] = a[1],然后对a[i]:若a[i]>d[len],那么len++,d[len] = a[i];
否则,我们要从d[1]到d[len-1]中找到一个j,满足d[j-1]<a[i]<d[j],则根据D的定义,我们需要更新长度为j的上升子序列的最末元素(使之为最小的)即 d[j] = a[i];
最终答案就是len
利用d的单调性,在查找j的时候可以二分查找,从而时间复杂度为nlogn。

 

还不懂可以去这里:http://blog.csdn.net/shuangde800/article/details/7474903

代码:

#include<iostream>
#include<cstdio>
using namespace std;
const int N = 100000 + 10;

int a[N], dp[N];

//                                                                    while循环实现
int binsearch(int *d, int left, int right, int key)
{
    int  mid;
    while (left <= right)
    {
        mid = left + ((right - left) >>1);
        if (d[mid] < key&&d[mid + 1] >= key)
            return mid;
        if (d[mid] < key&&d[mid + 1] < key)
            left = mid + 1;
        if (d[mid] == key)
            right = mid - 1;
        if (d[mid]>key)
            right = mid - 1;
    }
    return  -1;
}
//                                                                                递归实现
//int binsearch(int *d,int left, int right, int key)
//{
//    //     搜索区间   [left ,right]
//
//    if (left > right)
//        return -1;
//
//    int mid = left+(right-left)/2;
//    if (d[mid] < key&&d[mid + 1] >= key)
//        return mid;
//    if (d[mid] == key)
//        right = mid - 1;
//
//    else if (d[mid] < key){                    //可以优化?
//        left = mid+1;
//    }
//    else if(d[mid]>key){
//        right = mid - 1;
//    }
//    return binsearch(d, left, right, key);
//}

int main()
{
    //int aa[N] = { 1, 1, 1, 1, 1 };
    //cout << binsearch(aa, 0, 5, 1);
    int n;
    while (cin >> n)
    {
        for (int i = 0; i < n; i++)
        {
            scanf("%d", a + i);
        }
        dp[1] = a[0];
        int len = 1, protected_len;
        for (int i = 1; i < n; i++)
        {
            if (i == 3)
                int oiu=3;
            if (a[i]>dp[len]){
                len++;
                dp[len] = a[i];
            }
            else{
                protected_len = binsearch(dp,1,len,a[i]);
                //cout << "protencetd=" << protected_len << ‘ ‘ << a[i] << endl;
                if (protected_len != -1){
                    protected_len++;
                    dp[protected_len] = a[i];
                }
                else{
                    dp[1] = a[i];
                }
            }
        }
        cout << len << endl;
    }
    return 0;
}
时间: 2024-10-08 23:42:35

POJ 3903 Stock Exchange 解题心得的相关文章

LIS(nlogn) POJ 3903 Stock Exchange

题目传送门 1 /* 2 最长递增子序列O(nlogn)算法: 3 设当前最长递增子序列为len,考虑元素a[i]; 4 若d[len]<a[i],则len++,并将d[len]=a[i]; 5 否则,在d[1~len]中二分查找,找到第一个比它小的元素d[j],并d[j]=a[i]. 6 */ 7 #include <cstdio> 8 #include <cstring> 9 #include <iostream> 10 #include <algori

{POJ}{3903}{Stock Exchange}{nlogn 最长上升子序列}

题意:求最长上升子序列,n=100000 思路:O(N^2)铁定超时啊....利用贪心的思想去找答案.利用栈,每次输入数据检查栈,二分查找替换掉最小比他大的数据,这样得到的栈就是更优的.这个题目确实不错,思路很好 #include <iostream> #include <string> #include <cstring> #include <cstdio> #include <algorithm> #include <memory>

poj 3903 Stock Exchange(最长上升子序列,模版题)

题目 #include<stdio.h> //最长上升子序列 nlogn //入口参数:数组名+数组长度,类型不限,结构体类型可以通过重载运算符实现 //数组下标从1号开始. int bsearch(int a[],int len,int num) { int left=1,right=len; while(left<=right) { int mid=(left+right)/2; if(num<=a[mid]) //若最长不下降子序列,改<= 为 < right=m

POJ 3903 Stock Exchange LIS

题目链接:http://poj.org/problem?id=3903 题目大意:LIS的nlog(n)写法. 解题思路:dp[i]:=长度为i的最长递增子序列的末尾元素最小值.那么由于dp[i]形成了一个有序的序列,所以可以采用二分的办法. dp[j] = a[i]  dp[j] <= a[j] < dp[j + 1] 代码: 1 const int inf = 0x3f3f3f3f; 2 const int maxn = 1e5 + 5; 3 int a[maxn], n; 4 int d

POJ 3903 Stock Exchange

The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising tren

POJ - 3903 Stock Exchange(LIS最长上升子序列问题)

E - LIS Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Description The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned abo

POJ 3903 Stock Exchange(LIS)

Stock Exchange Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 4578   Accepted: 1618 Description The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very

POJ 3903 Stock Exchange (LIS:最长上升子序列)

POJ 3903Stock Exchange (LIS:最长上升子序列) http://poj.org/problem?id=3903 题意: 给你一个长度为n (n<=100000) 的数字序列, 要你求该序列中的最长(严格)上升子序列的长度. 分析: 由于n的规模达到10W, 所以只能用O(nlogn)的算法求. 令g[i]==x表示当前遍历到的长度为i的所有最长上升子序列中的最小序列末尾值为x.(如果到目前为止, 根本不存在长i的上升序列, 那么x==INF无穷大) 假设当前遍历到了第j个

POJ 3903 Stock Exchange 【最长上升子序列】模板题

题目链接:http://poj.org/problem?id=3903 转载于:https://www.cnblogs.com/GodA/p/5180560.html 题目大意: 裸的DP最长上升子序列,给你一段序列,求其最长上升子序列的长度,n^2的dp朴素算法过不了,这里用的是nlogn的算法,用了二分查找. 具体算法思路解析: 学习动态规划问题(DP问题)中,其中有一个知识点叫最长上升子序列(longest  increasing subsequence),也可以叫最长非降序子序列,简称L