HDOJ 1751 Highways(最小生成树prim)

Highways

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 11071   Accepted: 3145   Special Judge

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number
of highways connecting some of the most important towns. However, there are still some towns that you can‘t reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway
system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus
their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length.
Thus, the least expensive highway system will be the one that minimizes the total highways length.

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of ith town (for i from
1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a
highway. Each pair of towns is connected by at most one highway.

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing
town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.

Sample Input

9
1 5
0 0
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3

题意:给出n个城市的坐标,再给出m,后面有m行,每行两个数表示已经有公路连接的两个城市的编号。现在要使这n个城市实现畅通,且修路的成本最低。输出全部还需要修建公路的城市,每行两个城市编码,表示这两个城市间需要修一条公路。

最小生成树,输出连通的点的组合就行了。用prim算法比较方便,kruskal需要优化。

prim算法解题,用数组记录lowcost数组中值对应的城市。

代码如下:

<span style="font-size:12px;">#include<cstdio>
#include<cstring>
#define INF 0x3f3f3f
int map[800][800],n;

void prim()
{
	int i,j,next,min;
	int lowcost[800],visit[800],pos[800];
	memset(visit,0,sizeof(visit));
	for(i=1;i<=n;++i)
	{
		lowcost[i]=map[1][i];
		pos[i]=1;//用memset对数组初始化为1,居然结果不对,用循环就可以了,无语
	}
	visit[1]=1;
	for(i=2;i<=n;++i)
	{
		min=INF;
		for(j=1;j<=n;++j)
		{
			if(!visit[j]&&min>lowcost[j])
			{
				min=lowcost[j];
				next=j;
			}
		}
		if(min!=INF&&min!=0)//当前能够找到最小的权值,且不是已经连接的路径
			printf("%d %d\n",pos[next],next);
		visit[next]=1;
		for(j=1;j<=n;++j)
		{
			if(!visit[j]&&lowcost[j]>map[next][j])
			{
				lowcost[j]=map[next][j];
				pos[j]=next;//pos数组中下表j表示j城市,对应的值next表示next城市,lowcost[j]表示这两座城市的距离
			}
		}
	}
}

int main()
{
	int i,j,x[800],y[800],m,d,a,b;
	while(scanf("%d",&n)!=EOF)
	{
		memset(map,INF,sizeof(map));
		for(i=1;i<=n;++i)
		   scanf("%d%d",&x[i],&y[i]);
		for(i=1;i<n;++i)
		{
			for(j=1+i;j<=n;++j)
			{
				d=(x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]);
				map[i][j]=map[j][i]=d;
			}
		}
		scanf("%d",&m);
		for(i=0;i<m;++i)
		{
			scanf("%d%d",&a,&b);
			map[a][b]=map[b][a]=0;
		}
		prim();
	}
	return 0;
}

</span>

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-11-09 10:17:02

HDOJ 1751 Highways(最小生成树prim)的相关文章

poj 1751 Highways (prim )

Highways Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 9080   Accepted: 2536   Special Judge Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian

HDOJ 2682 Tree(最小生成树prim算法)

Tree Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1954    Accepted Submission(s): 573 Problem Description There are N (2<=N<=600) cities,each has a value of happiness,we consider two cities

poj 1751 Highways (最小生成树)

题目链接: http://poj.org/problem?id=1751 题目大意: 给出n个点,每个点用二维坐标表示,不会用任意两个点在同一位置,在这n个点之间已经有m条道路了,问在花费最少的情况下修建那几条路能把所有的点连在一起? 解题思路: 对任意一个点向其他的点建边,因为建图的时候,边比较密集,所以最好用prim算法求最短路,ps:我刚开始是多实例,一直tle,最后搜了一下题解,发现别人也是多实例,无奈最后改成单实例试试,竟然对了,为什么???难道大神怎么写都对,大神就是任性??有同学发

POJ 2485 Highways (最小生成树prim)

题目大意:    有一个岛国,没有高速公路,交通非常困难.政府意识到了这一问题,他们计划建造一些高速公路,这样可以使任何一对城镇都不离开公路系统.所有公路都是沿直线建造并且是双向的.政府想降低花费,所以想找到一种建造方案,能连接所有的城镇,并且公路的总长度最小.注意题目求的是最小生成树最长的那条边. #include <cstdio> #include <cstring> #include <algorithm> #define N 600 #define INF 0x

Highways POJ-1751 最小生成树 Prim算法

Highways POJ-1751 最小生成树 Prim算法 题意 有一个N个城市M条路的无向图,给你N个城市的坐标,然后现在该无向图已经有M条边了,问你还需要添加总长为多少的边能使得该无向图连通.输出需要添加边的两端点编号即可. 解题思路 这个可以使用最短路里面的Prim算法来实现,对于已经连接的城市,处理方式是令这两个城市之间的距离等于0即可. prim算法可以实现我们具体的路径输出,Kruskal算法暂时还不大会. 代码实现 #include<cstdio> #include<cs

POJ 2485-Highways(最小生成树prim)

Highways Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 22433   Accepted: 10341 Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Fl

最小生成树Prim poj1258 poj2485

poj:1258 Agri-Net Time Limit: 1000 MS Memory Limit: 10000 KB 64-bit integer IO format: %I64d , %I64u Java class name: Main [Submit] [Status] [Discuss] Description Farmer John has been elected mayor of his town! One of his campaign promises was to bri

poj2485最小生成树prim

Highways Time Limit: 1000 MS Memory Limit: 65536 KB 64-bit integer IO format: %I64d , %I64u Java class name: Main [Submit] [Status] [Discuss] Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways.

poj1861 最小生成树 prim &amp; kruskal

// poj1861 最小生成树 prim & kruskal // // 一个水题,为的只是回味一下模板,日后好有个照应不是 #include <cstdio> #include <algorithm> #include <cstring> #include <vector> #include <iostream> using namespace std; const int MAX_N = 1008; const int INF =