Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25929 Accepted Submission(s): 17918
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
C/C++:
1 #include <map> 2 #include <queue> 3 #include <cmath> 4 #include <vector> 5 #include <string> 6 #include <cstdio> 7 #include <cstring> 8 #include <climits> 9 #include <iostream> 10 #include <algorithm> 11 #define INF 0x3f3f3f3f 12 #define LL long long 13 using namespace std; 14 const int MAX = 2e2 + 10; 15 16 int n, ans[MAX], temp[MAX]; 17 18 void calc() 19 { 20 for (int i = 0; i <= 130; ++ i) 21 ans[i] = 1, temp[i] = 0; 22 for (int i = 2; i <= 130; ++ i) 23 { 24 for (int j = 0; j <= 130; ++ j) 25 for (int k = 0; j + k <= 130; k += i) 26 temp[j + k] += ans[j]; 27 for (int j = 0; j <= 130; ++ j) 28 ans[j] = temp[j], temp[j] = 0; 29 } 30 } 31 32 int main() 33 { 34 calc(); 35 while (~scanf("%d", &n)) 36 printf("%d\n", ans[n]); 37 return 0; 38 }
原文地址:https://www.cnblogs.com/GetcharZp/p/9557626.html