Hdu 5444 Elven Postman dfs

Elven Postman

Time Limit: 1 Sec

Memory Limit: 256 MB

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=5444

Description

Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture.

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.

Input

First you are given an integer T(T≤10) indicating the number of test cases.

For each test case, there is a number n(n≤1000) on a line representing the number of rooms in this tree. n integers representing the sequence written at the root follow, respectively a1,...,an where a1,...,an∈{1,...,n}.

On the next line, there is a number q representing the number of mails to be sent. After that, there will be q integers x1,...,xq indicating the destination room number of each mail.

Output

For each query, output a sequence of move (E or W) the postman needs to make to deliver the mail. For that E means that the postman should move up the eastern branch and W the western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.

Sample Input

2
4
2 1 4 3
3
1 2 3
6
6 5 4 3 2 1
1
1

Sample Output

E

WE
EEEEE

HINT

题意

建树;编号是这棵树从右往左进行编号的,越往右边的编号越小

给你一个数组,然后问你走到一些点,究竟该怎么走

题解:

注意,树的形态是唯一的

我们可以处理每个节点能够放的点的大小的范围,然后就可以求出这棵树的样子了

回答就可以顺便再DFS建树的过程中处理出来

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <vector>
#include <stack>
#include <map>
#include <set>
#include <queue>
#include <iomanip>
#include <string>
#include <ctime>
#include <list>
#include <bitset>
typedef unsigned char byte;
#define pb push_back
#define input_fast std::ios::sync_with_stdio(false);std::cin.tie(0)
#define local freopen("in.txt","r",stdin)
#define pi acos(-1)

using namespace std;
struct node
{
    int L , R ;
    string str;
};

const int maxn = 1e3 + 15;
int n , p[maxn] , q , ctt = 2 ;
vector<int>qq;
node c[maxn];

bool dfs(int u)
{
/*    cout << "u is " << u << endl;
    cout << "ctt is " << ctt << endl;
    getch();*/
    if(ctt == n + 1) return true;
    while(1)
    {
       if(c[u].L <= p[ctt] && p[ctt] <= c[u].R)
      {
        int x = p[ctt];
        int y = u;
        if(x < y)
        {
            c[x].str = c[u].str + ‘E‘;
            c[x].R = y;
            c[x].L = c[u].L;
        }
        else
        {
            c[x].str = c[u].str + ‘W‘;
            c[x].L = y;
            c[x].R = c[u].R;
        }
        ctt++;
        if(ctt == n + 1) return true;
        if(dfs(x)) return true;
      }
      else
       return false;
      if(ctt == n + 1) return true;
    }
}

void initiation()
{
    qq.clear();
    scanf("%d",&n);
    for(int i = 1 ; i <= n ; ++ i) scanf("%d",p + i);
    scanf("%d",&q);
    for(int i = 1 ; i <= q;  ++ i)
    {
        int x;
        scanf("%d",&x);
        qq.push_back(x);
    }
    for(int i = 1 ; i <= n ; ++ i)
    {
        c[i].str = "";
        c[i].L = -10000 , c[i].R = 10000;
    }
    ctt = 2;
    dfs(p[1]);
}

void solve()
{
    for(int i = 0 ; i < q ;++ i) cout << c[qq[i]].str << endl;
}

int main(int argc,char *argv[])
{
    //freopen("out.txt","w",stdout);
    int Case;
    scanf("%d",&Case);
    while(Case--)
    {
        initiation();
        solve();
    }
    return 0;
}
时间: 2024-11-09 02:14:28

Hdu 5444 Elven Postman dfs的相关文章

hdu 5444 Elven Postman

题目连接 http://acm.hdu.edu.cn/showproblem.php?pid=5444 Elven Postman Description Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on tr

hdu 5444 Elven Postman(长春网路赛——平衡二叉树遍历)

题目链接:pid=5444http://">http://acm.hdu.edu.cn/showproblem.php?pid=5444 Elven Postman Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 1206    Accepted Submission(s): 681 Problem Description E

2015 ACM/ICPC Asia Regional Changchun Online HDU 5444 Elven Postman【二叉排序树的建树和遍历查找】

Elven Postman Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 591    Accepted Submission(s): 329 Problem Description Elves are very peculiar creatures. As we all know, they can live for a very

HDU 5444 Elven Postman 二叉排序树

HDU 5444 题意:给你一棵树的先序遍历,中序遍历默认是1...n,然后q个查询,问根节点到该点的路径(题意挺难懂,还是我太傻逼) 思路:这他妈又是个大水题,可是我还是太傻逼.1000个点的树,居然用标准二叉树结构来存点,,,卧槽想些什么东西.可以用一维数组,left,right直接指向位置就行了,我这里用的是链表.对于读入的序列,生成一个二叉排序树,同时记录一下路径就可以了,后面居然忘了清空path又wa了一发. 1 #include<iostream> 2 #include<cs

HDU 5444 Elven Postman (2015 ACM/ICPC Asia Regional Changchun Online)

[题目链接]:click here~~ [题目大意]: HDU 5444 题意:在最初为空的二叉树中不断的插入n个数.对于每个数,从根节点开始判断,如果当前节点为空,就插入当前节点,如果当前节点不为空,则小于当前节点的值,插入右子树,否则插入左子树. 接着q次询问,每次询问一个值在二叉树中从根节点开始的查找路径. 3 直接用二叉树模拟整个插入和询问的过程 代码: /* * Problem: HDU No.5444 * Running time: 0MS * Complier: G++ * Aut

HDU 5444 Elven Postman(二叉查找树)

Elven Postman Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 558    Accepted Submission(s): 308 Problem Description Elves are very peculiar creatures. As we all know, they can live for a ver

hdu 5444 Elven Postman长春网赛

5444 2333 建二插排序树,dfs一遍,之后o(1)应对查询 #include<cstdio> #include<cstring> #include<algorithm> #include<queue> using namespace std; const int maxn=1008; struct fuck{ int left,right; }poi[maxn]; int tol; struct shit{ char s[maxn]; int idx

hdu 5444 Elven Postman(根据先序遍历和中序遍历求后序遍历)2015 ACM/ICPC Asia Regional Changchun Online

很坑的一道题,读了半天才读懂题,手忙脚乱的写完(套上模板+修改模板),然后RE到死…… 题意: 题面上告诉了我们这是一棵二叉树,然后告诉了我们它的先序遍历,然后,没了……没了! 反复读题,终于在偶然间注意到了这一句——"Not only that, when numbering the rooms, they always number the room number from the east-most position to the west." 它告诉我们,东边的点总是比西边的点

HDU 5444 Elven Postman (二叉树,暴力搜索)

题意:给出一颗二叉树的先序遍历,默认的中序遍历是1..2.……n.给出q个询问,询问从根节点出发到某个点的路径. 析:本来以为是要建树的,一想,原来不用,其实它给的数是按顺序给的,只要搜结点就行,从根开始搜,如果要到的结点比根结点大,那么一定是向W走, 然后去第一个结点,然后接着判定,一直走,如果找到结束就好.水题.当时想的有点复杂. 代码如下: #include <cstdio> #include <string> #include <cstdlib> #includ