poj1655 Balancing Act (dp? dfs?)

Balancing Act

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14247   Accepted: 6026

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T. 
For example, consider the tree: 

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two.

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

题意:

找树的重心,即:定义1:找到一个点,其所有的子树中最大的子树节点数最少,那么这个点就是这棵树的重心。定义2:以这个点为根,那么所有的子树(不算整个树自身)的大小都不超过整个树大小的一半。性质1:树中所有点到某个点的距离和中,到重心的距离和是最小的;如果有两个重心,那么他们的距离和一样。性质2:把两个树通过一条边相连得到一个新的树,那么新的树的重心在连接原来两个树的重心的路径上。性质3:把一个树添加或删除一个叶子,那么它的重心最多只移动一条边的距离。

思路:

选取任意节点为根节点,dfs求当前节点所代表的子树的节点总数(包含自己记为sum)和该节点的所有子树中节点数最大值(记为ave)。则依据题意,删除当前节点后的平衡值为

max(n-sum,ave);找到最小值输出。

看到别人说是dp,可能我不会dp。

代码:

#include<iostream>
#include<cstdio>
#include<vector>
using namespace std;
const int maxn = 2e4+4, INF = 0x3f3f3f3f;

vector<int> grap[maxn];
int vis[maxn], sum[maxn], ave[maxn];
int t, n;

int dfs(int x)
{
    int res=1;
    for(int i=0; i<grap[x].size(); ++i)
    {
        int xx=grap[x][i];
        if(vis[xx]) continue;
        vis[xx]=1;
        int kk=dfs(xx);
        ave[x]=max(ave[x], kk);
        res+=kk;
        vis[xx]=0;
    }
    sum[x]=res;
    ave[x]=max(ave[x], n-sum[x]);
    return res;
}

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(int i=1; i<=n; ++i)
        {
            grap[i].clear();
            vis[i]=0;
            sum[i]=0;
            ave[i]=0;
        }
        for(int i=2; i<=n; ++i)
        {
            int u, v;
            cin>>u>>v;
            grap[u].push_back(v);
            grap[v].push_back(u);
        }
        vis[1]=1;
        dfs(1);
        int ans=INF, v=0;
        for(int i=1; i<=n; ++i)
            if(ans>ave[i])
                ans=ave[i], v=i;
        cout<<v<<" "<<ans<<endl;
    }
    return 0;
}
时间: 2024-10-11 23:15:22

poj1655 Balancing Act (dp? dfs?)的相关文章

poj1655 Balancing Act 【树形DP(很弱)】

都不知道怎么分类了. 大概要求一个树中以某个结点为根的子树结点个数,还有儿子结点中以儿子结点为根的子树结点个数的最大值,用递归得到n[i],以i为根节点的子树结点个数 #include <cstdio> #include <cstdlib> #include <iostream> #include <algorithm> #include <vector> #include <cstring> #include <cmath&g

poj1655 Balancing Act(树形dp)

Balancing Act Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 11176   Accepted: 4702 Description Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or m

poj1655 Balancing Act 求树的重心

http://poj.org/problem?id=1655 Balancing Act Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 9072   Accepted: 3765 Description Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a fo

POJ1655——Balancing Act

Balancing Act Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 9143   Accepted: 3797 Description Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or mo

poj1655 Balancing Act(找树的重心)

Balancing Act POJ - 1655 题意:给定一棵树,求树的重心的编号以及重心删除后得到的最大子树的节点个数size,如果size相同就选取编号最小的. /* 找树的重心可以用树形dp或者dfs,这里我用的dfs 基本方法就是随便设定一个根节点,然后找出这个节点的子树大小(包括这个节点),然后总点数减去子树的大小就是向父亲节点走去的点数,使这几部分的最大值最小 */ #include<iostream> #include<cstdio> #include<alg

POJ1655 Balancing Act(树的重心)

题目链接 Balancing Act 就是求一棵树的重心,然后统计答案. 1 #include <bits/stdc++.h> 2 3 using namespace std; 4 5 #define REP(i,n) for(int i(0); i < (n); ++i) 6 #define for_edge(i,x) for(int i = H[x]; i; i = X[i]) 7 8 const int INF = 1 << 30; 9 const int N = 10

POJ-1655 Balancing Act

题目大意:一棵n个节点的树,找出最大子树最小的节点. 题目分析:过程类似求重心. 代码如下: # include<iostream> # include<cstdio> # include<cstring> # include<vector> # include<queue> # include<list> # include<set> # include<map> # include<string>

POJ1655 Balancing Act(树的重心)

题意: 给你一棵树,求树的重心 如果有多个就输出序号最小的 思路: 树的重心就是以它为根的所有子树中节点最多的节点数最小 树形dp轻松可以解决 /* *********************************************** Author :devil ************************************************ */ #include <cstdio> #include <cstring> #include <iost

[POJ1655]Balancing Act

题目描述 Description Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T cr