HDU 2736 Surprising Strings

Surprising Strings

Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

STL 的方法做的:
#include <stdio.h>
#include <string.h>
#include <string>
#include <map>
#include <algorithm>

using namespace std;

char s[100];

int main()
{
	int len;
	int i, j;
	map<string, int>ma;
	map<string, int>::iterator it;
    char sc[3];
	int flag;

    while( gets(s)!=NULL )
	{
		if(strcmp("*", s)==0)
			break;
		else
		{
			len = strlen(s);
			if(len==1)
			{
				printf("%s is surprising.\n", s );
				continue ;
			}

			flag=1; //初始化标记变量

            j=1;
			for(j=1; j<len; j++)
			{
				ma.clear();
			    for(i=0; i+j<len; i++)
				{
				    sc[0]=s[i];
				    sc[1]=s[i+j];
				    sc[2]=‘\0‘;
				    ma[sc]++;
				}
				for(it=ma.begin(); it!=ma.end(); it++)
				{
				    if(it->second>1)
					{
					    flag=0; //找到重复的了
					    break;
					}
				}
				if(flag==0)
				{
					printf("%s is NOT surprising.\n", s); //不是的话,直接跳出
					break;
				}
			}
			if(flag==1)
			{
				printf("%s is surprising.\n", s );
			}
		/*	else if(flag==0)
			{
				printf("%s is NOT surprising.\n", S );
			}  */
		}
	}
	return 0 ;
}

HDU 2736 Surprising Strings

时间: 2024-10-08 21:06:27

HDU 2736 Surprising Strings的相关文章

Surprising Strings

Surprising Strings Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 7403 Accepted: 4735 Description The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its

HDU 6170 - Two strings | 2017 ZJUT Multi-University Training 9

/* HDU 6170 - Two strings [ DP ] | 2017 ZJUT Multi-University Training 9 题意: 定义*可以匹配任意长度,.可以匹配任意字符,问两串是否匹配 分析: dp[i][j] 代表B[i] 到 A[j]全部匹配 然后根据三种匹配类型分类讨论,可以从i推到i+1 复杂度O(n^2) */ #include <bits/stdc++.h> using namespace std; const int N = 2505; int t;

POJ 3096 Surprising Strings

Surprising Strings Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7225   Accepted: 4663 Description The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of

[ACM] POJ 3096 Surprising Strings (map的使用)

Surprising Strings Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 5783   Accepted: 3792 Description The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of

C - Surprising Strings

                               C - Surprising Strings 题意:输入一段字符串,假设在同一距离下有两个字符串同样输出Not surprising ,否则输出surprising. Description The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-uniq

[ACM] POJ 3096 Surprising Strings (map使用)

Surprising Strings Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 5783   Accepted: 3792 Description The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of

[POJ3096]Surprising Strings

试题描述 The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D. Consider t

【TOJ 2176】Surprising Strings

描述 The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D. Consider the

HDU 6170 Two strings 思维 DP

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=6170 题目描述: 两个字符串问是否匹配, '.'可以匹配任意字符, '*'可以使前一个数的出现次数成上一个自然数(0, 1, 2, 3........) 解题思路: DP, dp(i, j)表示A串匹配到j位, B串匹配到i位两个串是否匹配, 转移方程再代码里有, 参考Jaihk662的博客, 注释在代码中 代码: #include <iostream> #include <cstdio&