uva558 Wormholes SPFA 求是否存在负环

J - Wormholes

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld
& %llu

Submit Status

Description

In the year 2163, wormholes were discovered. A wormhole is a subspace tunnel through space and time connecting two star systems. Wormholes have a few peculiar properties:

  • Wormholes are one-way only.
  • The time it takes to travel through a wormhole is negligible.
  • A wormhole has two end points, each situated in a star system.
  • A star system may have more than one wormhole end point within its boundaries.
  • For some unknown reason, starting from our solar system, it is always possible to end up in any star system by following a sequence of wormholes (maybe Earth is the centre of the universe).
  • Between any pair of star systems, there is at most one wormhole in either direction.
  • There are no wormholes with both end points in the same star system.

All wormholes have a constant time difference between their end points. For example, a specific wormhole may cause the person travelling through it to end up 15 years in the future. Another wormhole may cause
the person to end up 42 years in the past.

A brilliant physicist, living on earth, wants to use wormholes to study the Big Bang. Since warp drive has not been invented yet, it is not possible for her to travel from one star system to another one directly. This can be done using wormholes, of
course.

The scientist wants to reach a cycle of wormholes somewhere in the universe that causes her to end up in the past. By travelling along this cycle a lot of times, the scientist is able to go back as far in time as necessary to reach the beginning of the universe
and see the Big Bang with her own eyes. Write a program to find out whether such a cycle exists.

Input

The input file starts with a line containing the number of cases c to be analysed. Each case starts with a line with two numbers n and m . These indicate the number of star systems ( )
and the number of wormholes ( ) . The star systems are numbered from 0 (our solar system) through n-1
. For each wormhole a line containing three integer numbers xy and t is given. These numbers indicate that this wormhole allows someone to travel from the star system numbered x to the star system numbered y,
thereby ending up t ( ) years in the future.

Output

The output consists of c lines, one line for each case, containing the word possible if it is indeed possible to go back in time indefinitely, or not possible if this is not possible with the given set of star systems and wormholes.

Sample Input

2
3 3
0 1 1000
1 2 15
2 1 -42
4 4
0 1 10
1 2 20
2 3 30
3 0 -60

Sample Output

possible
not possible

Miguel A. Revilla

1998-03-10

题意:问是否能通过虫洞,回到过去,意思实际上就是求,最短路里面有不有负环。

思路:SPFA 或者Bellman-ford 判断下有不有负环就可以了,对于SPFA,如果有负环,表明进栈次数大于等于n次。

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#define INF 9999999
using namespace std;

int n,m;
int num[2222];
int dis[2222];
int vis[2222];
int f[2222];
int u[2222],v[2222],w[2222],next[2222];

int spfa()
{
    queue<int>q;
    memset(vis,0,sizeof vis);
    memset(num,0,sizeof num);

    for(int i=0;i<=n;i++) dis[i]=INF;
    dis[0]=0;
    q.push(0);
    num[0]++;

    while(!q.empty())
    {
        int x=q.front(); q.pop();
        vis[x]=0;
        for(int i=f[x];i!=-1;i=next[i])
        if(dis[x]+w[i]<dis[v[i]])
        {
            dis[v[i]]=dis[x]+w[i];
            if(vis[v[i]]==0)
            {
                vis[v[i]]=1;
                q.push(v[i]);
                num[v[i]]++;
                if(num[v[i]]>=n)
                    return 1;
            }
        }
    }

    return 0;
}

int main()
{
    int T;
    scanf("%d",&T);

    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(f,-1,sizeof f);

        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&u[i],&v[i],&w[i]);
            next[i]=f[u[i]];f[u[i]]=i;
        }

        if(spfa()==0)
            puts("not possible");
        else
            puts("possible");

    }
    return 0;
}

/*
5 4
1 2 1
1 3 2
2 4 3
2 5 2
*/

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-11-08 19:57:40

uva558 Wormholes SPFA 求是否存在负环的相关文章

vijos1053 用spfa判断是否存在负环

MARK 用spfa判断是否存在负环 判断是否存在负环的方法有很多, 其中用spfa判断的方法是:如果存在一个点入栈两次,那么就存在负环. 细节想想确实是这样,按理来说是不存在入栈两次的如果边权值为正的话 这个算法是O(N*M) 还有一种方法是直接用bellman-ford,虽说spfa也就是bellman-ford+FIFO队列 而且bellman-ford还可以计算负环的值 顺手附上代码好了: for(int i=0;i<n;i++) d[i]=INF;//初始化 d[0]=0; for(i

poj 3259 Wormholes 【SPFA&amp;amp;&amp;amp;推断负环】

Wormholes Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 36852   Accepted: 13502 Description While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way p

POJ 3259 Wormholes (bellman_ford算法判负环)

Wormholes Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 32393   Accepted: 11771 Description While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way p

POJ Wormholes 最短路径 ballman_ ford 有负环

1 #include <cstdio> 2 #include <cstring> 3 #include <algorithm> 4 #include <iostream> 5 #include <queue> 6 #define MAX 9999999 7 8 using namespace std; 9 10 struct node 11 { 12 int u, v, w;//u 为起点,v为终点,w为u—>v的权值 13 }; 14 n

uva 558 Wormholes (Bellman-Ford算法判断负环)

uva 558 Wormholes In the year 2163, wormholes were discovered. A wormhole is a subspace tunnel through space and time connecting two star systems. Wormholes have a few peculiar properties: Wormholes are one-way only. The time it takes to travel throu

用SPFA判断是否存在负环

负环指的是权值和为负数的环,用SPFA加上DFS做比较方便,如果用BFS来做就要便利太多点了. 题目描述 暴力枚举/SPFA/Bellman-ford/奇怪的贪心/超神搜索 输入输出格式 输入格式: 第一行一个正整数T表示数据组数,对于每组数据: 第一行两个正整数N M,表示图有N个顶点,M条边 接下来M行,每行三个整数a b w,表示a->b有一条权值为w的边(若w<0则为单向,否则双向) 输出格式: 共T行.对于每组数据,存在负环则输出一行"YE5"(不含引号),否则输

POJ3259 Wormholes —— spfa求负环

题目链接:http://poj.org/problem?id=3259 Wormholes Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 55082   Accepted: 20543 Description While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is ver

(简单) POJ 3259 Wormholes,SPFA判断负环。

Description While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Eac

POJ3259:Wormholes(spfa判负环)

Wormholes Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 68097   Accepted: 25374 题目链接:http://poj.org/problem?id=3259 Description: While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is ve