1024. Palindromic Number (25)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until
it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps,
just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

4842

Sample Input 2:

69 3

Sample Output 2:

13533

#include <iostream>
#include <vector>
#include <string.h>
using namespace std;

bool isPalindromic(vector<int> a) {
    int i, j;
    for(i=0, j=a.size()-1; i<=j; i++, j--) {
        if(a[i] != a[j])
            return false;
    }
    return true;
}

void print(vector<int> input) {
    int i;
    for(i=input.size()-1; i>=0; i--) {
        cout<<input[i];
    }
    cout<<endl;
}

int main() {
    vector<int> input;
    char s[11];
    int k, i;
    cin>>s>>k;
    int len = strlen(s);
    for(i=0; i<len; i++) {
        input.push_back(s[i] - '0');
    }
    if(isPalindromic(input)) {
        print(input);
        cout<<"0"<<endl;
    } else {
        int len_temp = len;
        for(i=1; i<=k; i++) {
            int end = len_temp - 1;
            int start = 0;
            int j = 0;
            int t = 0;//进位标示
            vector<int> vec_temp;
            for(; start<len_temp && end>=0; start++, end--, j++) {
                vec_temp.push_back(t + input[start] + input[end]);
                if(vec_temp[j] >= 10) {
                    vec_temp[j] -= 10;
                    t = 1;
                } else {
                    t = 0;
                }
            }
            if(t > 0) { //高位进一
                vec_temp.push_back(1);
            }
            len_temp = vec_temp.size();
            input.assign(vec_temp.begin(),vec_temp.end());
            if(isPalindromic(input))
                break;
        }
        print(input);
        if(i>k)
            cout<<k<<endl;
        else
            cout<<i<<endl;
    }
    return 0;
}
时间: 2024-08-09 02:04:17

1024. Palindromic Number (25)的相关文章

PAT 1024. Palindromic Number (25)

1024. Palindromic Number (25) A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Non-palindromic nu

PAT 甲级 1024 Palindromic Number (25 分)(大数加法,考虑这个数一开始是不是回文串)

1024 Palindromic Number (25 分) A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Non-palindromic n

1024 Palindromic Number (25 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Non-palindromic numbers can be paired with palin

1024 Palindromic Number (25)(25 point(s))

problem A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Non-palindromic numbers can be paired wi

PAT Advanced 1024 Palindromic Number (25分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Non-palindromic numbers can be paired with palin

【PAT甲级】1024 Palindromic Number (25 分)

题意: 输入两个正整数N和K(N<=1e10,k<=100),求K次内N和N的反置相加能否得到一个回文数,输出这个数和最小的操作次数. trick: 1e10的数字相加100次可能达到1e40,所以long long会爆,采用字符数组操作,以及代码注释中遇到的一些小问题. 代码: #define HAVE_STRUCT_TIMESPEC#include<bits/stdc++.h>using namespace std;char num[107];char s[107];//这里用

A1024. Palindromic Number (25)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Non-palindromic numbers can be paired with palin

1024 Palindromic Number int_string转换 大整数相加

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Non-palindromic numbers can be paired with palin

PAT 1024 Palindromic Number

#include <cstdio> #include <iostream> #include <cstdlib> #include <algorithm> using namespace std; void print(vector<char> &num) { int len = num.size(); bool value_begin = false; for (int i=0; i<len; i++) { if (!value_