50、BGP配置实验之社团属性community

1、社团属性community解析

BGP社团属性community:

可开启:BGP社团属性community为可选属性,默认不识别。可通过命令开启:neighbor x.x.x.x send-community

传递性:BGP社团属性community只在邻居有效,邻居的邻居不再有效,想要传递到邻居的邻居需配置neighbor x.x.x.x send-community

修改BGP社团属性community步骤:

ip prefix-list 1 permit 1.1.1.0/24

route-map COM permit 10

match ip address prefix-list 1

set community no-advertise 不传给BGP邻居

set community no-export不传出大AS

set community local-AS 不传出小AS

route-map COM permit 20

router bgp 1

neighbor 12.1.1.2 send-community

neighbor 12.1.1.2 route-map COM out

2、实验拓扑

3、基础配置

R1配置

interface Loopback0

ip address 1.1.1.1 255.255.255.0

interface Serial0/0

ip address 12.1.1.1 255.255.255.0

router bgp 1

no synchronization

bgp router-id 1.1.1.1

network 1.1.1.0 mask 255.255.255.0

neighbor 12.1.1.2 remote-as 2

neighbor 12.1.1.2 send-community

no auto-summary

R2配置

interface Loopback0

ip address 2.2.2.2 255.255.255.0

interface Serial0/0

ip address 12.1.1.2 255.255.255.0

interface Serial0/1

ip address 23.1.1.2 255.255.255.0

router ospf 110

router-id 2.2.2.2

network 2.2.2.0 0.0.0.255 area 0

network 23.1.1.0 0.0.0.255 area 0

router bgp 64512

no synchronization

bgp router-id 2.2.2.2

bgp confederation identifier 2

neighbor 3.3.3.3 remote-as 64512

neighbor 3.3.3.3 update-source Loopback0

neighbor 3.3.3.3 next-hop-self

neighbor 12.1.1.1 remote-as 1

neighbor 3.3.3.3 send-community

no auto-summary

R3配置

interface Loopback0

ip address 3.3.3.3 255.255.255.0

interface Serial0/0

ip address 34.1.1.3 255.255.255.0

interface Serial0/1

ip address 23.1.1.3 255.255.255.0

router ospf 110

router-id 3.3.3.3

network 3.3.3.0 0.0.0.255 area 0

network 23.1.1.0 0.0.0.255 area 0

network 34.1.1.0 0.0.0.255 area 0

router bgp 64512

no synchronization

bgp router-id 3.3.3.3

bgp confederation identifier 2

bgp confederation peers 64513

neighbor 2.2.2.2 remote-as 64512

neighbor 2.2.2.2 update-source Loopback0

neighbor 4.4.4.4 remote-as 64513

neighbor 4.4.4.4 ebgp-multihop 255

neighbor 4.4.4.4 update-source Loopback0

neighbor 4.4.4.4 send-community

no auto-summary

R4配置

interface Loopback0

ip address 4.4.4.4 255.255.255.0

interface Serial0/0

ip address 34.1.1.4 255.255.255.0

interface Serial0/1

ip address 45.1.1.4 255.255.255.0

router ospf 110

router-id 4.4.4.4

network 4.4.4.0 0.0.0.255 area 0

network 34.1.1.0 0.0.0.255 area 0

network 45.1.1.0 0.0.0.255 area 0

router bgp 64513

no synchronization

bgp router-id 4.4.4.4

bgp confederation identifier 2

bgp confederation peers 64512

neighbor 3.3.3.3 remote-as 64512

neighbor 3.3.3.3 ebgp-multihop 255

neighbor 3.3.3.3 update-source Loopback0

neighbor 5.5.5.5 remote-as 64513

neighbor 5.5.5.5 update-source Loopback0

neighbor 5.5.5.5 send-community

no auto-summary

R5配置

interface Loopback0

ip address 5.5.5.5 255.255.255.0

interface Serial0/0

ip address 56.1.1.5 255.255.255.0

interface Serial0/1

ip address 45.1.1.5 255.255.255.0

router ospf 110

router-id 5.5.5.5

network 5.5.5.0 0.0.0.255 area 0

network 45.1.1.0 0.0.0.255 area 0

router bgp 64513

no synchronization

bgp router-id 5.5.5.5

bgp confederation identifier 2

neighbor 4.4.4.4 remote-as 64513

neighbor 4.4.4.4 update-source Loopback0

neighbor 56.1.1.6 remote-as 6

neighbor 56.1.1.6 send-community

no auto-summary

R6配置

interface Loopback0

ip address 6.6.6.6 255.255.255.0

interface Serial0/0

ip address 56.1.1.6 255.255.255.0

router bgp 6

no synchronization

bgp router-id 6.6.6.6

neighbor 56.1.1.5 remote-as 2

no auto-summary

4、社团属性验证

ip prefix-list 1 seq 5 permit 1.1.1.0/24

route-map COM permit 10

match ip address prefix-list 1

set community no-advertise

route-map COM permit 20

router bgp 1

neighbor 12.1.1.2 send-community

neighbor 12.1.1.2 route-map COM out

ip prefix-list 1 seq 5 permit 1.1.1.0/24

route-map COM permit 10

match ip address prefix-list 1

set community no-export

route-map COM permit 20

router bgp 1

neighbor 12.1.1.2 send-community

neighbor 12.1.1.2 route-map COM out

ip prefix-list 1 seq 5 permit 1.1.1.0/24

route-map COM permit 10

match ip address prefix-list 1

set community local-AS

route-map COM permit 20

router bgp 1

neighbor 12.1.1.2 send-community

neighbor 12.1.1.2 route-map COM out

时间: 2024-10-26 19:14:11

50、BGP配置实验之社团属性community的相关文章

43、BGP配置实验之聚合aggregate-address

1.实验拓扑 2.基础配置 R1配置 interface Loopback0 ip address 1.1.1.1 255.255.255.0 interface Serial0/0 ip address 13.1.1.1 255.255.255.0 interface FastEthernet1/0 ip address 124.1.1.1 255.255.255.0 router ospf 110 log-adjacency-changes network 1.1.1.0 0.0.0.255

47、BGP配置实验之MED选路

1.as-path选路解析 属性 传播范围 默认值 优先值 方向 备注 weight 本路由器 本路由器32768,其他路由器0 大值优先 IN CISCO私有 Local preference AS内部 100:边界路由器,通告给IBGP邻居,告知如何离开本AS 大值优先 OUT As path AS之间 无 短优先 IN.OUT MED AS内部 0:通告给EBGP,告知如何进入本AS 小优先 OUT 修改MED值的方法: 2.实验拓扑 3.基础配置 R1配置 interface Loopb

45、BGP配置实验之Local preference选路

1.Local preference选路解析 属性 传播范围 默认值 优先值 方向 备注 weight 本路由器 本路由器32768,其他路由器0 大值优先 IN CISCO私有 Local preference AS内部 100:边界路由器,通告给IBGP邻居,告知如何离开本AS 大值优先 OUT 修改Local preference值的方法: 方法一:全部修改通告给IBGP邻居的路由的Local preference值,例如: router bgp 4 bgp default local-p

BGP的community社团属性

如图,R1在AS1中,R2,R3,R4在一个大AS100中(R2,R3在AS23中,R4在AS4中),5在AS5中.标准Community社团属性----邻居之间一定要开启传输社团属性R2#show run | s route-maproute-map aa permit 10match ip address 1set community internet 全网都可以传递route-map aa permit 20match ip address 2set community local-AS

# 大小型网络构建-BGP加实验验证

大小型网络构建-BGP加实验验证 BGP -定义-概述-原理#建立邻居表#同步数据库 :network {精确的路由条目}import-route {protocol}BGP数据库中每个条目的状态,必须是: , 表示的是"best -- 最好的".1.尝试着放入自己的路由表:2.发送给自己的 BGP 邻居:#计算路由表 -报文 open :包含BGP建立邻居时需要协商的参数update:包含的是 BGP 路由条目 keep-alive : 用于周期性的发送,维护邻居关系:notific

使用GNS3软件配置VTP、DHCP和单臂路由的详细截图和配置实验

使用软件GNS3配置VTP.DHCP和单臂路由的集体实验 首先创建拓扑图:红色字体是路由交换需要做的项目. SW1上的配置: 首先是trunk链路并做两条以太网通道.注意看是谁和谁捆绑在了一起!!!别搞错了哦! 然后配置SW1的VTP域和server(服务)模式 在fa1/0上面配置trunk模式(连接路由器的那个端口) 创建两个VLAN,让下面两个交换机自动学习 SW2上的配置: 首先配置的是VTP域和SW3一样都是配置了客户模式 给相应的端口配置trunk和以太网通道(注意以太网通道编号,要

samba配置实验

实验一 要求: 将目录/usr/src 共享给所有人 共享名设为tools 允许所有人访问.无需密码验证 访问权限为只读 系统:RHEL6.4 1.安装软件包 [[email protected] ~]# rpm -q samba-client samba samba-common package smaba-client is not installed ...... [[email protected] ~]# vim /etc/repos.d/rhel.repo [rhel6.4] nam

windows server 2008的安装以及主机IP配置实验

第2天:nsd windows 实验01:安装windows server 2008 r2 实验目标:配置一台安装windows server 2008 r2操作系统的虚拟机 实验环境:无 实验步骤: 1配置一台未安装操作系统的虚拟机裸机 等待windows安装完成 首次进入系统需要设置密码 结果验证:安装完成 问题和经验总结 实验02:配置主机IP并ping通 实验目标:新建两台虚拟机,一台为windows server 2008 r2,另一台为windows7,分别为两台虚拟机配置IP地址,

ASA基本配置实验报告

网络运维 ASA基本配置 实验报告 姓名: 李军 班级: NTD1710 日期: 2017 年 12 月 29 日实验任务 验证R1可以telnet到R2和R3,R3可以telnet到R2但不能telnet到R1,R2不能telnet到R1和R3思路及实验步骤 将RR的端口额IP设置正确并开启路由功能EnableConfigure terminalIp routingInterface fastethernet 1/0Ip address 172.16.1.1 255.255.255.0No s