light_oj 1236 求最小公倍数( lcm(a,b) )等于n的数对 素因数分解

light_oj 1236 求最小公倍数( lcm(a,b) )等于n的数对  素因数分解

H - Pairs Forming LCM

Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Submit Status Practice LightOJ 1236

Description

Find the result of the following code:

long long pairsFormLCM( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        for( int j = i; j <= n; j++ )
           if( lcm(i, j) == n ) res++; // lcm means least common multiple
    return res;
}

A straight forward implementation of the code may time out. If you analyze the code, you will find that the code actually counts the number of pairs (i, j) for which lcm(i, j) = n and (i ≤ j).

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1014).

Output

For each case, print the case number and the value returned by the function ‘pairsFormLCM(n)‘.

Sample Input

15

2

3

4

6

8

10

12

15

18

20

21

24

25

27

29

Sample Output

Case 1: 2

Case 2: 2

Case 3: 3

Case 4: 5

Case 5: 4

Case 6: 5

Case 7: 8

Case 8: 5

Case 9: 8

Case 10: 8

Case 11: 5

Case 12: 11

Case 13: 3

Case 14: 4

Case 15: 2

题意:对给定的n,求符合lcm(a,b)==n的(a,b)的数对的个数。

思路:对n进行素数分解,a和b与n对应分解

n=p1^e1*p2^e2*...*pk^ek;

a=p1^a1*p2^a2*…*pk^ak
     b=p1^b1*p2^b2*…*pk^bk
对于a,b它们的最小公倍数为n,则a1<=e1,b1<=e1,则(a1,b1)有2*(e1+1)-1对则总的对数有t=(2*e1+1)*(2*e2+1)....,其中除了(n,n),其他的都重复了两次则答案为(t+1)/2.

注意由于n的范围是10^14,因此素数筛到10^7,然而还是会漏过素因子,但显然只会漏过最多一个素因子,因为sqrt(10^14)==10^7,如果有两个大于10^7的素因子,根据素数分解公式,必定含有这两个大于10^7的素因子,相乘一定大于10^14大于n,与分解等式矛盾。因此只需最后特判最后一个即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<vector>
#include<stack>
#include<queue>
#include<set>
#include<map>
#include<string>
#include<math.h>
#include<cctype>

using namespace std;

typedef long long ll;
const int maxn=10000100;
const int INF=(1<<29);
const double EPS=0.0000000001;
const double Pi=acos(-1.0);

int T;
ll n;
vector<ll> prime;
bool isprime[maxn];

void play_prime()
{
    memset(isprime,1,sizeof(isprime));
    isprime[1]=0;
    for(int i=2;i<maxn;i++){
        if(!isprime[i]) continue;
        for(int j=i*2;j<maxn;j+=i) isprime[j]=0;
    }
    for(int i=1;i<maxn;i++) if(isprime[i]) prime.push_back(i);
}

int main()
{
    int tag=1;
    cin>>T;
    play_prime();
    while(T--){
        cin>>n;
        ll ans=1;
        for(int i=0;i<prime.size()&&prime[i]<=n;i++){
            ll t=prime[i];
            int cnt=0;
            while(n%t==0){
                n/=t;
                cnt++;
            }
            ans*=(2*cnt+1);
        }
        if(n>1) ans*=(2*1+1);
        ans=(ans+1)/2;
        printf("Case %d: %lld\n",tag++,ans);
    }
    return 0;
}

时间: 2024-10-06 06:45:32

light_oj 1236 求最小公倍数( lcm(a,b) )等于n的数对 素因数分解的相关文章

模板 求GCD&amp;LCM

求最大公倍数 1 int GCD(int a,int b) 2 { 3 if(a % b == 0) return b; 4 else 5 return GCD(b,a%b); 6 } 求最小公倍数 1 int LCM(int a,int b) 2 { 3 return a*a/GCD(a,b); //最小公倍数等于两数乘积除以最大公约数 4 }

LightOJ 1236 Pairs Forming LCM (LCM 唯一分解定理 + 素数筛选)

http://lightoj.com/volume_showproblem.php?problem=1236 Pairs Forming LCM Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu Submit Status Practice LightOJ 1236 Description Find the result of the following code: long long pairs

LightOJ 1236 - Pairs Forming LCM (LCM&#183;唯一分解)

题意  给你一个数n  求满足lcm(a, b) == n, a <= b 的 (a,b) 的个数 容易知道 n 是a, b的所有素因子取在a, b中较大指数的积 先将n分解为素数指数积的形式  n = π(pi^ei)    那么对于每个素因子pi  pi在a,b中的指数ai, bi 至少有一个等于pi, 另一个小于等于pi 先不考虑a, b的大小  对于每个素因子pi 1. 在a中的指数 ai == ei   那么 pi 在 b 中的指数可取 [0, ei] 中的所有数  有 ei + 1

(hdu step 2.1.1)最小公倍数(使用最大公约数来辅助求最小公倍数)

题目: 最小公倍数 Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3609 Accepted Submission(s): 2596   Problem Description 给定两个正整数,计算这两个数的最小公倍数. Input 输入包含多组测试数据,每组只有一行,包括两个不大于1000的正整数. Output 对于每个测试用例,给出这

求最小公倍数和最大公约数

1.分解素因数法:把每个数分别分解素因数,再把各数中的全部公有素因数提取出来连乘,所得的积就是这几个数的最大公约数:先把这几个数的质因数写出来,最小公倍数等于它们所有的质因数的乘积: 2.短除法:短除法求最大公约数,先用这几个数的公约数连续去除,一直除到所有的商互质为止,然后把所有的除数连乘起来,所得的积就是这几个数的最大公约数: 把数字依次相乘,最小公倍数等于它们所有因数的乘积: public class LeastCommonMultiple { // 定义两个数 private int m

1012 最小公倍数LCM

1012 最小公倍数LCM 基准时间限制:1 秒 空间限制:131072 KB 输入2个正整数A,B,求A与B的最小公倍数. Input 2个数A,B,中间用空格隔开.(1<= A,B <= 10^9) Output 输出A与B的最小公倍数. Input示例 30 105 Output示例 210 import java.util.Scanner; public class Main { static long gcd(long a,long b){ return a%b==0? b:gcd(

LightOJ 1236 - Pairs Forming LCM(素因子分解)

题意 给你一个数n 求满足lcm(a, b) == n, a <= b 的 (a,b) 的个数 容易知道 n 是a, b的所有素因子取在a, b中较大指数的积 先将n分解为素数指数积的形式 n = π(pi^ei) 那么对于每个素因子pi pi在a,b中的指数ai, bi 至少有一个等于pi, 另一个小于等于pi 先不考虑a, b的大小 对于每个素因子pi 1. 在a中的指数 ai == ei 那么 pi 在 b 中的指数可取 [0, ei] 中的所有数 有 ei + 1 种情况 2. 在a中的

1012 最小公倍数LCM(51NOD基础题)

1012 最小公倍数LCM(51NOD基础题) 基准时间限制:1 秒 空间限制:131072 KB 分值: 0 难度:基础题 输入2个正整数A,B,求A与B的最小公倍数. Input 2个数A,B,中间用空格隔开.(1<= A,B <= 10^9) Output 输出A与B的最小公倍数. Input示例 30 105 Output示例 210 #include <cstdio> #define LL long long LL n , m ; LL result ; // 递归实现辗

[2016-05-09][51nod][1012 最小公倍数LCM]

时间:2016-05-09 18:53:56 星期一 题目编号:[2016-05-09][51nod][1012 最小公倍数LCM] 题目大意:求a和b的最小公倍数 #include<cstdio> using namespace std; typedef long long ll; ll gcd(ll a,ll b){ return b == 0 ? a : gcd(b ,a%b); } ll lcm(ll a,ll b){ return a / gcd(a,b) * b; } int ma