Problem D: 零起点学算法95——弓型矩阵

#include<stdio.h>
#include<string.h>
int main()
{
    int n,m,a[20][20];
    while(scanf("%d%d",&n,&m)!=EOF)
    {

        int t,i,j;
        t=a[i=0][j=0]=1;
        while(t<n*m)
        {
            while(j+1<m)
              a[i][++j]=++t;
              a[++i][j]=++t;
            while(j-1>=0)
              a[i][--j]=++t;
              a[++i][j]=++t;
        }

        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m-1;j++)
            {
                printf("%2d ",a[i][j]);
            }
            printf("%2d\n",a[i][m-1]);
        }
    }

    return 0;
}

原文地址:https://www.cnblogs.com/chenlong991223/p/10042223.html

时间: 2024-10-07 14:51:21

Problem D: 零起点学算法95——弓型矩阵的相关文章

1156: 零起点学算法63——弓型矩阵

1156: 零起点学算法63--弓型矩阵 Time Limit: 1 Sec  Memory Limit: 64 MB   64bit IO Format: %lldSubmitted: 3403  Accepted: 1284[Submit][Status][Web Board] Description 输出n*m的弓型矩阵 Input 多组测试数据 每组输入2个整数 n和m(不大于20) Output 输出n*m的弓型矩阵,要求左上角元素是1,(每个元素占2个位置,靠右) Sample In

武汉科技大学ACM :1009: 零起点学算法63——弓型矩阵

Problem Description 输出n*m的弓型矩阵 Input 多组测试数据 每组输入2个整数 n和m(不大于20) Output 输出n*m的弓型矩阵,要求左上角元素是1,(每个元素占2个位置,靠右) Sample Input 4 3 Sample Output 1 2 3 6 5 4 7 8 9 12 11 10 我的代码: 1 #include<iostream> 2 #include <iomanip> 3 using namespace std; 4 5 int

Problem O: 零起点学算法10——求圆柱体的表面积

#include<stdio.h> int main() { float r,h,pi; pi=3.1415926; scanf("%f %f",&r,&h); printf("Area=""%.3f",2*pi*r*r+2*pi*r*h); return 0; } 原文地址:https://www.cnblogs.com/chenlong991223/p/9720035.html

Problem U: 零起点学算法19——输出特殊值

#include<stdio.h> int main() { printf("%%d"); return 0; } 原文地址:https://www.cnblogs.com/chenlong991223/p/9720422.html

Problem V: 零起点学算法20——输出特殊值II

#include<stdio.h> int main() { printf("\\n"); return 0; } 原文地址:https://www.cnblogs.com/chenlong991223/p/9720428.html

Problem S: 零起点学算法14——三位数反转

#include<stdio.h> #include<stdlib.h> int main() { int a,b,c,s; scanf("%d",&s); a=s/100; b=s%100/10; c=s%100%10; printf("%d%d%d",c,b,a); system("pause"); return 0; } 原文地址:https://www.cnblogs.com/chenlong991223/

Problem T: 零起点学算法15——交换变量

#include<stdio.h> int main() { int a,b,c; scanf("%d %d",&a,&b); c=a; a=b; b=c; printf("%d %d",a,b); return 0; } 原文地址:https://www.cnblogs.com/chenlong991223/p/9720399.html

Problem Z: 零起点学算法22——求正弦和余弦

#include<stdio.h> #include <math.h> int main() { int n; const double pi=acos(-1); double a,b; while(scanf("%d",&n)!=EOF) a=sin(n*pi/180); b=cos(n*pi/180); printf("%.2f\n%.2f\n",a,b); return 0; } 原文地址:https://www.cnblogs

Problem Y: 零起点学算法21——摄氏温度转换

#include<stdio.h> int main() { float f,c; while(scanf("%f",&f)!=EOF) c=5.0/9*(f-32); printf("%.3f",c); return 0; } 原文地址:https://www.cnblogs.com/chenlong991223/p/9742929.html