最长最短单词c++

本人只是一个菜鸡。这还是要感谢一个大佬的帮助才能够写出来。分享给大家。

#include<bits/stdc++.h>
using namespace std;
int main()
{
char a[20000];
char wlong[200];
char wshort[200],word[200];
int numlong=0,numshort=100;
int i,n,l,k,cl;
l=0;
k=0;
cin.getline(a,20000);
n=strlen(a);
for(i=0;i<=n;i++)
{
if(a[i]!=‘ ‘&&a[i]!=‘,‘&&a[i]!=0)
{
l++;
word[k]=a[i];
k++;
}
if(a[i]==‘ ‘||a[i]==‘,‘||a[i]==0)
{
if(l>numlong)
{
numlong=l;
strcpy(wlong,word);
}
if(l>0&&l<numshort)
{
numshort=l;
strcpy(wshort,word);
}
l=0;
k=0;
for(cl=0;cl<=200;cl++)
word[cl]=‘\0‘;
}

}
cout<<wlong<<endl;
cout<<wshort;
return 0;
}

原文地址:https://www.cnblogs.com/5t2y0/p/9229771.html

时间: 2024-11-04 12:49:57

最长最短单词c++的相关文章

AC日记——最长最短单词 openjudge 1.7 25

25:最长最短单词 总时间限制:  1000ms 内存限制:  65536kB 描述 输入1行句子(不多于200个单词,每个单词长度不超过100),只包含字母.空格和逗号.单词由至少一个连续的字母构成,空格和逗号都是单词间的间隔. 试输出第1个最长的单词和第1个最短单词. 输入 一行句子. 输出 两行输出:第1行,第一个最长的单词.第2行,第一个最短的单词. 样例输入 I am studying Programming language C in Peking University 样例输出 P

最长最短单词

21:最长最短单词    总时间限制:1000ms  内存限制:65536kB描述    输入1行句子(不多于200个单词,每个单词长度不超过100),    只包含字母.空格和逗号.单词由至少一个连续的字母构成,    空格和逗号都是单词间的间隔.    试输出第1个最长的单词和第1个最短单词.输入    一行句子.输出    两行输出:    第1行,第一个最长的单词.    第2行,第一个最短的单词.样例输入    I am studying Programming language C

统计语句中的最长最短单词

已知 string sentence="We were her pride of 10 she named us: Benjamin, Phoenix, the Pordigal and perspicacious pacific Suzanne.";编写程序,计算sentence中有多少个单次,并指出其中最长和最短的单词,如果有多个,则将它们全部输出 使用find_first_of 和find_first_not_of,寻找到单词的起始位置: 使用vector存放最长和最短单词:通过

【C】字符串的输入,求输入字符串中最长的单词

首先,基本目标很简单,就是利用C语言:编写一个函数,输入一行字符,将此行字符中的最长的单词输出. 代码如下: #include<stdio.h> void input(char s[]){ int i=0; for(int c;(c=getchar())!='\n';i++){ s[i]=c; } s[i]='\0';//读取完成,记得对这个字符数组封口 } char* findmax(char s[]){ int max=0,word_length=0,p=0,i=0;//这个p是用来记录最

寻找最长的单词算法

给定一句话,查询出里面的最长单词的长度. 返回提供的句子中最长的单词的长度. 返回值应该是一个数字. 以split()分割句子里的每个单词保存的数组里,然后比较最长的单词. function findLongestWord(str) { var s=str.split(" "); var len=0; for(i=0;i<s.length;i++){ if(s[i].length>len){ len=s[i].length; } } return len; } findLo

[LeetCode] 244. Shortest Word Distance II 最短单词距离 II

This is a follow up of Shortest Word Distance. The only difference is now you are given the list of words and your method will be called repeatedly many times with different parameters. How would you optimize it? Design a class which receives a list

[LeetCode] 243. Shortest Word Distance 最短单词距离

Given a list of words and two words word1 and word2, return the shortest distance between these two words in the list. For example,Assume that words = ["practice", "makes", "perfect", "coding", "makes"]. G

搜索(BFS)---最短单词路径

最短单词路径 127. Word Ladder (Medium) Input: beginWord = "hit", endWord = "cog", wordList = ["hot","dot","dog","lot","log","cog"] Output: 5 Explanation: As one shortest transformat

来自百度贴吧的练习题 :求最长单词的长度和最短单词的长度。

In the function ex5 write code that will input a line of text, split it into words, and display these words one per line, and also print the length of the longest and shortest words. You should regard any sequence of consecutive non-space characters