River Hopscotch(二分最大化最小值)

River Hopscotch

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 9923   Accepted: 4252

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: LN, and M  Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25)

题解:

河中起点终点各有一个石头,然后再给你N块石头,代表在河中的位置,问去掉M块石头后的最大最小值为多少,二分极大化最小值;二分错点就是关于里面的大于等于之类判断的问题,可以想成当l,r相等时谁最后判断的就好了,l+1跳出来,直接return l-1就可以了;

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
using namespace std;
const int INF=0x3f3f3f3f;
#define mem(x,y) memset(x,y,sizeof(x))
#define SI(x) scanf("%d",&x)
#define PI(x) printf("%d",x)
#define T_T while(T--)
const int MAXN=50010;
int rock[MAXN];
int N,M;
int js(int x){
	int cnt=0;
	int last=rock[0];
	for(int i=1;i<=N+1;i++){
		if(rock[i]-last<x){
			cnt++;
		}
		else last=rock[i];
	}
	return cnt;
}
int erfen(int l,int r){
	int mid;
	while(l<=r){
		mid=(l+r)>>1;
		if(js(mid)>M)r=mid-1;//就把等号去了,后面变成l-1就对了。。。。
		else l=mid+1;
	}
	return l-1;
}
int main(){
	int L;
	while(~scanf("%d%d%d",&L,&N,&M)){
		rock[0]=0;
		for(int i=1;i<=N;i++)SI(rock[i]);
		rock[N+1]=L;
		sort(rock,rock+N+2);
		printf("%d\n",erfen(0,L));
	}
	return 0;
}

  

时间: 2024-07-28 13:31:38

River Hopscotch(二分最大化最小值)的相关文章

POJ - 3258 River Hopscotch(二分 最大化最小值)

大致题意: 坐标 从  [0-L], 上有 N 个点 , 现在需要移去 M 个点.求任意两点(包括0,L)点的距离中最小值的最大值 思路:枚举答案,若移去M个点不能达成目标,则使答案变小. while(l <= r){ ll mid = l + (r-l)/2; // 是否可能使得所有石头之间的距离不小于 mid if(check(mid)){ l = mid+1; }else{ r = mid-1; } } printf("%lld\n",l-1); 1 bool check(

【贪心专题】POJ 3258 River Hopscotch (最大化最小值 贪心+二分搜索)

链接:click here~~ [题意] 一条河长度为 L,河的起点(Start)和终点(End)分别有2块石头,S到E的距离就是L,河中有n块石头,每块石头到S都有唯一的距离,,现在要你移除其中的m块,使得具有最小间距的相邻两块石头之间的距离最大. [解题思路] 又是一道经典的二分搜索,跟前一道一样的思路,不过要注意的是:此题是移除其中的元素,从而达到最大化的最小值. 代码: #include <stdio.h> #include <string.h> #include <

POJ 3258 River Hopscotch 二分答案

River Hopscotch Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 6193   Accepted: 2685 Description Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. T

POJ3258:River Hopscotch(二分)

Description Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at th

[ACM] POJ 3258 River Hopscotch (二分,最大化最小值)

River Hopscotch Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 6697   Accepted: 2893 Description Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. T

POJ 3258- River Hopscotch(二分求最小值最大)

River Hopscotch Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 3258 Appoint description:  System Crawler  (2015-05-27) Description Every year the cows hold an event featuring a peculiar version

POJ3258 River Hopscotch —— 二分

题目链接:http://poj.org/problem?id=3258 River Hopscotch Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 15753   Accepted: 6649 Description Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully ju

POJ 3258 River Hopscotch(二分求最小中的最大)

Description Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at th

POJ - 3258 River Hopscotch 二分

题目大意:给出河的宽度L和N块石头,现在要求移除M块石头,使得石头间的距离的最小值达到最大(起点和终点都有一块石头,但这两块石头不能移除) 解题思路:最小值的最大值,肯定用二分了 如果存在最优的距离,那么移走的石头数量肯定刚好是M块的 枚举的时候判断移除石头的数量,只需要从起点开始枚举,然后计算一下在最小跳跃距离内的石头有几个,有几个就移除几个,最后判断移除了多少个石头 如果移走的数量大于M,就表示所枚举的长度偏大 如果移走的数量小于M,就表示所枚举的长度偏小 有一种比较特殊的情况,就是N =