HDU 1162 Eddy's picture(图论-最小生成树)

题目如下:

Eddy‘s picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7267    Accepted Submission(s): 3676

Problem Description

Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends
are not interested in his picture.Eddy feels very puzzled,in order to change all friends ‘s view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.

Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length
which the ink draws?

Input

The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

Sample Input

3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output

3.41

题目大意:

给出n个点的坐标(二维x, y),可以使用直线(无向的)将任意两个点连接起来,求将所有点连接起来形成一个整体(使任何两点之间可达),线的最小距离。

一个简单的最小生成树问题,这里边的权要根据输入的点的坐标信息求出,在输入的时候存储点的数组中下标可以认为是该点的编号,通过O(n^2)的复杂度来求任意两个不同点之间的距离作为权,边的两个顶点就是这段距离两端点的编号。则接下来就是简单的最小生成树算法了,可以使用kruskal也可以使用prim。

kruskal算法实现

#include <cstdio>
#include <vector>
#include <algorithm>
#include <cmath>

using namespace std;

const int N = 105;

struct Edge
{
	int x, y;
	double w;
};

struct Point
{
	double x;
	double y;
};

int pre[N];
Point point[N];
Edge edges[N * N / 2];

int i_p, i_e, cnt;
double res;

int root(int x)
{
	if (x != pre[x])
	{
		pre[x] = root(pre[x]);
	}
	return pre[x];
}

bool merge(int x, int y)
{
	int fx = root(x);
	int fy = root(y);

	bool ret = false;

	if (fx != fy)
	{
		pre[fx] = pre[fy];
		ret = true;
		--cnt;
	}
	return ret;
}

void init(int n)
{
	cnt = n;
	res = 0;

	for (int i = 0; i <= n; ++i)
	{
		pre[i] = i;
	}
}

bool cmp(const Edge &a, const Edge &b)
{
	return a.w < b.w;
}

int main()
{
	int n;
	double dx, dy;

	while (scanf("%d", &n) != EOF)
	{
		init(n);

		i_e = i_p = 0;

		for (int i = 0; i < n; ++i)
		{
			scanf("%lf %lf", &dx, &dy);
			point[i_p].x = dx;
			point[i_p].y = dy;
			++i_p;
		}

		for (int i = 0; i < n; ++i)
		{
			for (int j = i + 1; j < n; ++j)
			{
				edges[i_e].x = i;
				edges[i_e].y = j;
				double dd = (point[i].x - point[j].x) * (point[i].x - point[j].x);
				dd += (point[i].y - point[j].y) * (point[i].y - point[j].y);
				edges[i_e].w = sqrt(dd);
				++i_e;
			}
		}

		sort(edges, edges + i_e, cmp);

		//the cnt == 1 indicates that the mixnum spanning tree is builded sucessfully.
		for (int i = 0; i < i_e && cnt != 1; ++i)
		{
			if (merge(edges[i].x, edges[i].y))res += edges[i].w;
		}

		printf("%.2lf\n", res);
	}
	return 0;
}

HDU 1162 Eddy's picture(图论-最小生成树)

时间: 2024-10-10 13:00:41

HDU 1162 Eddy's picture(图论-最小生成树)的相关文章

HDU 1162 Eddy&#39;s picture【最小生成树,Prime算法+Kruskal算法】

Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9334    Accepted Submission(s): 4711 Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to

hdu 1162 Eddy&#39;s picture(最小生成树)

Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result i

HDU 1162 Eddy&#39;s picture (最小生成树 prim)

题目链接 Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the res

hdu 1162 Eddy&#39;s picture 最小生成树入门题 Prim+Kruskal两种算法AC

Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7428    Accepted Submission(s): 3770 Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to

hdu 1162 Eddy&#39;s picture(最小生成树算法)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1162 Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6866    Accepted Submission(s): 3469 Problem Description Eddy begins to like p

HDU 1162 Eddy&#39;s picture (最小生成树)(java版)

Eddy's picture 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1162 --每天在线,欢迎留言谈论. 题目大意: 给你N个点,求把这N个点连在一起的最短总距离. 思路: 假设每两两点之间都有路径,求最小生成树. AC代码:(Java) 1 import java.util.Scanner; 2 import java.math.*; 3 public class Main { 4 public static final int MAX

hdu 1162 Eddy&#39;s picture (Kruskal算法,prim算法,最小生成树)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1162 [题目大意] 给你n个点的坐标,让你找到联通n个点的一种方法,保证联通的线路最短,典型的最小生成树问题. 方法一 , 通过不断找到最小的边来找到最终结果. Kruskal 算法 #include <iostream> #include <algorithm> #include <cstdio> #include <cmath> using namespac

hdu 1162 Eddy&#39;s picture

最小生成树裸题,没有初始化都能AC,看来测试数据只有一组 #include<iostream> #include<vector> #include<cmath> #include<cstdio> #define inf 1<<30 #define maxn 105 using namespace std; struct stu { double x,y; }; stu mapp[maxn]; int n; vector<int>roo

题解报告:hdu 1162 Eddy&#39;s picture

Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result i