Power Network(最大流基础_增广路算法:多源多汇,自建总源点和总汇点)



Power NetworkCrawling in process...
Crawling failed
Time Limit:2000MS    
Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Submit
Status

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p
max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c
max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at
most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l
max(u,v) of power delivered by u to v. Let Con=Σ
uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p
max(u)=y. The label x/y of consumer u shows that c(u)=x and c
max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l
max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines).
Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l
max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p
max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c
max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and
are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a
separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum
value of Con is 15. The second data set encodes the network from figure 1.

ps:坑我的一道题啊,题目看了好长时间才明白,那么多数据直接吓哭我了,输入的时候也调试了好久,以后再也不在输入的时候随便打空格了。怎么会有这样的呢!输出按ctrl+z

题意:有n个结点,np个发电站,nc个消费者,m个电力运输线。接下去是n条边的信息(u,v)cost,cost表示边(u,v)的最大流量;a个发电站的信息(u)cost,cost表示发电站u能提供的最大流量;b个用户的信息(v)cost,cost表示每个用户v能接受的最大流量。

思路:在图中添加1个源点S和汇点T,将S和每个发电站相连,边的权值是发电站能提供的最大流量;将每个用户和T相连,边的权值是每个用户能接受的最大流量。从而转化成了一般的最大网络流问题,然后求解。(自己语言总结不好,觉得这个能看懂,就贴一下)

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <iostream>
#include <queue>
using namespace std;
#define inf  9999999999
int flow[210][210];
int maxflow[210],father[210],vis[210];
int max_flow;
int m,i;
void EK(int s,int e)
{
    queue<int >q;
    int u,v;
    max_flow=0;
    while(1)
    {
        memset(maxflow,0,sizeof(maxflow));
        memset(vis,0,sizeof(vis));
        maxflow[s]=inf;
        q.push(s);
        while(!q.empty())
        {
            u=q.front();
            q.pop();
            for(v=s;v<=e;v++)
            {
                if(!vis[v]&&flow[u][v]>0)
                {
                    vis[v]=1;
                    father[v]=u;
                    q.push(v);
                    maxflow[v]=min(maxflow[u],flow[u][v]);
                }
            }
            if(maxflow[e]>0)
            {
                while(!q.empty())
                    q.pop();
                break;
            }
        }
        if(maxflow[e]==0)
            break;
        for(i=e;i!=s;i=father[i])
        {
            flow[father[i]][i]-=maxflow[e];
            flow[i][father[i]]+=maxflow[e];
        }
        max_flow+=maxflow[e];
    }
}
int main()
{
    int n,np,nc,m;
	int i,a,b,c;
	char ch;
	while(~scanf("%d%d%d%d ",&n,&np,&nc,&m))//输入注意后面的空格
	{
		memset(flow,0,sizeof(flow));
		for(i=1;i<=m;i++)
		{
			scanf("(%d,%d)",&a,&b);
			scanf("%d ",&c);//注意后面的空格
			flow[a+1][b+1]=c;
		}
		for(i=1;i<=np;i++)//建立总源点
		{
			scanf("(%d)%d ",&a,&b);//注意后面空格
			flow[0][a+1]=b;
		}
		for(i=1;i<=nc;i++)//建立总汇点
		{
            scanf("(%d)%d ",&a,&b);//注意后面的空格
			flow[a+1][n+1]=b;
		}
		EK(0,n+1);
		printf("%d\n",max_flow);
	}
	return 0;
}

Power Network(最大流基础_增广路算法:多源多汇,自建总源点和总汇点)

时间: 2024-10-11 21:14:28

Power Network(最大流基础_增广路算法:多源多汇,自建总源点和总汇点)的相关文章

Drainage Ditches(最大流基础_增广路算法)

 Drainage DitchesCrawling in process... Crawling failed Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Description Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover p

最大流——增广路算法

关于网络流的增广路算法,网上有很多详细介绍,这里是摘录的模板.详细请见:http://www.cnblogs.com/kuangbin/archive/2011/07/26/2117636.html 1 #include<iostream> 2 #include<iomanip> 3 #include<ctime> 4 #include<climits> 5 #include<algorithm> 6 #include<queue>

关于最短增广路算法和连续最短增广路算法的操作步骤

最短增广路算法(SAP): 1.初始化容量网络和网络流: 2.构造残留网络和层次网络,如果汇点不在层次网络中,则算法结束: 3.在层次网络中不断用BFS增广,直到层次网络中没有增广路为止:每次增广完毕,在层次网络中要去掉因改进流量而导致饱和的弧: 4.转到步骤(2). 连续最短增广路算法(Dinic): 1.初始化容量网络和网络流: 2.构造残留网络和层次网络,如果汇点不在层次网络中,则算法结束: 3.在层次网络中用一次DFS过程进行增广,DFS执行完毕,该阶段的增广也执行完毕: 4.转到步骤(

增广路算法

#include<queue> #include<cstdio> #include<iostream> #include<cstring> using namespace std; const int maxn = 20; const int INF = (1<<30); int cap[maxn][maxn],flow[maxn][maxn];//cap记录容量,flow记录流量 int m; //弧的数量 int EdmondsKarp(in

最大网络流——增广路算法

几句废话:读了刘汝佳的书之后,感觉一切都是那么茫然,于是自己在网上找教程,自己一点点码的,大概用了三天.网络流基础:看来我很有必要说一下网络流的基础网络流问题就是给你一个图,每个图的边权叫做这条边的流量,问你从起始点出发,有多少值能通过这些边流到重点我知道你没看懂,举个例子: 如图: 最大值为 从1到2到4运6个 从1到2到3到4运1个 从1到3到4运3个 一共运10个. 举例说完了,那么我说几个定义: 容量,就只一条边的权值,表示能从这条边运送的最大值 流量,表示一条边实际上流过的最大值 那么

网络流之 最短增广路算法模板(SAP)

数据输入格式:首先输入顶点个数n和弧数m,然后输入每条弧的数据.规定源点为顶点0,汇点为顶点n-1.每条弧的数据格式为:u,v,w,分别表示这条弧的起点,终点,容量.顶点序号从0开始. 代码: 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 #include <algorithm> 5 #include <cmath> 6 #include <string&g

网络流 之 一般增广路算法 标号法实现

数据输入格式:首先输入顶点个数n和弧数m,然后输入每条弧的数据.规定源点为顶点0,汇点为顶点n-1.每条弧的数据格式为:u,v,c,f,分别表示这条弧的起点,终点,容量和流量.顶点序号从0开始. 代码: 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 #include <algorithm> 5 #include <cmath> 6 #include <str

网络流——增广路算法(dinic)模板

1 #include<iostream> 2 #include<cstring> 3 #include<algorithm> 4 #include<cmath> 5 #include<cstdio> 6 #include<queue> 7 using namespace std; 8 struct data 9 { 10 int from,to,next,cup,flow; 11 data(){from=-1,to=-1,next=-

网络流初步——增广路算法(EK)模板

1 #include <iostream> 2 #include <queue> 3 #include<string.h> 4 using namespace std; 5 #define arraysize 201 6 int maxData = 0x7fffffff; 7 int a[222][222]; 8 int flow[222]; 9 int pre[222]; 10 int n,m; 11 queue<int> q; 12 int BFS(in