poj 1745 Divisibility(DP + 数学)

题目链接:http://poj.org/problem?id=1745

Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are
eight possible expressions: 17 + 5 + -21 + 15 = 16

17 + 5 + -21 - 15 = -14

17 + 5 - -21 + 15 = 58

17 + 5 - -21 - 15 = 28

17 - 5 + -21 + 15 = 6

17 - 5 + -21 - 15 = -24

17 - 5 - -21 + 15 = 48

17 - 5 - -21 - 15 = 18

We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible
by 5.

You are to write a program that will determine divisibility of sequence of integers.

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space.

The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it‘s absolute value.

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it‘s not.

Sample Input

4 7
17 5 -21 15

Sample Output

Divisible

Source

Northeastern Europe 1999

题意:

给出N和K,然后给出N个整数(不论正负),问在这N个数中,每两个数之间(即N - 1个位置)添加加号或者减号,然后运算的值对K取余,如果余数等于0输出Divisible,否则输出Not
divisible

思路:

4 7

17 5 -21 15

举例

首先一个数,不用说,第一个数之前不用加符号就是本身,那么本身直接对K取余,

那么取17的时候有个余数为2

然后来了一个5,

(2 + 5)对7取余为0

(2 - 5)对7取余为4(将取余的负数变正)

那么前2个数有余数0和4

再来一个-21

(0+21)对7取余为0

(0-21)对7取余为0

(4+21)对7取余为4

(4-21)对7取余为4

再来一个-15同样是这样

(0+15)%7 = 1

(0-15)%7 = 6

(4+15)%7 = 5

(4-15)%7 = 3

同理可以找到规律,定义dp[i][j]为前i个数进来余数等于j是不是成立,1为成立,0为不成立

那么如果dp[N][0]为1那么即可以组成一个数对K取余为0

初始化dp为0

然后dp[1][a[1]%k] = 1

for i = 2 to N do

for j = 0 to K do

if(dp[i - 1][j])

dp[i][(j + a[i])%k] = 1;

dp[i][(j - a[i])%k] = 1;

if end

for end

for end

以上系转载:http://blog.csdn.net/wangjian8006/article/details/10170671

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int a[10017];
int dp[10017][117];
//dp[i][j]为前i个数进来余数等于j是不是成立,1为成立,0为不成立
int n, k;
int f(int tt)
{
    tt %= k;
    while(tt < 0)
        tt+=k;
    return tt;
}

int main()
{
    while(~scanf("%d %d",&n,&k))
    {
        memset(dp,0,sizeof(dp));
        for(int i = 1; i <= n; i++)
        {
            scanf("%d",&a[i]);
        }
        dp[1][f(a[1])] = 1;
        for(int i = 2; i <= n; i++)
        {
            for(int j = 0; j < k; j++)
            {
                if(dp[i-1][j])
                {
                    dp[i][f(j+a[i])] = 1;
                    dp[i][f(j-a[i])] = 1;
                }
            }
        }
        if(dp[n][0])
        {
            printf("Divisible\n");
        }
        else
            printf("Not divisible\n");
    }
    return 0;
}
时间: 2024-10-19 01:46:05

poj 1745 Divisibility(DP + 数学)的相关文章

poj 1745 Divisibility (dp)

//给你n个数,两个数之间可以+.-两个运算 得出的所有结果只要有能被k正除,输出Divisible,否则Not divisible # include <iostream> # include <stdio.h> # include <algorithm> # include <string.h> using namespace std; int dp[10010][110];//第一维代表几个数相加,第二位为几个数相加%k后的余数 int b[10010

POJ 1745 Divisibility (线性dp)

Divisibility Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 10598   Accepted: 3787 Description Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmet

poj 1745 Divisibility 【DP】

Divisibility Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 11044   Accepted: 3949 Description Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmet

poj 1745 Divisibility(DP)

最大子矩阵 Time Limit: 30000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Problem Description 给你一个m×n的整数矩阵,在上面找一个x×y的子矩阵,使子矩阵中所有元素的和最大. Input 输入数据的第一行为一个正整数T,表示有T组测试数据.每一组测试数据的第一行为四个正整数m,n,x,y(0<m,n<1000 AND 0<x<=m AND 0<y

POJ 1745 Divisibility【DP】

题意:给出n,k,n个数,在这n个数之间任意放置+,-号,称得到的等式的值能够整除k则为可划分的,否则为不可划分的. 自己想的是枚举,将所有得到的等式的和算出来,再判断它是否能够整除k,可是有10000个数-_- 5555---还是看的题解-- 话说这样的状态好奇妙啊啊啊--- 用dp[i][j]表示等式中有i个数的时候余数为j是否成立,成立的话dp[i][j]的值为1,否则为0 然后就是递推的过程, 如果dp[i-1][j]为1,那么dp[i][(j-a[i])%k]=1,dp[i][(j+a

poj 1745 Divisibility

Divisibility Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%lld & %llu Description Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expr

POJ 1745 Divisibility(0,1背包)(好题)

题意: 输入n个有序数字,数字前可加上+或-,求是否存在这样的和,使得该和能够整除数字k 每个数字前只有取正或负两种情况,所以符合0,1背包,而且背包的重量是除k的余数(均是正数) //172 KB 297 ms C++ 785 B #include<cstdio> #include<cstring> #include<algorithm> #include<iostream> using namespace std; int num[10010]; boo

POJ 1745 【0/1 背包】

题目链接:http://poj.org/problem?id=1745 Divisibility Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 13431   Accepted: 4774 Description Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequen

POJ 1745 线性和差取余判断

POJ 1745 线性和差取余判断 题目大意:每个数都必须取到,相加或相减去,问所有的方案最后的得数中有没有一个方案可以整除k 这个题目的难点在于dp数组的安排上面 其实也就是手动模仿了一下 比如 一个数,不用说,第一个数之前不用加符号就是本身,那么本身直接对K取余, 那么取17的时候有个余数为2----基础然后来了一个5,(2 + 5)对7取余为0----层层延伸 (2 - 5)对7取余为4(将取余的负数变正) 那么前2个数有余数0和4再来一个-21(0+21)对7取余为0(0-21)对7取余