hdu4800 Josephina and RPG

Josephina and RPG

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 511    Accepted Submission(s): 139
Special Judge

Problem Description

A role-playing game (RPG and sometimes roleplaying game) is a game in which players assume the roles of characters in a fictional setting. Players take responsibility for acting out these roles within a narrative, either through literal acting or through a process of structured decision-making or character development.
Recently, Josephina is busy playing a RPG named TX3. In this game, M characters are available to by selected by players. In the whole game, Josephina is most interested in the "Challenge Game" part.
The Challenge Game is a team play game. A challenger team is made up of three players, and the three characters used by players in the team are required to be different. At the beginning of the Challenge Game, the players can choose any characters combination as the start team. Then, they will fight with N AI teams one after another. There is a special rule in the Challenge Game: once the challenger team beat an AI team, they have a chance to change the current characters combination with the AI team. Anyway, the challenger team can insist on using the current team and ignore the exchange opportunity. Note that the players can only change the characters combination to the latest defeated AI team. The challenger team gets victory only if they beat all the AI teams.
Josephina is good at statistics, and she writes a table to record the winning rate between all different character combinations. She wants to know the maximum winning probability if she always chooses best strategy in the game. Can you help her?

Input

There are multiple test cases. The first line of each test case is an integer M (3 ≤ M ≤ 10), which indicates the number of characters. The following is a matrix T whose size is R × R. R equals to C(M, 3). T(i, j) indicates the winning rate of team i when it is faced with team j. We guarantee that T(i, j) + T(j, i) = 1.0. All winning rates will retain two decimal places. An integer N (1 ≤ N ≤ 10000) is given next, which indicates the number of AI teams. The following line contains N integers which are the IDs (0-based) of the AI teams. The IDs can be duplicated.

Output

For each test case, please output the maximum winning probability if Josephina uses the best strategy in the game. For each answer, an absolute error not more than 1e-6 is acceptable.

Sample Input

4
0.50 0.50 0.20 0.30
0.50 0.50 0.90 0.40
0.80 0.10 0.50 0.60
0.70 0.60 0.40 0.50
3
0 1 2

Sample Output

0.378000

坑点: 有可能超过c(m,3),忽略可A

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <vector>
#include <iostream>
#define INF 10000005000
using namespace std;

const int maxm=10500;
const int maxn=150;

typedef long long LL;

int c[20][20],a[maxm];
double dp[2][maxn];
double cc[maxn][maxn];

void init()
{
	memset(c,0,sizeof(c));
	c[0][0]=c[1][0]=c[1][1]=1;
	for(int i=2;i<=15;i++){
		c[i][0]=c[i][i]=1;
		for(int j=1;j<i;j++) c[i][j]=(c[i-1][j]+c[i-1][j-1]);
	}
}

int main()
{
	int N,n,M,cur;
	double res;
	init();
	while(scanf("%d",&N)!=EOF){
		n=c[N][3];
		for(int i=0;i<n;i++) for(int j=0;j<n;j++) scanf("%lf",&cc[i][j]);
		memset(dp,0,sizeof(dp));
		scanf("%d",&M);
		for(int i=0;i<M;i++) {scanf("%d",&a[i]);if(a[i]>n)a[i]=0;}//ATTENTION!
	    for(int i=0;i<n;i++) dp[0][i]=cc[i][a[0]];
	    cur=1;
	    for(int i=1;i<M;i++){
	    	for(int j=0;j<n;j++) dp[cur][j]=0;
	    	for(int j=0;j<n;j++){
	    		dp[cur][j]=max(dp[cur][j],dp[cur^1][j]*cc[j][a[i]]);
	    		dp[cur][a[i-1]]=max(dp[cur][a[i-1]],dp[cur^1][j]*cc[a[i-1]][a[i]]);
	    	}
	    	cur^=1;
	    }
	    res=0;
	    for(int i=0;i<n;i++) res=max(res,dp[cur^1][i]);
	    printf("%.6f\n",res);
	}
}
时间: 2024-10-26 12:15:20

hdu4800 Josephina and RPG的相关文章

HDU 4800 Josephina and RPG

Josephina and RPG Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 605    Accepted Submission(s): 165Special Judge Problem Description A role-playing game (RPG and sometimes roleplaying game) is

Josephina and RPG 简单概率DP

Josephina and RPG 题目抽象:给出R=C(m,3)个队伍之间的胜率.给出需要挑战的n个队伍(按顺序).玩家最开始从R个队伍中任选一支队伍去挑战,当挑战某队伍成功时,可以将当前的队伍与挑战成功的队伍交换,也可以继续选择该队伍.  求最大的胜率. 思路:物理递推法. /*                    dp[i+1][j]            dp[i][j]=                    dp[i+1][num[i]]*/ 1 #include <iostrea

2013长沙赛区现场赛 J - Josephina and RPG

J - Josephina and RPG Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 4800 Description A role-playing game (RPG and sometimes roleplaying game) is a game in which players assume the roles of cha

hdu 4800 Josephina and RPG (动态规划)

Josephina and RPG Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 923    Accepted Submission(s): 261 Special Judge Problem Description A role-playing game (RPG and sometimes roleplaying game) i

Josephina and RPG

Josephina and RPG Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 929    Accepted Submission(s): 265Special Judge Problem Description A role-playing game (RPG and sometimes roleplaying game) is

HDU 4800 Josephina and RPG(动态规划)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4800 题面: Josephina and RPG Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1077    Accepted Submission(s): 320 Special Judge Problem Description A

HDU 4800 &amp; ZJU 3735 Josephina and RPG(状压dp)

题目链接: ZJU:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5081 HDU:http://acm.hdu.edu.cn/showproblem.php?pid=4800 Problem Description A role-playing game (RPG and sometimes roleplaying game) is a game in which players assume the roles of c

DP ZOJ 3735 Josephina and RPG

题目传送门 题意:告诉你C(m,3)个队伍相互之间的胜率,然后要你依次对战n个AI队伍,首先任选一种队伍,然后战胜一个AI后可以选择替换成AI的队伍,也可以不换,问你最后最大的胜率是多少. 分析:dp[i][j][0/1] 表示第i个AI,用j的id去攻打,此j可以是上一个状态交换AI的id而来也可以不是,状态转移方程: dp[i][j][0] = max (dp[i-1][j][0], dp[i-1][j][1]) * p[j][a[i]]; if (i > 1) dp[i][a[i-1]][

zoj 3735 概率dp

Josephina and RPG Time Limit: 2 Seconds      Memory Limit: 65536 KB      Special Judge A role-playing game (RPG and sometimes roleplaying game) is a game in which players assume the roles of characters in a fictional setting. Players take responsibil