hdu 1263 水果(map)

水果

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3831    Accepted Submission(s): 1433

Problem Description

夏天来了~~好开心啊,呵呵,好多好多水果~~

Joe经营着一个不大的水果店.他认为生存之道就是经营最受顾客欢迎的水果.现在他想要一份水果销售情况的明细表,这样Joe就可以很容易掌握所有水果的销售情况了.

Input

第一行正整数N(0<N<=10)表示有N组测试数据.

每组测试数据的第一行是一个整数M(0<M<=100),表示工有M次成功的交易.其后有M行数据,每行表示一次交易,由水果名称(小写字母组成,长度不超过80),水果产地(小写字母组成,长度不超过80)和交易的水果数目(正整数,不超过100)组成.

Output

对于每一组测试数据,请你输出一份排版格式正确(请分析样本输出)的水果销售情况明细表.这份明细表包括所有水果的产地,名称和销售数目的信息.水果先按产地分类,产地按字母顺序排列;同一产地的水果按照名称排序,名称按字母顺序排序.

两组测试数据之间有一个空行.最后一组测试数据之后没有空行.

Sample Input

1
5
apple shandong 3
pineapple guangdong 1
sugarcane guangdong 1
pineapple guangdong 3
pineapple guangdong 1

Sample Output

guangdong
   |----pineapple(5)
   |----sugarcane(1)
shandong
   |----apple(3)

Source

浙江工业大学第四届大学生程序设计竞赛

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1262 1265 1261 1257 1264

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<map>

#define N 100010
#define Mod 10000007
#define lson l,mid,idx<<1
#define rson mid+1,r,idx<<1|1
#define lc idx<<1
#define rc idx<<1|1
typedef long long ll;

const int INF = 1000010;

using namespace std;

int main()
{
    int t;
    while ( cin >> t )
    {
        while ( t-- )
        {
            int n;
            scanf ( "%d", &n );
            string a, b;
            int v;
            map<string, map<string, int> >mp;
            for ( int i = 0; i < n; i++ )
            {
                cin >> a >> b >> v;
                mp[b][a] += v;
            }
            map<string, map<string, int> >::iterator it;
            for ( it = mp.begin(); it != mp.end(); it++ )
            {
                cout << it->first << endl;
                map<string, int> :: iterator it2;
                for ( it2 = it->second.begin(); it2 != it->second.end(); it2++ )
                {
                    cout << "   |----" << it2->first << "(" << it2->second << ")" << endl;
                }
            }
            if ( t )
                cout << endl;
        }
    }
    return 0;
}
时间: 2024-10-29 19:09:41

hdu 1263 水果(map)的相关文章

题解报告:hdu 1263 水果

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1263 Problem Description 夏天来了~~好开心啊,呵呵,好多好多水果~~ Joe经营着一个不大的水果店.他认为生存之道就是经营最受顾客欢迎的水果.现在他想要一份水果销售情况的明细表,这样Joe就可以很容易掌握所有水果的销售情况了. Input 第一行正整数N(0<N<=10)表示有N组测试数据. 每组测试数据的第一行是一个整数M(0<M<=100),表示工有M次成功的

Hdu 1263 水果

水果 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 6986    Accepted Submission(s): 2748 Problem Description 夏天来了~~好开心啊,呵呵,好多好多水果~~Joe经营着一个不大的水果店.他认为生存之道就是经营最受顾客欢迎的水果.现在他想要一份水果销售情况的明细表,这样Joe就可以很容

hdu 1263 水果 sort对结构体中字符串二级排序

#include <stdio.h> #include <string.h> #include <algorithm> using namespace std; struct node { char name[90],place[90]; int num; }c[105]; bool cmp(node x,node y) { if(strcmp(x.place,y.place)<0) return true; if(strcmp(x.place,y.place)=

HDU 1263

第一次写map的嵌套 和less<>的排序 #include <map> #include <cstdio> #include <iostream> #include <string.h> #include <cstring> #include <string> using namespace std; map<string,map<string,int>,less<string> >

hdu 1800 (map)

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1800 Flying to the Mars Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 10830    Accepted Submission(s): 3472 Problem Description In the year 8888, t

hdoj 1263 水果(map)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1263 Input 第一行正整数N(0<N<=10)表示有N组测试数据.每组测试数据的第一行是一个整数M(0<M<=100),表示工有M次成功的交易.其后有M行数据,每行表示一次交易,由水果名称(小写字母组成,长度不超过80),水果产地(小写字母组成,长度不超过80)和交易的水果数目(正整数,不超过100)组成. Output 对于每一组测试数据,请你输出一份排版格式正确(请分析样本输出

HDU 1263 二维map

题意:给出一份水果的交易表,根据地区统计出水果的交易情况. 思路:二维map使用. #include<cstdio> #include<string> #include<map> #include<iostream> using namespace std; map<string,map<string,int> > m; map<string,map<string,int> >::iterator it; ma

G - 水果(HDU - 1263)

- 题目大意 将每个产地的水果种类和数量按照字典序输出. - 解题思路 利用一个二维的map容器将它的产地,品种,数目记录即可.(注意第一维以产地为键,水果为值,第二维以水果类型为键,水果数量为值,就可以自动按照字典序排序了.). - 代码 #include<iostream> #include<map> #include<string> using namespace std; int main() { int m, n; string nam, adr; int b

hdu 统计难题(map)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1251 map的强大之处,但是运行时间太长. 代码: 1 #include <stdio.h> 2 #include <string.h> 3 #include <math.h> 4 #include <algorithm> 5 #include <iostream> 6 #include <ctype.h> 7 #include <