HDU 1528 Card Game Cheater

Card Game Cheater

Problem Description

Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards face down in a row on the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for each i ∈ {1, . . . , k}):

If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.

If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.

A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.

If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit.

For example, the ten of spades beats the ten of diamonds but not the Jack of clubs.

This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders her own cards so that she gets as many points as possible.

Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally.

InputThere will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.

Each test case starts with a line with a single positive integer k <= 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line


TC 2H JD

Output

For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.

Sample Input

3

1

JD
JH

2

5D TC

4C 5H

3

2H 3H

4H
2D

3D 4D

Sample Output

1

1

2

#include<cstdio>
#include<cctype>
#include<cstring>
#include<vector>
#include<algorithm>
#define pb push_back
using namespace std;
bool cmp(char a,char b)
{
    if(isdigit(a))
    {
        if(isalpha(b))return 1;
        else return a<b;
    }
    else
    {
        if(isdigit(b))return 0;
        else
        {
            if(a==‘T‘)return 1;
            else if(a==‘J‘)
            {
                if(b==‘Q‘||b==‘K‘||b==‘A‘)return 1;
                else return 0;
            }
            else if(a==‘Q‘)
            {
                if(b==‘K‘||b==‘A‘)return 1;
                else return 0;
            }
            else if(a==‘K‘)
            {
                if(b==‘A‘)return 1;
                else return 0;
            }
            else return 0;
        }
    }
}
struct Card
{
    char val,suit;
    bool operator < (const Card& rhs)const
    {
        if(val!=rhs.val)return cmp(val,rhs.val);
        else
        {
            if(suit==‘C‘)return 1;
            else if(suit==‘D‘)
            {
                if(rhs.suit==‘S‘||rhs.suit==‘H‘)return 1;
                else return 0;
            }
            else if(suit==‘S‘)
            {
                if(rhs.suit==‘H‘)return 1;
                else return 0;
            }
            else return 0;
        }
    }
}c[2][26];
int k,link[26],vis[26];
vector<int>G[26];
bool dfs(int u)
{
    for(int len=G[u].size(),i=0;i<len;i++)
    {
        int v=G[u][i];
        if(!vis[v])
        {
            vis[v]=1;
            if(link[v]==-1||dfs(link[v]))
            {
                link[v]=u;
                return 1;
            }
        }
    }
    return 0;
}
int match()
{
    int ans=0;
    memset(link,-1,sizeof(link));
    for(int i=0;i<k;i++)
    {
        memset(vis,0,sizeof(vis));
        if(dfs(i))ans++;
    }
    return ans;
}
void create_graph()
{
    for(int i=0;i<k;i++)G[i].clear();
    for(int i=0;i<k;i++)
        for(int j=0;j<k;j++)
            if(c[0][i]<c[1][j])G[i].pb(j);
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&k);
        for(int i=0;i<k;i++)
        {
            getchar();
            scanf("%c%c",&c[0][i].val,&c[0][i].suit);
        }
        for(int i=0;i<k;i++)
        {
            getchar();
            scanf("%c%c",&c[1][i].val,&c[1][i].suit);
        }
        create_graph();
        printf("%d\n",match());
    }
    return 0;
}
时间: 2024-08-23 05:25:11

HDU 1528 Card Game Cheater的相关文章

HDU 1528 Card Game Cheater(打扑克)

Description: Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards fa

hdu 1528 Card Game Cheater (最小覆盖)

#include"stdio.h" #include"string.h" #define N 52 int map[N][N],v[N],link[N]; int A[N],B[N],t,n; int dfs(int k) { int i; for(i=1;i<=n;i++) { if(map[k][i]&&!v[i]) { v[i]=1; if(link[i]==0||dfs(link[i])) { link[i]=k; return 1;

HDOJ 1528 Card Game Cheater

简单二分图匹配.... Card Game Cheater Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 1073    Accepted Submission(s): 565 Problem Description Adam and Eve play a card game using a regular deck of 52 ca

HDOJ 题目1528 Card Game Cheater(二分图最小点覆盖)

Card Game Cheater Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 1357    Accepted Submission(s): 722 Problem Description Adam and Eve play a card game using a regular deck of 52 cards. The rul

(hdu step 6.3.5)Card Game Cheater(匹配的最大数:a与b打牌,问b赢a多少次)

称号: Card Game Cheater Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 103 Accepted Submission(s): 74   Problem Description Adam and Eve play a card game using a regular deck of 52 cards. The rules

(hdu step 6.3.5)Card Game Cheater(最大匹配数:a与b打牌,问b能赢a多少次)

题目: Card Game Cheater Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 103 Accepted Submission(s): 74   Problem Description Adam and Eve play a card game using a regular deck of 52 cards. The rules

HDU 1528 (二分图最大匹配 + 最小覆盖, 14.07.17)

Problem Description Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the c

hdu 6025 card card card(双指针)

题目链接:hdu 6025 card card card 题意: 有n对数(a,b),现在你可以将前x对(a,b)移到尾部. 操作完后,现在定义sum=ai-bi (1,x),当sum<0时,当前的价值为Σai (1<=i<=x-1). 问你移动前多少对(a,b),使得价值最大,如果有多个答案,输出最小的那个. 题解: 复制一份,双指针模拟一下就行了. 1 #include<bits/stdc++.h> 2 #define F(i,a,b) for(int i=a;i<

Card Game Cheater(贪心+二分匹配)

Card Game Cheater Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 1566    Accepted Submission(s): 822 Problem Description Adam and Eve play a card game using a regular deck of 52 cards. The rule