hdoj 1102 Constructing Roads

并查集+最小生成树

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15844    Accepted Submission(s):
6028

Problem Description

There are N villages, which are numbered from 1 to N,
and you should build some roads such that every two villages can connect to each
other. We say two village A and B are connected, if and only if there is a road
between A and B, or there exists a village C such that there is a road between A
and C, and C and B are connected.

We know that there are already some
roads between some villages and your job is the build some roads such that all
the villages are connect and the length of all the roads built is
minimum.

Input

The first line is an integer N (3 <= N <= 100),
which is the number of villages. Then come N lines, the i-th of which contains N
integers, and the j-th of these N integers is the distance (the distance should
be an integer within [1, 1000]) between village i and village j.

Then
there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each
line contains two integers a and b (1 <= a < b <= N), which means the
road between village a and village b has been built.

Output

You should output a line contains an integer, which is
the length of all the roads to be built such that all the villages are
connected, and this value is minimum.

Sample Input

3

0 990 692

990 0 179

692 179 0

1

1 2

Sample Output

179

题目的意思是  首先输入一个数n  代表城市的数量(既测试数据中的3)接下来n行数,每行n个数,设i=n;j=n则每一行数的意义为第i个城市与第j个城市之间的距离(如 第一行0  990 692 意思为第一个城市与第一个城市之间距离为0,第一个城市与第二个城市之间距离为990,第一个城市与第三个城市之间距离为 692)

附上AC代码

kruskal算法

#include<stdio.h>
#include<algorithm>
int set[110];
using namespace std;
struct record
{
	int a;
	int b;
	int ju;
}s[200000];
int find(int fa)
{
	int ch=fa;
	int t;
	while(fa!=set[fa])
	fa=set[fa];
	while(ch!=fa)
	{
		t=set[ch];
		set[ch]=fa;
		ch=t;
	}
	return fa;
}
void mix(int x,int y)
{
	int fx,fy;
	fx=find(x);
	fy=find(y);
	if(fx!=fy)
	set[fx]=fy;
}
bool cmp(record a,record b)
{
	return a.ju<b.ju;
}
int main()
{
	int n,m,j,i,sum,ju1,village,k,q,v1,v2;
	while(scanf("%d",&village)!=EOF)
	{
	    k=0;m=0;
	    for(i=0;i<=village;i++)
	    {
		    set[i]=i;
	    }
	    for(i=1;i<=village;i++)   //注意此处应从1开始,因为没有0号城市
	    {
		    for(j=1;j<=village;j++)
		    {
			    scanf("%d",&ju1);
			    if(j>i)      //此循环计入了所有的两个城市组合之间的距离
			    {             //以及对应城市编号
				    s[k].a=i;
				    s[k].b=j;
				    s[k].ju=ju1;
				    k++;
			    }
		    }
	    }
	    sort(s,s+k,cmp);
	    scanf("%d",&q);
	    for(i=0;i<q;i++)
	    {
		    scanf("%d%d",&v1,&v2);
		    mix(v1,v2);
	    }
	    sum=0;
	    for(i=0;i<k;i++)
	    {
		    if(find(s[i].a)!=find(s[i].b))
		    {
			    mix(s[i].a,s[i].b);
			    sum+=s[i].ju;
		    }
	    }
	    printf("%d\n",sum);
	}
	return 0;
}

  

时间: 2024-08-24 12:42:45

hdoj 1102 Constructing Roads的相关文章

HDU 1102 Constructing Roads, Prim+优先队列

题目链接:HDU 1102 Constructing Roads Constructing Roads Problem Description There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are conne

hdu 1102 Constructing Roads (Prim算法)

题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=1102 Constructing Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 21947    Accepted Submission(s): 8448 Problem Description There are N villa

HDU 1102 Constructing Roads (最小生成树)

最小生成树模板(嗯……在kuangbin模板里面抄的……) 最小生成树(prim) /** Prim求MST * 耗费矩阵cost[][],标号从0开始,0~n-1 * 返回最小生成树的权值,返回-1表示原图不连通 */ const int INF = 0x3f3f3f3f; const int MAXN = 110; bool vis[MAXN]; int lowc[MAXN]; int map[MAXN][MAXN]; int Prim(int cost[][MAXN], int n) {

hdu 1102 Constructing Roads (最小生成树)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1102 Constructing Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 14172    Accepted Submission(s): 5402 Problem Description There are N villa

hust 1102 Constructing Roads

Problem Description There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B

hdoj 1025 Constructing Roads In JGShining&amp;#39;s Kingdom 【最长递增子序列】

Constructing Roads In JGShining's Kingdom Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16262    Accepted Submission(s): 4633 Problem Description JGShining's kingdom consists of 2n(n is no mo

HDU 1102 Constructing Roads (裸的并查集)

Constructing Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 13210    Accepted Submission(s): 4995 Problem Description There are N villages, which are numbered from 1 to N, and you should

hdoj 1025 Constructing Roads In JGShining&#39;s Kingdom 【最长递增子序列】

Constructing Roads In JGShining's Kingdom Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16262    Accepted Submission(s): 4633 Problem Description JGShining's kingdom consists of 2n(n is no mo

hdu 1102 Constructing Roads Kruscal

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1102 题意:这道题实际上和hdu 1242 Rescue 非常相似,改变了输入方式之后, 本题实际上更适合用Prim来做. 用Kruscal的话要做一些变化. /*Constructing Roads Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s)