POJ1505&&UVa714 Copying Books(DP)

Copying Books

Time Limit: 3000MS Memory Limit: 10000K
Total Submissions: 7109 Accepted: 2221

Description

Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been
given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed
it up was to hire more scribers.

Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books.
Imagine you have m books (numbered 1, 2 ... m) that may have different number of pages (p1, p2 ... pm) and you want to make one copy of each of them. Your task is to divide these books among k scribes, k <= m. Each book can be assigned to a single scriber
only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers 0 = b0 < b1 < b2, ... < bk-1 <= bk = m such that i-th scriber gets a sequence of books with numbers between bi-1+1 and
bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line,
there are two integers m and k, 1 <= k <= m <= 500. At the second line, there are integers p1, p2, ... pm separated by spaces. All these values are positive and less than 10000000.

Output

For each case, print exactly one line. The line must contain the input succession p1, p2, ... pm divided into exactly k parts such that the maximum sum of a single part should
be as small as possible. Use the slash character (‘/‘) to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash.

If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.

Sample Input

2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100

Sample Output

100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100

Source

Central Europe 1998

题意  k个人复制m本书  求最小的时间   即把m个数分成k份  使和最大的那份最小

d[i][j]表示i个人完成前j本书需要的时间  有转移方程d[i][j]=min(d[i][j],max(d[i-1][k],s[j]-s[k]))  k表示i-1到j之间的所有数  s[k]表示从第一本书到第k本书需要时间的和  初始d[1][i]=s[i];

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 550, INF = 0x3f3f3f3f;
int a[N], flag[N], s[N],  d[N][N], t, cas, n, m, ans;
int dp (int i, int j)
{
    if (d[i][j] > 0) return d[i][j];
    d[i][j] = INF;
    for (int k = i - 1; k < j; ++k)
        d[i][j] = min (d[i][j], max (dp (i - 1, k), s[j] - s[k]));
    return d[i][j];
}

int main()
{
    scanf ("%d", &cas);
    while (cas--)
    {
        scanf ("%d%d", &n, &m);
        memset (d, -1, sizeof (d));  memset (flag, -1, sizeof (flag));
        for (int i = 1; i <= n; ++i)
        { scanf ("%d", &a[i]); d[1][i] = s[i] = s[i - 1] + a[i]; }
        ans = dp (m, n);

        for (int i = n,t=0 ; i >= 1; --i)
            if ( ( (t = t + a[i]) > ans) || m > i)
                {  t = a[i]; flag[i] = 0; --m; }
        for (int i = 1; i <= n; ++i)
        {
            printf (flag[i] ? "%d" : "%d /", a[i]);
            printf (i == n ? "\n" : " ");
        }
    }
    return 0;
}

POJ1505&&UVa714 Copying Books(DP)

时间: 2024-10-09 14:05:57

POJ1505&&UVa714 Copying Books(DP)的相关文章

uva714 - Copying Books(最大值最小化)

题目:uva714 - Copying Books(最大值最小化) 题目大意:给出n本书,每本书的值代表这本书的页数.然后给定m个scribers,每个scriber至少要抄一本书,或者连续的几本书.每个scriber的工作量就等于他要抄的书的页数之和.问怎样划分能使的scribers中工作量的最大值最小.这里要求答案如果有多种的话就输出前面的和比较小的那个划分. 解题思路:最大值最小化问题. 二分尝试可能的最大值,然后如果在这个最大值的情况下可以划分的话,说明最大值可能是这个值,也可能更小.如

UVa714 Copying Books (二分法,贪心)

链接:http://vjudge.net/problem/UVA-714 分析:二分枚举最小值,用贪心的思想每段序列尽量往右划分,注意:因为要求字典序最小解,输出时还有一个贪心过程,左起S[i]尽量小,相当于右起S[j]尽量大,还有一种情况是剩下的数之和已经小于等于ans,但是此时剩余要分配的组数还有多(remain>1). 1 #include <cstdio> 2 #include <algorithm> 3 #include <cstring> 4 usin

uva714 Copying Books

#include<bits/stdc++.h> #define REP(i,a,b) for(int i=a;i<=b;i++) #define MS0(a) memset(a,0,sizeof(a)) using namespace std; typedef long long ll; const int maxn=1000100; const int INF=1<<29; int n,k; ll a[maxn]; int ans[maxn],tmp[maxn]; ll M

poj 1505 Copying Books

http://poj.org/problem?id=1505 Copying Books Time Limit: 3000MS   Memory Limit: 10000K Total Submissions: 7053   Accepted: 2200 Description Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be r

Copying Books

Copying Books 给出一个长度为m的序列\(\{a_i\}\),将其划分成k个区间,求区间和的最大值的最小值对应的方案,多种方案,则按从左到右的区间长度尽可能小(也就是从左到右区间长度构成的序列的字典序最小),\(m,k\leq 500\). 解 显然最大值的最小值想到二分,其实dp也可以,因为区间划分问题有可递推性,而且它能求出答案. 二分一个东西就等于换时间复杂度增加个\(log(n)\)增加了一个已知条件,虽然前提是单调性,但不妨以后缺少条件,先考虑二分再找单调性. 我们二分\(

uva 714 Copying Books (二分)

uva 714 Copying Books Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its co

uva 714 - Copying Books(贪心 最大值最小化 二分)

题目描述开头一大堆屁话,我还仔细看了半天..其实就最后2句管用.意思就是给出n本书然后要分成k份,每份总页数的最大值要最小.问你分配方案,如果最小值相同情况下有多种分配方案,输出前面份数小的,就像字典序输出从小到大一样的意思. 这里用到贪心的方法,定义f(x)为真的条件是满足x为最大值使n本书分成k份,那么就是求x的最小值.如何确定这个x就是用的二分法,x一定大于0小于所有值的合,不断的二分再判断是否成立,成立就取左半边,不成立说明太小了就取右半边,写的时候还是没有把二分法理解透彻,我还怕会丢失

UVa 714 Copying Books(贪心 二分)

题意  把m数分成k组  使每组数的和的最大值最小  如果有多种分法 靠前的组的和尽量小 关键是找出那个最小的最大值   可以通过二分来找出  开始左端点为m个数中最大的数  右端点为m个数的和  若中点能将m个数分为小于等于k组  比它大的肯定都是可以的  中点变为右端点   否则中点变成左端点 然后就可以贪心逆向模拟了  从后往前每组选择尽量多的数直到剩下的数等于组数 #include <bits/stdc++.h> using namespace std; typedef long lo

POJ 1505 (Copying Books)(经典二分)

Description Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its copy. One of